diff options
author | Yogesh Tyagi <yogesh.tyagi@intel.com> | 2024-10-22 15:07:25 +0530 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2024-10-22 20:09:40 +0800 |
commit | 7d826adfe783a601df593afface01877de739bfd (patch) | |
tree | 93a466019c823566021e0e024dbf812b07bbfb7a | |
parent | 51cc236453f370e7a3ab624e61e3157a6ae3c7fe (diff) | |
download | meta-intel-7d826adfe783a601df593afface01877de739bfd.tar.gz |
ipmctl : upgrade 03.00.00.0485 -> 03.00.00.0499
Refresh patch 0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch
Release Notes:
ipmctl:
https://github.com/intel/ipmctl/releases/tag/v03.00.00.0499
Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch | 43 | ||||
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0499.bb (renamed from dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0485.bb) | 8 |
2 files changed, 27 insertions, 24 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch index 11305e83..8a734ed2 100644 --- a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch +++ b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl/0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch | |||
@@ -6,10 +6,10 @@ Signed-off-by: Teoh Suh Haw <suh.haw.teoh@intel.com> | |||
6 | MdePkg/Include/Base.h | 12 ++++++++++++ | 6 | MdePkg/Include/Base.h | 12 ++++++++++++ |
7 | 1 file changed, 12 insertions(+) | 7 | 1 file changed, 12 insertions(+) |
8 | 8 | ||
9 | diff --git a/MdePkg/Include/Base.h b/MdePkg/Include/Base.h | 9 | Index: edk2/MdePkg/Include/Base.h |
10 | index d209e6de28..6e61b8f3d3 100644 | 10 | =================================================================== |
11 | --- a/MdePkg/Include/Base.h | 11 | --- edk2.orig/MdePkg/Include/Base.h |
12 | +++ b/MdePkg/Include/Base.h | 12 | +++ edk2/MdePkg/Include/Base.h |
13 | @@ -316,8 +316,12 @@ struct _LIST_ENTRY { | 13 | @@ -316,8 +316,12 @@ struct _LIST_ENTRY { |
14 | #define NULL __null | 14 | #define NULL __null |
15 | #endif | 15 | #endif |
@@ -20,40 +20,43 @@ index d209e6de28..6e61b8f3d3 100644 | |||
20 | #endif | 20 | #endif |
21 | +#endif | 21 | +#endif |
22 | +#endif | 22 | +#endif |
23 | 23 | ||
24 | // | 24 | // |
25 | // Null character | 25 | // Null character |
26 | @@ -779,6 +783,8 @@ typedef UINTN *BASE_LIST; | 26 | @@ -813,6 +817,8 @@ typedef UINTN *BASE_LIST; |
27 | // Section 2.3.1 of the UEFI 2.3 Specification. | 27 | // Section 2.3.1 of the UEFI 2.3 Specification. |
28 | // | 28 | // |
29 | 29 | ||
30 | +#ifndef OS_BUILD | 30 | +#ifndef OS_BUILD |
31 | +#ifndef UNIT_TEST_UEFI_BUILD | 31 | +#ifndef UNIT_TEST_UEFI_BUILD |
32 | STATIC_ASSERT (sizeof (BOOLEAN) == 1, "sizeof (BOOLEAN) does not meet UEFI Specification Data Type requirements"); | 32 | STATIC_ASSERT (sizeof (BOOLEAN) == 1, "sizeof (BOOLEAN) does not meet UEFI Specification Data Type requirements"); |
33 | STATIC_ASSERT (sizeof (INT8) == 1, "sizeof (INT8) does not meet UEFI Specification Data Type requirements"); | 33 | STATIC_ASSERT (sizeof (INT8) == 1, "sizeof (INT8) does not meet UEFI Specification Data Type requirements"); |
34 | STATIC_ASSERT (sizeof (UINT8) == 1, "sizeof (UINT8) does not meet UEFI Specification Data Type requirements"); | 34 | STATIC_ASSERT (sizeof (UINT8) == 1, "sizeof (UINT8) does not meet UEFI Specification Data Type requirements"); |
35 | @@ -792,6 +798,8 @@ STATIC_ASSERT (sizeof (CHAR8) == 1, "sizeof (CHAR8) does not meet UEFI Specifi | 35 | @@ -841,7 +847,8 @@ STATIC_ASSERT (ALIGNOF (CHAR16) == size |
36 | STATIC_ASSERT (sizeof (CHAR16) == 2, "sizeof (CHAR16) does not meet UEFI Specification Data Type requirements"); | 36 | STATIC_ASSERT (ALIGNOF (INTN) == sizeof (INTN), "Alignment of INTN does not meet UEFI Specification Data Type requirements"); |
37 | STATIC_ASSERT (sizeof (L'A') == 2, "sizeof (L'A') does not meet UEFI Specification Data Type requirements"); | 37 | STATIC_ASSERT (ALIGNOF (UINTN) == sizeof (UINTN), "Alignment of UINTN does not meet UEFI Specification Data Type requirements"); |
38 | STATIC_ASSERT (sizeof (L"A") == 4, "sizeof (L\"A\") does not meet UEFI Specification Data Type requirements"); | 38 | STATIC_ASSERT (ALIGNOF (VOID *) == sizeof (VOID *), "Alignment of VOID * does not meet UEFI Specification Data Type requirements"); |
39 | - | ||
39 | +#endif | 40 | +#endif |
40 | +#endif | 41 | +#endif |
41 | |||
42 | // | 42 | // |
43 | // The following three enum types are used to verify that the compiler | 43 | // The following three enum types are used to verify that the compiler |
44 | @@ -812,9 +820,13 @@ typedef enum { | 44 | // configuration for enum types is compliant with Section 2.3.1 of the |
45 | __VerifyUint32EnumValue = 0xffffffff | 45 | @@ -861,6 +868,8 @@ typedef enum { |
46 | } __VERIFY_UINT32_ENUM_SIZE; | 46 | __VerifyInt32EnumValue = 0x7fffffff |
47 | 47 | } __VERIFY_INT32_ENUM_SIZE; | |
48 | |||
48 | +#ifndef OS_BUILD | 49 | +#ifndef OS_BUILD |
49 | +#ifndef UNIT_TEST_UEFI_BUILD | 50 | +#ifndef UNIT_TEST_UEFI_BUILD |
50 | STATIC_ASSERT (sizeof (__VERIFY_UINT8_ENUM_SIZE) == 4, "Size of enum does not meet UEFI Specification Data Type requirements"); | 51 | STATIC_ASSERT (sizeof (__VERIFY_UINT8_ENUM_SIZE) == 4, "Size of enum does not meet UEFI Specification Data Type requirements"); |
51 | STATIC_ASSERT (sizeof (__VERIFY_UINT16_ENUM_SIZE) == 4, "Size of enum does not meet UEFI Specification Data Type requirements"); | 52 | STATIC_ASSERT (sizeof (__VERIFY_UINT16_ENUM_SIZE) == 4, "Size of enum does not meet UEFI Specification Data Type requirements"); |
52 | STATIC_ASSERT (sizeof (__VERIFY_UINT32_ENUM_SIZE) == 4, "Size of enum does not meet UEFI Specification Data Type requirements"); | 53 | STATIC_ASSERT (sizeof (__VERIFY_INT32_ENUM_SIZE) == 4, "Size of enum does not meet UEFI Specification Data Type requirements"); |
54 | @@ -868,6 +877,8 @@ STATIC_ASSERT (sizeof (__VERIFY_INT32_EN | ||
55 | STATIC_ASSERT (ALIGNOF (__VERIFY_UINT8_ENUM_SIZE) == sizeof (__VERIFY_UINT8_ENUM_SIZE), "Alignment of enum does not meet UEFI Specification Data Type requirements"); | ||
56 | STATIC_ASSERT (ALIGNOF (__VERIFY_UINT16_ENUM_SIZE) == sizeof (__VERIFY_UINT16_ENUM_SIZE), "Alignment of enum does not meet UEFI Specification Data Type requirements"); | ||
57 | STATIC_ASSERT (ALIGNOF (__VERIFY_INT32_ENUM_SIZE) == sizeof (__VERIFY_INT32_ENUM_SIZE), "Alignment of enum does not meet UEFI Specification Data Type requirements"); | ||
53 | +#endif | 58 | +#endif |
54 | +#endif | 59 | +#endif |
55 | 60 | ||
56 | /** | 61 | /** |
57 | Macro that returns a pointer to the data structure that contains a specified field of | 62 | Macro that returns a pointer to the data structure that contains a specified field of |
58 | -- | ||
59 | 2.37.3 | ||
diff --git a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0485.bb b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0499.bb index c4743d1c..695e29e9 100644 --- a/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0485.bb +++ b/dynamic-layers/openembedded-layer/recipes-support/ipmctl/ipmctl_03.00.00.0499.bb | |||
@@ -15,15 +15,15 @@ LICENSE = "BSD-3-Clause | BSD-2-Clause" | |||
15 | LIC_FILES_CHKSUM = "file://LICENSE;md5=72b9da60da6219d612ce30b746a0fe71 \ | 15 | LIC_FILES_CHKSUM = "file://LICENSE;md5=72b9da60da6219d612ce30b746a0fe71 \ |
16 | file://edk2/License.txt;md5=6123e5bf044a66db96c4ce88a36b2d08" | 16 | file://edk2/License.txt;md5=6123e5bf044a66db96c4ce88a36b2d08" |
17 | 17 | ||
18 | SRC_URI = "git://github.com/intel/ipmctl.git;protocol=https;branch=master;name=ipmctl; \ | 18 | SRC_URI = "git://github.com/intel/ipmctl.git;protocol=https;branch=master_3_0;name=ipmctl; \ |
19 | git://github.com/tianocore/edk2.git;protocol=https;name=edk2;destsuffix=git/edk2;branch=master \ | 19 | git://github.com/tianocore/edk2.git;protocol=https;name=edk2;destsuffix=git/edk2;branch=master \ |
20 | file://0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch;patchdir=edk2 \ | 20 | file://0001-Ignore-STATIC_ASSERTs-and-NULL-define-for-os-and-ut-builds.patch;patchdir=edk2 \ |
21 | file://0001-CMakeLists-disable-Werror.patch \ | 21 | file://0001-CMakeLists-disable-Werror.patch \ |
22 | " | 22 | " |
23 | 23 | ||
24 | SRCREV_ipmctl = "c75bd840ea7820c8f93a5488fcff75d08beedd51" | 24 | SRCREV_ipmctl = "a71f2fb1c90dd07f9862b71c789881132193e8f9" |
25 | #tag edk2-stable202302 | 25 | #tag edk2-stable202408 |
26 | SRCREV_edk2 = "f80f052277c88a67c55e107b550f504eeea947d3" | 26 | SRCREV_edk2 = "b158dad150bf02879668f72ce306445250838201" |
27 | SRCREV_FORMAT = "ipmctl_edk2" | 27 | SRCREV_FORMAT = "ipmctl_edk2" |
28 | 28 | ||
29 | S = "${WORKDIR}/git" | 29 | S = "${WORKDIR}/git" |