summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2024-10-08 10:04:11 +0530
committerAnuj Mittal <anuj.mittal@intel.com>2024-10-10 09:15:57 +0800
commita38d69ee3d9cea8440768394642c0d99e527726c (patch)
tree6efa25b89b01258fe070c5121c78b0a4bb4f5aed
parent945c5bbb80c4c480c563f6ddd5a9e7acd5ad713e (diff)
downloadmeta-intel-a38d69ee3d9cea8440768394642c0d99e527726c.tar.gz
linux-intel/6.11 : update to tag mainline-tracking-pre-prod-v6.11-linux-240925T085433Z
* Drop recipe for 6.10 kernel * Drop the patch 0001-6.10-vt-conmakehash-improve-reproducibility.patch * Add recipe for 6.11 kernel Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-kernel/linux/linux-intel/0001-6.10-vt-conmakehash-improve-reproducibility.patch58
-rw-r--r--recipes-kernel/linux/linux-intel/0001-6.11-lib-build_OID_registry-fix-reproducibility-issues.patch (renamed from recipes-kernel/linux/linux-intel/0001-6.10-lib-build_OID_registry-fix-reproducibility-issues.patch)0
-rw-r--r--recipes-kernel/linux/linux-intel_6.11.bb (renamed from recipes-kernel/linux/linux-intel_6.10.bb)13
3 files changed, 6 insertions, 65 deletions
diff --git a/recipes-kernel/linux/linux-intel/0001-6.10-vt-conmakehash-improve-reproducibility.patch b/recipes-kernel/linux/linux-intel/0001-6.10-vt-conmakehash-improve-reproducibility.patch
deleted file mode 100644
index fd89af6c..00000000
--- a/recipes-kernel/linux/linux-intel/0001-6.10-vt-conmakehash-improve-reproducibility.patch
+++ /dev/null
@@ -1,58 +0,0 @@
1From 5635e0677692bc502588b09d04f138394e02669b Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Sun, 10 Jul 2022 21:37:07 -0400
4Subject: [PATCH] vt/conmakehash: improve reproducibility
5
6The file generated by conmakehash capture the application
7path used to generate the file. While that can be informative,
8it varies based on where the kernel was built, as the full
9path is captured.
10
11We tweak the application to use a second input as the "capture
12name", and then modify the Makefile to pass the basename of
13the source, making it reproducible.
14
15This could be improved by using some sort of path mapping,
16or the application manipualing argv[1] itself, but for now
17this solves the reprodicibility issue.
18
19Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
20
21Upstream-Status: Inappropriate
22
23Taken from linux-yocto, v5.15/standard/base
24Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
25---
26 drivers/tty/vt/Makefile | 2 +-
27 drivers/tty/vt/conmakehash.c | 2 +-
28 2 files changed, 2 insertions(+), 2 deletions(-)
29
30diff --git a/drivers/tty/vt/Makefile b/drivers/tty/vt/Makefile
31index 2c8ce8b592ed..8532077ed3bb 100644
32--- a/drivers/tty/vt/Makefile
33+++ b/drivers/tty/vt/Makefile
34@@ -15,7 +15,7 @@ clean-files := consolemap_deftbl.c defkeymap.c
35 hostprogs += conmakehash
36
37 quiet_cmd_conmk = CONMK $@
38- cmd_conmk = $(obj)/conmakehash $< > $@
39+ cmd_conmk = $(obj)/conmakehash $< $(shell basename $<) > $@
40
41 $(obj)/consolemap_deftbl.c: $(src)/$(FONTMAPFILE) $(obj)/conmakehash
42 $(call cmd,conmk)
43diff --git a/drivers/tty/vt/conmakehash.c b/drivers/tty/vt/conmakehash.c
44index dc2177fec715..9df2198c459b 100644
45--- a/drivers/tty/vt/conmakehash.c
46+++ b/drivers/tty/vt/conmakehash.c
47@@ -264,7 +264,7 @@ int main(int argc, char *argv[])
48 #include <linux/types.h>\n\
49 \n\
50 u8 dfont_unicount[%d] = \n\
51-{\n\t", rel_tblname, fontlen);
52+{\n\t", argv[2], fontlen);
53
54 for ( i = 0 ; i < fontlen ; i++ )
55 {
56--
572.34.1
58
diff --git a/recipes-kernel/linux/linux-intel/0001-6.10-lib-build_OID_registry-fix-reproducibility-issues.patch b/recipes-kernel/linux/linux-intel/0001-6.11-lib-build_OID_registry-fix-reproducibility-issues.patch
index df2a4139..df2a4139 100644
--- a/recipes-kernel/linux/linux-intel/0001-6.10-lib-build_OID_registry-fix-reproducibility-issues.patch
+++ b/recipes-kernel/linux/linux-intel/0001-6.11-lib-build_OID_registry-fix-reproducibility-issues.patch
diff --git a/recipes-kernel/linux/linux-intel_6.10.bb b/recipes-kernel/linux/linux-intel_6.11.bb
index c6e5cf1c..2e9c9d99 100644
--- a/recipes-kernel/linux/linux-intel_6.10.bb
+++ b/recipes-kernel/linux/linux-intel_6.11.bb
@@ -2,10 +2,9 @@ require linux-intel.inc
2 2
3SRC_URI:prepend = "git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \ 3SRC_URI:prepend = "git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \
4 " 4 "
5SRC_URI:append = " file://0001-6.10-vt-conmakehash-improve-reproducibility.patch \ 5SRC_URI:append = " file://0001-6.11-lib-build_OID_registry-fix-reproducibility-issues.patch \
6 file://0001-6.10-lib-build_OID_registry-fix-reproducibility-issues.patch \
7 " 6 "
8KMETA_BRANCH = "yocto-6.10" 7KMETA_BRANCH = "master"
9 8
10LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 9LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
11 10
@@ -13,13 +12,13 @@ DEPENDS += "elfutils-native openssl-native util-linux-native"
13 12
14LINUX_VERSION_EXTENSION ??= "-mainline-tracking-${LINUX_KERNEL_TYPE}" 13LINUX_VERSION_EXTENSION ??= "-mainline-tracking-${LINUX_KERNEL_TYPE}"
15 14
16LINUX_VERSION ?= "6.10" 15LINUX_VERSION ?= "6.11"
17SRCREV_machine ?= "37b6bf1243b894e0da6e640e589d479f3208f5ae" 16SRCREV_machine ?= "9a961f4b0a6a2655ef37e86b8588f2946b427650"
18SRCREV_meta ?= "e4d2ade39f231ea279f19298c008ba48f4a202e5" 17SRCREV_meta ?= "5b42ba3f7fd0bb7b15d194871152f3b1a30f3926"
19 18
20# Functionality flags 19# Functionality flags
21KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc \ 20KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc \
22 features/security/security.scc \ 21 features/security/security.scc \
23 features/intel-npu/intel-npu.scc" 22 features/intel-npu/intel-npu.scc"
24 23
25UPSTREAM_CHECK_GITTAGREGEX = "^mainline-tracking-v6.10-linux-(?P<pver>(\d+)T(\d+)Z)$" 24UPSTREAM_CHECK_GITTAGREGEX = "^mainline-tracking-v6.11-linux-(?P<pver>(\d+)T(\d+)Z)$"