diff options
author | Yogesh Tyagi <yogesh.tyagi@intel.com> | 2024-09-13 14:15:44 +0530 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2024-09-13 16:50:47 +0800 |
commit | c2bc8e27e9cc83654a23e8d89525fd9b1e781eb6 (patch) | |
tree | 84ea09651f8453397d1c6ef9c511e277f4e30c7a | |
parent | bcad39140f02a3a0d932f50fbc4b7319d039b171 (diff) | |
download | meta-intel-c2bc8e27e9cc83654a23e8d89525fd9b1e781eb6.tar.gz |
linux-intel/6.8 : Move the patches specific to kernel 6.8 to the recipe
* Refresh patches
Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
3 files changed, 110 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel/0001-6.8-lib-build_OID_registry-fix-reproducibility-issues.patch b/recipes-kernel/linux/linux-intel/0001-6.8-lib-build_OID_registry-fix-reproducibility-issues.patch new file mode 100644 index 00000000..313e5dae --- /dev/null +++ b/recipes-kernel/linux/linux-intel/0001-6.8-lib-build_OID_registry-fix-reproducibility-issues.patch | |||
@@ -0,0 +1,48 @@ | |||
1 | From 5e919368eaabcfbd91e8d61922849dc37622cea0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Sun, 10 Jul 2022 22:56:53 -0400 | ||
4 | Subject: [PATCH 2/2] lib/build_OID_registry: fix reproducibility issues | ||
5 | |||
6 | The script build_OID_registry captures the full path of itself | ||
7 | in the generated data. This causes reproduciblity issues as the | ||
8 | path is captured and packaged. | ||
9 | |||
10 | We use the basename of the script instead, and that allows us | ||
11 | to be reprodicible, with slightly less information captured in | ||
12 | the output data (but the generating script can still easily | ||
13 | be found). | ||
14 | |||
15 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
16 | Upstream-Status: Inappropriate | ||
17 | |||
18 | Taken from linux-yocto, v5.15/standard/base. | ||
19 | |||
20 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
21 | --- | ||
22 | lib/build_OID_registry | 3 ++- | ||
23 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
24 | |||
25 | diff --git a/lib/build_OID_registry b/lib/build_OID_registry | ||
26 | index d7fc32ea8ac2..f6de0a7f7457 100755 | ||
27 | --- a/lib/build_OID_registry | ||
28 | +++ b/lib/build_OID_registry | ||
29 | @@ -8,6 +8,7 @@ | ||
30 | # | ||
31 | |||
32 | use strict; | ||
33 | +use File::Basename; | ||
34 | |||
35 | my @names = (); | ||
36 | my @oids = (); | ||
37 | @@ -35,7 +36,7 @@ close IN_FILE || die; | ||
38 | # | ||
39 | open C_FILE, ">$ARGV[1]" or die; | ||
40 | print C_FILE "/*\n"; | ||
41 | -print C_FILE " * Automatically generated by ", $0, ". Do not edit\n"; | ||
42 | +print C_FILE " * Automatically generated by ", basename $0, ". Do not edit\n"; | ||
43 | print C_FILE " */\n"; | ||
44 | |||
45 | # | ||
46 | -- | ||
47 | 2.34.1 | ||
48 | |||
diff --git a/recipes-kernel/linux/linux-intel/0001-6.8-vt-conmakehash-improve-reproducibility.patch b/recipes-kernel/linux/linux-intel/0001-6.8-vt-conmakehash-improve-reproducibility.patch new file mode 100644 index 00000000..1fac9432 --- /dev/null +++ b/recipes-kernel/linux/linux-intel/0001-6.8-vt-conmakehash-improve-reproducibility.patch | |||
@@ -0,0 +1,58 @@ | |||
1 | From 5173c844a7814d0bc6f54cc75bb33e033b08e88c Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Sun, 10 Jul 2022 21:37:07 -0400 | ||
4 | Subject: [PATCH 1/2] vt/conmakehash: improve reproducibility | ||
5 | |||
6 | The file generated by conmakehash capture the application | ||
7 | path used to generate the file. While that can be informative, | ||
8 | it varies based on where the kernel was built, as the full | ||
9 | path is captured. | ||
10 | |||
11 | We tweak the application to use a second input as the "capture | ||
12 | name", and then modify the Makefile to pass the basename of | ||
13 | the source, making it reproducible. | ||
14 | |||
15 | This could be improved by using some sort of path mapping, | ||
16 | or the application manipualing argv[1] itself, but for now | ||
17 | this solves the reprodicibility issue. | ||
18 | |||
19 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
20 | |||
21 | Upstream-Status: Inappropriate | ||
22 | |||
23 | Taken from linux-yocto, v5.15/standard/base | ||
24 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
25 | --- | ||
26 | drivers/tty/vt/Makefile | 2 +- | ||
27 | drivers/tty/vt/conmakehash.c | 2 +- | ||
28 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
29 | |||
30 | diff --git a/drivers/tty/vt/Makefile b/drivers/tty/vt/Makefile | ||
31 | index b3dfe9d5717e..6ee3736776c8 100644 | ||
32 | --- a/drivers/tty/vt/Makefile | ||
33 | +++ b/drivers/tty/vt/Makefile | ||
34 | @@ -15,7 +15,7 @@ clean-files := consolemap_deftbl.c defkeymap.c | ||
35 | hostprogs += conmakehash | ||
36 | |||
37 | quiet_cmd_conmk = CONMK $@ | ||
38 | - cmd_conmk = $(obj)/conmakehash $< > $@ | ||
39 | + cmd_conmk = $(obj)/conmakehash $< $(shell basename $<) > $@ | ||
40 | |||
41 | $(obj)/consolemap_deftbl.c: $(src)/$(FONTMAPFILE) $(obj)/conmakehash | ||
42 | $(call cmd,conmk) | ||
43 | diff --git a/drivers/tty/vt/conmakehash.c b/drivers/tty/vt/conmakehash.c | ||
44 | index cddd789fe46e..d62510b280e9 100644 | ||
45 | --- a/drivers/tty/vt/conmakehash.c | ||
46 | +++ b/drivers/tty/vt/conmakehash.c | ||
47 | @@ -253,7 +253,7 @@ int main(int argc, char *argv[]) | ||
48 | #include <linux/types.h>\n\ | ||
49 | \n\ | ||
50 | u8 dfont_unicount[%d] = \n\ | ||
51 | -{\n\t", argv[1], fontlen); | ||
52 | +{\n\t", argv[2], fontlen); | ||
53 | |||
54 | for ( i = 0 ; i < fontlen ; i++ ) | ||
55 | { | ||
56 | -- | ||
57 | 2.34.1 | ||
58 | |||
diff --git a/recipes-kernel/linux/linux-intel_6.8.bb b/recipes-kernel/linux/linux-intel_6.8.bb index 30343357..dccda073 100644 --- a/recipes-kernel/linux/linux-intel_6.8.bb +++ b/recipes-kernel/linux/linux-intel_6.8.bb | |||
@@ -2,6 +2,10 @@ require linux-intel.inc | |||
2 | 2 | ||
3 | SRC_URI:prepend = "git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \ | 3 | SRC_URI:prepend = "git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \ |
4 | " | 4 | " |
5 | SRC_URI:append = " file://0001-6.8-vt-conmakehash-improve-reproducibility.patch \ | ||
6 | file://0001-6.8-lib-build_OID_registry-fix-reproducibility-issues.patch \ | ||
7 | " | ||
8 | |||
5 | KMETA_BRANCH = "master" | 9 | KMETA_BRANCH = "master" |
6 | 10 | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" | 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" |