summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2025-03-09 21:15:56 +0530
committerAnuj Mittal <anuj.mittal@intel.com>2025-03-10 10:02:28 +0800
commitcb85578bf32caee74a8bbad0174eb96aecba8272 (patch)
tree408f47f0f650085c58b1a360ab2f3b7ec2439d3d
parent8bd6506e1efbcf8fe3e6cf7ffc88ca6900cc27e6 (diff)
downloadmeta-intel-cb85578bf32caee74a8bbad0174eb96aecba8272.tar.gz
linux-intel-rt/6.12: Adapt 6.6-rt recipe for 6.12-rt
* Use LTS 6.12 for RT as well, as 6.12 now has a single branch for both RT and non-RT kernels. * Rename the patch: linux-intel/0001-6.11-6.12-lib-build_OID_registry-fix-reproducibility-issues.patch * Drop the following patches, as they were specific to the 6.6 kernel: 0001-6.6-lib-build_OID_registry-fix-reproducibility-issues.patch 0001-6.6-vt-conmakehash-improve-reproducibility.patch Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--recipes-kernel/linux/linux-intel-rt_6.12.bb (renamed from recipes-kernel/linux/linux-intel-rt_6.6.bb)15
-rw-r--r--recipes-kernel/linux/linux-intel/0001-6.12-lib-build_OID_registry-fix-reproducibility-issues.patch (renamed from recipes-kernel/linux/linux-intel/0001-6.11-6.12-lib-build_OID_registry-fix-reproducibility-issues.patch)0
-rw-r--r--recipes-kernel/linux/linux-intel/0001-6.6-lib-build_OID_registry-fix-reproducibility-issues.patch39
-rw-r--r--recipes-kernel/linux/linux-intel/0001-6.6-vt-conmakehash-improve-reproducibility.patch58
4 files changed, 7 insertions, 105 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_6.6.bb b/recipes-kernel/linux/linux-intel-rt_6.12.bb
index 06c29e61..139d4c91 100644
--- a/recipes-kernel/linux/linux-intel-rt_6.6.bb
+++ b/recipes-kernel/linux/linux-intel-rt_6.12.bb
@@ -2,8 +2,7 @@ require linux-intel.inc
2 2
3SRC_URI:prepend = "git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \ 3SRC_URI:prepend = "git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \
4 " 4 "
5SRC_URI:append = " file://0001-6.6-vt-conmakehash-improve-reproducibility.patch \ 5SRC_URI:append = " file://0001-6.12-lib-build_OID_registry-fix-reproducibility-issues.patch \
6 file://0001-6.6-lib-build_OID_registry-fix-reproducibility-issues.patch \
7 " 6 "
8 7
9# Skip processing of this recipe if it is not explicitly specified as the 8# Skip processing of this recipe if it is not explicitly specified as the
@@ -15,8 +14,8 @@ python () {
15 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it") 14 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
16} 15}
17 16
18KBRANCH = "6.6/preempt-rt" 17KBRANCH = "6.12/linux"
19KMETA_BRANCH = "yocto-6.6" 18KMETA_BRANCH = "yocto-6.12"
20 19
21LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 20LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
22 21
@@ -24,13 +23,13 @@ DEPENDS += "elfutils-native openssl-native util-linux-native"
24 23
25LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}" 24LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}"
26 25
27LINUX_VERSION ?= "6.6.63" 26LINUX_VERSION ?= "6.12.16"
28SRCREV_machine ?= "91eff9b39c0f16e7487480fb2f1b89446b16b055" 27SRCREV_machine ?= "934bc38849dd7c6cabd8110d3ef2bd50a7fc79c4"
29SRCREV_meta ?= "693358ea6816821663168ac9063d60e52a8ee4fe" 28SRCREV_meta ?= "f24c58a63b7e047d2c4441dd2adc30de21c8814d"
30 29
31LINUX_KERNEL_TYPE = "preempt-rt" 30LINUX_KERNEL_TYPE = "preempt-rt"
32 31
33# Functionality flags 32# Functionality flags
34KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc" 33KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
35 34
36UPSTREAM_CHECK_GITTAGREGEX = "^lts-(?P<pver>v6.6.(\d+)-rt(\d)-preempt-rt-(\d+)T(\d+)Z)$" 35UPSTREAM_CHECK_GITTAGREGEX = "^lts-(?P<pver>v6.12.(\d+)-linux-(\d+)T(\d+)Z)$"
diff --git a/recipes-kernel/linux/linux-intel/0001-6.11-6.12-lib-build_OID_registry-fix-reproducibility-issues.patch b/recipes-kernel/linux/linux-intel/0001-6.12-lib-build_OID_registry-fix-reproducibility-issues.patch
index df2a4139..df2a4139 100644
--- a/recipes-kernel/linux/linux-intel/0001-6.11-6.12-lib-build_OID_registry-fix-reproducibility-issues.patch
+++ b/recipes-kernel/linux/linux-intel/0001-6.12-lib-build_OID_registry-fix-reproducibility-issues.patch
diff --git a/recipes-kernel/linux/linux-intel/0001-6.6-lib-build_OID_registry-fix-reproducibility-issues.patch b/recipes-kernel/linux/linux-intel/0001-6.6-lib-build_OID_registry-fix-reproducibility-issues.patch
deleted file mode 100644
index 4a918616..00000000
--- a/recipes-kernel/linux/linux-intel/0001-6.6-lib-build_OID_registry-fix-reproducibility-issues.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From c53db24c143f9d0f5f1c1894852c00c0567f80a6 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Sun, 10 Jul 2022 22:56:53 -0400
4Subject: [PATCH] lib/build_OID_registry: fix reproducibility issues
5
6The script build_OID_registry captures the full path of itself
7in the generated data. This causes reproduciblity issues as the
8path is captured and packaged.
9
10We use the basename of the script instead, and that allows us
11to be reprodicible, with slightly less information captured in
12the output data (but the generating script can still easily
13be found).
14
15Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
16Upstream-Status: Inappropriate
17
18Taken from linux-yocto, v5.15/standard/base.
19
20Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
21---
22 lib/build_OID_registry | 1 +
23 1 file changed, 1 insertion(+)
24
25diff --git a/lib/build_OID_registry b/lib/build_OID_registry
26index 8267e8d71338..7bb198f08c94 100755
27--- a/lib/build_OID_registry
28+++ b/lib/build_OID_registry
29@@ -9,6 +9,7 @@
30
31 use strict;
32 use Cwd qw(abs_path);
33+use File::Basename;
34
35 my @names = ();
36 my @oids = ();
37--
382.43.0
39
diff --git a/recipes-kernel/linux/linux-intel/0001-6.6-vt-conmakehash-improve-reproducibility.patch b/recipes-kernel/linux/linux-intel/0001-6.6-vt-conmakehash-improve-reproducibility.patch
deleted file mode 100644
index 0ecacb30..00000000
--- a/recipes-kernel/linux/linux-intel/0001-6.6-vt-conmakehash-improve-reproducibility.patch
+++ /dev/null
@@ -1,58 +0,0 @@
1From 2f662283528bc003d0be988bf6590a271ebe7755 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Sun, 10 Jul 2022 21:37:07 -0400
4Subject: [PATCH] vt/conmakehash: improve reproducibility
5
6The file generated by conmakehash capture the application
7path used to generate the file. While that can be informative,
8it varies based on where the kernel was built, as the full
9path is captured.
10
11We tweak the application to use a second input as the "capture
12name", and then modify the Makefile to pass the basename of
13the source, making it reproducible.
14
15This could be improved by using some sort of path mapping,
16or the application manipualing argv[1] itself, but for now
17this solves the reprodicibility issue.
18
19Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
20
21Upstream-Status: Inappropriate
22
23Taken from linux-yocto, v5.15/standard/base
24Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
25---
26 drivers/tty/vt/Makefile | 2 +-
27 drivers/tty/vt/conmakehash.c | 2 +-
28 2 files changed, 2 insertions(+), 2 deletions(-)
29
30diff --git a/drivers/tty/vt/Makefile b/drivers/tty/vt/Makefile
31index b3dfe9d5717e..6ee3736776c8 100644
32--- a/drivers/tty/vt/Makefile
33+++ b/drivers/tty/vt/Makefile
34@@ -15,7 +15,7 @@ clean-files := consolemap_deftbl.c defkeymap.c
35 hostprogs += conmakehash
36
37 quiet_cmd_conmk = CONMK $@
38- cmd_conmk = $(obj)/conmakehash $< > $@
39+ cmd_conmk = $(obj)/conmakehash $< $(shell basename $<) > $@
40
41 $(obj)/consolemap_deftbl.c: $(src)/$(FONTMAPFILE) $(obj)/conmakehash
42 $(call cmd,conmk)
43diff --git a/drivers/tty/vt/conmakehash.c b/drivers/tty/vt/conmakehash.c
44index cddd789fe46e..d62510b280e9 100644
45--- a/drivers/tty/vt/conmakehash.c
46+++ b/drivers/tty/vt/conmakehash.c
47@@ -253,7 +253,7 @@ int main(int argc, char *argv[])
48 #include <linux/types.h>\n\
49 \n\
50 u8 dfont_unicount[%d] = \n\
51-{\n\t", argv[1], fontlen);
52+{\n\t", argv[2], fontlen);
53
54 for ( i = 0 ; i < fontlen ; i++ )
55 {
56--
572.34.1
58