diff options
author | Yogesh Tyagi <yogesh.tyagi@intel.com> | 2025-03-09 21:15:54 +0530 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2025-03-10 10:02:16 +0800 |
commit | db1f123d8ba9b509e2c3a4549e9e795c67047709 (patch) | |
tree | 1d32a782c64c39e580bf89fce41d2a62902d5d23 | |
parent | 81b110e4fae3c47d65872ffc60bda6e92271b3f5 (diff) | |
download | meta-intel-db1f123d8ba9b509e2c3a4549e9e795c67047709.tar.gz |
linux-intel/6.12: add recipe
* Convert the mainline kernel 6.12 recipe to lts kernel 6.12 recipe
* Drop recipe for linux-intel-lts 6.6 kernel
* Use the 6.12 kernel tag lts-v6.12.16-linux-250225T162742Z
Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r-- | recipes-kernel/linux/linux-intel_6.12.bb | 17 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-intel_6.6.bb | 26 |
2 files changed, 9 insertions, 34 deletions
diff --git a/recipes-kernel/linux/linux-intel_6.12.bb b/recipes-kernel/linux/linux-intel_6.12.bb index d3933898..3bda3236 100644 --- a/recipes-kernel/linux/linux-intel_6.12.bb +++ b/recipes-kernel/linux/linux-intel_6.12.bb | |||
@@ -1,24 +1,25 @@ | |||
1 | require linux-intel.inc | 1 | require linux-intel.inc |
2 | 2 | ||
3 | SRC_URI:prepend = "git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \ | 3 | SRC_URI:prepend = "git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \ |
4 | " | 4 | " |
5 | SRC_URI:append = " file://0001-6.11-6.12-lib-build_OID_registry-fix-reproducibility-issues.patch \ | 5 | SRC_URI:append = " file://0001-6.12-lib-build_OID_registry-fix-reproducibility-issues.patch \ |
6 | " | 6 | " |
7 | KBRANCH = "6.12/linux" | ||
7 | KMETA_BRANCH = "yocto-6.12" | 8 | KMETA_BRANCH = "yocto-6.12" |
8 | 9 | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" | 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" |
10 | 11 | ||
11 | DEPENDS += "elfutils-native openssl-native util-linux-native" | 12 | DEPENDS += "elfutils-native openssl-native util-linux-native" |
12 | 13 | ||
13 | LINUX_VERSION_EXTENSION ??= "-mainline-tracking-${LINUX_KERNEL_TYPE}" | 14 | LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}" |
14 | 15 | ||
15 | LINUX_VERSION ?= "6.12" | 16 | LINUX_VERSION ?= "6.12.16" |
16 | SRCREV_machine ?= "0f23779724ce8d6654abd0ef2a4167dd37d677c8" | 17 | SRCREV_machine ?= "934bc38849dd7c6cabd8110d3ef2bd50a7fc79c4" |
17 | SRCREV_meta ?= "b6eb84a3327f850c42300c394586fe58a57db72d" | 18 | SRCREV_meta ?= "f24c58a63b7e047d2c4441dd2adc30de21c8814d" |
18 | 19 | ||
19 | # Functionality flags | 20 | # Functionality flags |
20 | KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc \ | 21 | KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc \ |
21 | features/security/security.scc \ | 22 | features/security/security.scc \ |
22 | features/intel-npu/intel-npu.scc" | 23 | features/intel-npu/intel-npu.scc" |
23 | 24 | ||
24 | UPSTREAM_CHECK_GITTAGREGEX = "^mainline-tracking-v6.12-linux-(?P<pver>(\d+)T(\d+)Z)$" | 25 | UPSTREAM_CHECK_GITTAGREGEX = "^lts-(?P<pver>v6.12.(\d+)-linux-(\d+)T(\d+)Z)$" |
diff --git a/recipes-kernel/linux/linux-intel_6.6.bb b/recipes-kernel/linux/linux-intel_6.6.bb deleted file mode 100644 index a7949232..00000000 --- a/recipes-kernel/linux/linux-intel_6.6.bb +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | require linux-intel.inc | ||
2 | |||
3 | SRC_URI:prepend = "git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \ | ||
4 | " | ||
5 | SRC_URI:append = " file://0001-6.6-vt-conmakehash-improve-reproducibility.patch \ | ||
6 | file://0001-6.6-lib-build_OID_registry-fix-reproducibility-issues.patch \ | ||
7 | " | ||
8 | KBRANCH = "6.6/linux" | ||
9 | KMETA_BRANCH = "yocto-6.6" | ||
10 | |||
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" | ||
12 | |||
13 | DEPENDS += "elfutils-native openssl-native util-linux-native" | ||
14 | |||
15 | LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}" | ||
16 | |||
17 | LINUX_VERSION ?= "6.6.63" | ||
18 | SRCREV_machine ?= "248856fd22b40784d5b53ac2c600064502573b9d" | ||
19 | SRCREV_meta ?= "693358ea6816821663168ac9063d60e52a8ee4fe" | ||
20 | |||
21 | # Functionality flags | ||
22 | KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc \ | ||
23 | features/security/security.scc \ | ||
24 | features/intel-npu/intel-npu.scc" | ||
25 | |||
26 | UPSTREAM_CHECK_GITTAGREGEX = "^lts-(?P<pver>v6.6.(\d+)-linux-(\d+)T(\d+)Z)$" | ||