diff options
author | Naveen Saini <naveen.kumar.saini@intel.com> | 2021-08-20 09:45:23 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2021-08-24 10:41:24 +0800 |
commit | 109fe9679337315fe80c1f97491fe4059fdf05cb (patch) | |
tree | b6c5e3bdea0f2e70964a41dd727e18693ca0ea72 /dynamic-layers/clang-layer/recipes-devtools/clang/files/fix-shared-libs.patch | |
parent | 3838f1d263aceef8f94c340593323b67391a26fa (diff) | |
download | meta-intel-109fe9679337315fe80c1f97491fe4059fdf05cb.tar.gz |
llvm/10.0.0: apply opencl-clang recommend patches
https://github.com/intel/opencl-clang/tree/ocl-open-100/patches
Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-devtools/clang/files/fix-shared-libs.patch')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-devtools/clang/files/fix-shared-libs.patch | 30 |
1 files changed, 0 insertions, 30 deletions
diff --git a/dynamic-layers/clang-layer/recipes-devtools/clang/files/fix-shared-libs.patch b/dynamic-layers/clang-layer/recipes-devtools/clang/files/fix-shared-libs.patch deleted file mode 100644 index d69d2a97..00000000 --- a/dynamic-layers/clang-layer/recipes-devtools/clang/files/fix-shared-libs.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From a6d4ccf082858e63e139ca06c02a071c343d2657 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrea Bocci <andrea.bocci@cern.ch> | ||
3 | Date: Sun, 15 Mar 2020 17:35:44 +0100 | ||
4 | Subject: [PATCH] Fix building in-tree with cmake -DLLVM_LINK_LLVM_DYLIB=ON | ||
5 | |||
6 | Building in-tree with LLVM 11.0 master with the LLVM_LINK_LLVM_DYLIB | ||
7 | cmake flag fails to link with the LLVMSPIRVLib library. | ||
8 | |||
9 | Add an explicit dependency to force the correct build order and linking. | ||
10 | |||
11 | Signed-off-by: Andrea Bocci <andrea.bocci@cern.ch> | ||
12 | Upstream-Status: Backport | ||
13 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
14 | --- | ||
15 | tools/llvm-spirv/CMakeLists.txt | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/tools/llvm-spirv/CMakeLists.txt b/tools/llvm-spirv/CMakeLists.txt | ||
19 | index 9aa96d9c..501c0daf 100644 | ||
20 | --- a/tools/llvm-spirv/CMakeLists.txt | ||
21 | +++ b/tools/llvm-spirv/CMakeLists.txt | ||
22 | @@ -14,7 +14,7 @@ add_llvm_tool(llvm-spirv | ||
23 | NO_INSTALL_RPATH | ||
24 | ) | ||
25 | |||
26 | -if (LLVM_SPIRV_BUILD_EXTERNAL) | ||
27 | +if (LLVM_SPIRV_BUILD_EXTERNAL OR LLVM_LINK_LLVM_DYLIB) | ||
28 | target_link_libraries(llvm-spirv PRIVATE LLVMSPIRVLib) | ||
29 | endif() | ||
30 | |||