diff options
author | Anuj Mittal <anuj.mittal@intel.com> | 2021-10-13 00:07:17 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2021-10-13 11:23:41 +0800 |
commit | a809b8c531f6f0176f7148977b1237319abdd660 (patch) | |
tree | 88ce637013b0ea30224d778413417c5fe9e972cf /dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm11-0001-llvm-spirv-skip-building-tests.patch | |
parent | 467d15d57afea208fb7bc35e486ee274700dca70 (diff) | |
download | meta-intel-a809b8c531f6f0176f7148977b1237319abdd660.tar.gz |
Remove support for gatesgarth
Building with oe-core gatesgarth is no longer supported. Remove from
LAYERSERIES_COMPAT and remove the LLVM 11 patches as well.
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm11-0001-llvm-spirv-skip-building-tests.patch')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm11-0001-llvm-spirv-skip-building-tests.patch | 51 |
1 files changed, 0 insertions, 51 deletions
diff --git a/dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm11-0001-llvm-spirv-skip-building-tests.patch b/dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm11-0001-llvm-spirv-skip-building-tests.patch deleted file mode 100644 index 237dec51..00000000 --- a/dynamic-layers/clang-layer/recipes-devtools/clang/files/llvm11-0001-llvm-spirv-skip-building-tests.patch +++ /dev/null | |||
@@ -1,51 +0,0 @@ | |||
1 | From 6690d77f9007ce82984dc1b6ae12585cb3e04785 Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Wed, 21 Aug 2019 14:35:31 +0800 | ||
4 | Subject: [PATCH 1/2] llvm-spirv: skip building tests | ||
5 | |||
6 | Some of these need clang to be built and since we're building this in-tree, | ||
7 | that leads to problems when compiling libcxx, compiler-rt which aren't built | ||
8 | in-tree. | ||
9 | |||
10 | Instead of using SPIRV_SKIP_CLANG_BUILD to skip clang build and adding this to | ||
11 | all components, disable the building of tests altogether. | ||
12 | |||
13 | Upstream-Status: Inappropriate | ||
14 | |||
15 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
16 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
17 | --- | ||
18 | CMakeLists.txt | 10 ---------- | ||
19 | 1 file changed, 10 deletions(-) | ||
20 | |||
21 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
22 | index ec61fb95..d723c0a5 100644 | ||
23 | --- a/CMakeLists.txt | ||
24 | +++ b/CMakeLists.txt | ||
25 | @@ -26,13 +26,6 @@ if(LLVM_SPIRV_BUILD_EXTERNAL) | ||
26 | set(CMAKE_CXX_STANDARD 14) | ||
27 | set(CMAKE_CXX_STANDARD_REQUIRED ON) | ||
28 | |||
29 | - if(LLVM_SPIRV_INCLUDE_TESTS) | ||
30 | - set(LLVM_TEST_COMPONENTS | ||
31 | - llvm-as | ||
32 | - llvm-dis | ||
33 | - ) | ||
34 | - endif(LLVM_SPIRV_INCLUDE_TESTS) | ||
35 | - | ||
36 | find_package(LLVM ${BASE_LLVM_VERSION} REQUIRED | ||
37 | COMPONENTS | ||
38 | Analysis | ||
39 | @@ -65,9 +58,6 @@ set(LLVM_SPIRV_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/include) | ||
40 | |||
41 | add_subdirectory(lib/SPIRV) | ||
42 | add_subdirectory(tools/llvm-spirv) | ||
43 | -if(LLVM_SPIRV_INCLUDE_TESTS) | ||
44 | - add_subdirectory(test) | ||
45 | -endif(LLVM_SPIRV_INCLUDE_TESTS) | ||
46 | |||
47 | install( | ||
48 | FILES | ||
49 | -- | ||
50 | 2.17.1 | ||
51 | |||