summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch
diff options
context:
space:
mode:
authorYogesh Tyagi <yogesh.tyagi@intel.com>2025-05-14 18:55:25 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2025-05-20 15:35:04 +0800
commitb5c65864faeff4ed95f4f75daf5535a95a809e5e (patch)
tree1936384cf1562dccb7176877eb170a76eba48483 /dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch
parent343435a2f109fba31b684e019d32f3f73e8e2c1b (diff)
downloadmeta-intel-b5c65864faeff4ed95f4f75daf5535a95a809e5e.tar.gz
intel-compute-runtime : upgrade 24.39.31294.12 -> 25.13.33276.16HEADwalnascarmaster
Drop patch already merged upstream Release Notes: https://github.com/intel/compute-runtime/releases/tag/25.13.33276.16 Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch27
1 files changed, 0 insertions, 27 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch
deleted file mode 100644
index bc718eed..00000000
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From a40ed1c5274f867385610bb57ceee75bf4722de9 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 30 May 2023 09:03:01 +0800
4Subject: [PATCH 1/5] intel-compute-runtime: fix build with gcc13
5
6Upstream-Status: Inappropriate
7Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
8---
9 CMakeLists.txt | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/CMakeLists.txt b/CMakeLists.txt
13index 5e43b4ad76..619243913b 100644
14--- a/CMakeLists.txt
15+++ b/CMakeLists.txt
16@@ -811,7 +811,7 @@ if(NOT MSVC)
17 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-noexcept-type") # Added for gtest
18 endif()
19 endif()
20- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Werror=vla")
21+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror=vla")
22
23 if(USE_SANITIZE_UB)
24 check_cxx_compiler_flag(-fsanitize=undefined COMPILER_SUPPORTS_UNDEFINED_BEHAVIOR_SANITIZER)
25--
262.34.1
27