diff options
author | Naveen Saini <naveen.kumar.saini@intel.com> | 2020-05-28 17:53:24 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2020-05-28 19:02:57 +0800 |
commit | d5fb8c53d1934e2433a5441741429f407e7c6266 (patch) | |
tree | b4445eab089131c9b29c23d19227dd7b4b1e378f /dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch | |
parent | 8e1c5395e85921350ff40564edf035faacd98e3d (diff) | |
download | meta-intel-d5fb8c53d1934e2433a5441741429f407e7c6266.tar.gz |
intel-compute-runtime: upgrade 20.15.16524 -> 20.20.16837
Release notes:
https://github.com/intel/compute-runtime/releases/tag/20.20.16837
Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch new file mode 100644 index 00000000..eae129c7 --- /dev/null +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/allow-to-find-cpp-generation-tool.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From d6c5bf050f3d50ca02866ec90e474ef540df2ffa Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Wed, 27 May 2020 11:12:09 +0000 | ||
4 | Subject: [PATCH] intel-compute-runtime: allow to find cpp_generation_tool | ||
5 | |||
6 | Build not able to locate cpp_generation_tool. | ||
7 | |||
8 | Upstream-Status: Inappropriate [oe specific] | ||
9 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
10 | --- | ||
11 | shared/source/built_ins/kernels/CMakeLists.txt | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/shared/source/built_ins/kernels/CMakeLists.txt b/shared/source/built_ins/kernels/CMakeLists.txt | ||
15 | index 308a6cb3b..9f34359c3 100644 | ||
16 | --- a/shared/source/built_ins/kernels/CMakeLists.txt | ||
17 | +++ b/shared/source/built_ins/kernels/CMakeLists.txt | ||
18 | @@ -84,9 +84,9 @@ function(compile_builtin gen_type platform_type builtin bits builtin_options) | ||
19 | ) | ||
20 | add_custom_command( | ||
21 | OUTPUT ${OUTPUT_FILE_CPP} | ||
22 | - COMMAND $<TARGET_FILE:cpp_generate_tool> --file ${OUTPUTPATH_BASE}.gen --output ${OUTPUT_FILE_CPP} --array ${BASENAME} --platform ${family_name_with_type} | ||
23 | + COMMAND cpp_generate_tool --file ${OUTPUTPATH_BASE}.gen --output ${OUTPUT_FILE_CPP} --array ${BASENAME} --platform ${family_name_with_type} | ||
24 | WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} | ||
25 | - DEPENDS ${OUTPUTPATH_BASE}.gen $<TARGET_FILE:cpp_generate_tool> | ||
26 | + DEPENDS ${OUTPUTPATH_BASE}.gen cpp_generate_tool | ||
27 | ) | ||
28 | endfunction() | ||
29 | |||
30 | -- | ||
31 | 2.24.1 | ||
32 | |||