diff options
author | Yogesh Tyagi <yogesh.tyagi@intel.com> | 2024-09-24 17:44:44 +0530 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2024-09-24 22:07:08 +0800 |
commit | 1abc8ef0fc11041e2ff18989dce5b99214ee89ed (patch) | |
tree | a28810658163d6f1bca5bf36a6bcf9bf4e8f069e /dynamic-layers/clang-layer | |
parent | 474bdffd8b5776eb1519d21323cbf6d22a14f78c (diff) | |
download | meta-intel-1abc8ef0fc11041e2ff18989dce5b99214ee89ed.tar.gz |
intel-compute-runtime : Fix build error with gcc13
Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/clang-layer')
2 files changed, 158 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-fix-add-missing-includes.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-fix-add-missing-includes.patch new file mode 100644 index 00000000..a008d69e --- /dev/null +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-fix-add-missing-includes.patch | |||
@@ -0,0 +1,157 @@ | |||
1 | From 1517c8689cdaab9aaa1fa25e8db3b84f93e1f1ca Mon Sep 17 00:00:00 2001 | ||
2 | From: Mateusz Jablonski <mateusz.jablonski@intel.com> | ||
3 | Date: Tue, 22 Aug 2023 12:37:37 +0200 | ||
4 | Subject: [PATCH] fix: add missing includes | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> | ||
8 | --- | ||
9 | level_zero/tools/source/sysman/linux/pmt/pmt_xml_offsets.h | 1 + | ||
10 | opencl/test/unit_test/built_ins/built_ins_file_names.h | 3 ++- | ||
11 | shared/source/compiler_interface/external_functions.h | 1 + | ||
12 | shared/source/os_interface/linux/drm_debug.h | 1 + | ||
13 | shared/source/os_interface/linux/pci_path.h | 3 ++- | ||
14 | shared/source/os_interface/linux/pmt_util.h | 1 + | ||
15 | shared/source/os_interface/print.h | 1 + | ||
16 | shared/source/tbx/tbx_sockets.h | 1 + | ||
17 | shared/source/tbx/tbx_sockets_imp.h | 1 + | ||
18 | third_party/aot_config_headers/platforms.h | 1 + | ||
19 | 10 files changed, 12 insertions(+), 2 deletions(-) | ||
20 | |||
21 | diff --git a/level_zero/tools/source/sysman/linux/pmt/pmt_xml_offsets.h b/level_zero/tools/source/sysman/linux/pmt/pmt_xml_offsets.h | ||
22 | index 2bcfa0e6aa..2a30b0c6be 100644 | ||
23 | --- a/level_zero/tools/source/sysman/linux/pmt/pmt_xml_offsets.h | ||
24 | +++ b/level_zero/tools/source/sysman/linux/pmt/pmt_xml_offsets.h | ||
25 | @@ -7,6 +7,7 @@ | ||
26 | |||
27 | #pragma once | ||
28 | |||
29 | +#include <cstdint> | ||
30 | #include <map> | ||
31 | #include <string> | ||
32 | |||
33 | diff --git a/opencl/test/unit_test/built_ins/built_ins_file_names.h b/opencl/test/unit_test/built_ins/built_ins_file_names.h | ||
34 | index 08dc38d406..ca43ba0f26 100644 | ||
35 | --- a/opencl/test/unit_test/built_ins/built_ins_file_names.h | ||
36 | +++ b/opencl/test/unit_test/built_ins/built_ins_file_names.h | ||
37 | @@ -1,5 +1,5 @@ | ||
38 | /* | ||
39 | - * Copyright (C) 2020-2022 Intel Corporation | ||
40 | + * Copyright (C) 2020-2023 Intel Corporation | ||
41 | * | ||
42 | * SPDX-License-Identifier: MIT | ||
43 | * | ||
44 | @@ -7,6 +7,7 @@ | ||
45 | |||
46 | #pragma once | ||
47 | |||
48 | +#include <cstdint> | ||
49 | #include <string> | ||
50 | #include <vector> | ||
51 | |||
52 | diff --git a/shared/source/compiler_interface/external_functions.h b/shared/source/compiler_interface/external_functions.h | ||
53 | index f4cd790489..d377bf3937 100644 | ||
54 | --- a/shared/source/compiler_interface/external_functions.h | ||
55 | +++ b/shared/source/compiler_interface/external_functions.h | ||
56 | @@ -9,6 +9,7 @@ | ||
57 | |||
58 | #include "shared/source/utilities/arrayref.h" | ||
59 | |||
60 | +#include <cstdint> | ||
61 | #include <string> | ||
62 | #include <unordered_map> | ||
63 | #include <vector> | ||
64 | diff --git a/shared/source/os_interface/linux/drm_debug.h b/shared/source/os_interface/linux/drm_debug.h | ||
65 | index a1a46fcd8e..bc56e407d9 100644 | ||
66 | --- a/shared/source/os_interface/linux/drm_debug.h | ||
67 | +++ b/shared/source/os_interface/linux/drm_debug.h | ||
68 | @@ -7,6 +7,7 @@ | ||
69 | |||
70 | #pragma once | ||
71 | |||
72 | +#include <cstdint> | ||
73 | #include <array> | ||
74 | #include <string> | ||
75 | #include <utility> | ||
76 | diff --git a/shared/source/os_interface/linux/pci_path.h b/shared/source/os_interface/linux/pci_path.h | ||
77 | index c72c1d65d0..4f95e5ba61 100644 | ||
78 | --- a/shared/source/os_interface/linux/pci_path.h | ||
79 | +++ b/shared/source/os_interface/linux/pci_path.h | ||
80 | @@ -7,6 +7,7 @@ | ||
81 | |||
82 | #pragma once | ||
83 | |||
84 | +#include <cstdint> | ||
85 | #include <optional> | ||
86 | #include <string> | ||
87 | |||
88 | @@ -16,4 +17,4 @@ std::optional<std::string> getPciPath(int deviceFd); | ||
89 | std::optional<std::string> getPciLinkPath(int deviceFd); | ||
90 | std::optional<std::string> getPciRootPath(int deviceFd); | ||
91 | |||
92 | -} // namespace NEO | ||
93 | \ No newline at end of file | ||
94 | +} // namespace NEO | ||
95 | diff --git a/shared/source/os_interface/linux/pmt_util.h b/shared/source/os_interface/linux/pmt_util.h | ||
96 | index 28ecad3f05..d85bf298ae 100644 | ||
97 | --- a/shared/source/os_interface/linux/pmt_util.h | ||
98 | +++ b/shared/source/os_interface/linux/pmt_util.h | ||
99 | @@ -7,6 +7,7 @@ | ||
100 | |||
101 | #pragma once | ||
102 | |||
103 | +#include <cstdint> | ||
104 | #include <map> | ||
105 | #include <poll.h> | ||
106 | #include <string> | ||
107 | diff --git a/shared/source/os_interface/print.h b/shared/source/os_interface/print.h | ||
108 | index 7cc214e6ec..ac967be44b 100644 | ||
109 | --- a/shared/source/os_interface/print.h | ||
110 | +++ b/shared/source/os_interface/print.h | ||
111 | @@ -7,6 +7,7 @@ | ||
112 | |||
113 | #pragma once | ||
114 | |||
115 | +#include <cstdint> | ||
116 | #include <cstddef> | ||
117 | |||
118 | void printToSTDOUT(const char *str); | ||
119 | diff --git a/shared/source/tbx/tbx_sockets.h b/shared/source/tbx/tbx_sockets.h | ||
120 | index 9b7f7863f0..2d4cf2ffbe 100644 | ||
121 | --- a/shared/source/tbx/tbx_sockets.h | ||
122 | +++ b/shared/source/tbx/tbx_sockets.h | ||
123 | @@ -6,6 +6,7 @@ | ||
124 | */ | ||
125 | |||
126 | #pragma once | ||
127 | +#include <cstdint> | ||
128 | #include <string> | ||
129 | |||
130 | namespace NEO { | ||
131 | diff --git a/shared/source/tbx/tbx_sockets_imp.h b/shared/source/tbx/tbx_sockets_imp.h | ||
132 | index 738f26175b..4a567a8f64 100644 | ||
133 | --- a/shared/source/tbx/tbx_sockets_imp.h | ||
134 | +++ b/shared/source/tbx/tbx_sockets_imp.h | ||
135 | @@ -10,6 +10,7 @@ | ||
136 | |||
137 | #include "os_socket.h" | ||
138 | |||
139 | +#include <cstdint> | ||
140 | #include <iostream> | ||
141 | |||
142 | namespace NEO { | ||
143 | diff --git a/third_party/aot_config_headers/platforms.h b/third_party/aot_config_headers/platforms.h | ||
144 | index 05f75a40b3..35fb490a55 100644 | ||
145 | --- a/third_party/aot_config_headers/platforms.h | ||
146 | +++ b/third_party/aot_config_headers/platforms.h | ||
147 | @@ -7,6 +7,7 @@ | ||
148 | |||
149 | #include <map> | ||
150 | #include <string> | ||
151 | +#include <cstdint> | ||
152 | |||
153 | #pragma once | ||
154 | |||
155 | -- | ||
156 | 2.43.0 | ||
157 | |||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.31.23852.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.31.23852.bb index 9bbbb3a7..bb471f00 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.31.23852.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.31.23852.bb | |||
@@ -10,6 +10,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9280143b568466d8fbe385f838078b93 \ | |||
10 | 10 | ||
11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=master \ | 11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=master \ |
12 | file://0001-fix-add-missing-zero-initialization-in-StackVec-clas.patch \ | 12 | file://0001-fix-add-missing-zero-initialization-in-StackVec-clas.patch \ |
13 | file://0001-fix-add-missing-includes.patch \ | ||
13 | " | 14 | " |
14 | 15 | ||
15 | SRC_URI:append:class-target = "file://allow-to-find-cpp-generation-tool.patch \ | 16 | SRC_URI:append:class-target = "file://allow-to-find-cpp-generation-tool.patch \ |