diff options
author | Yogesh Tyagi <yogesh.tyagi@intel.com> | 2024-05-02 18:23:23 +0530 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2024-05-03 10:13:09 +0800 |
commit | 374a26b5016fbc7d632fce0554c29229056386c7 (patch) | |
tree | 8e57b695721146dbfbed228a79241dc58085e22e /dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch | |
parent | aad60b5319cc99fa660982dc30a9b81807c5c64a (diff) | |
download | meta-intel-374a26b5016fbc7d632fce0554c29229056386c7.tar.gz |
openvino-inference-engine : upgrade 2024.0.0 -> 2024.1.0
- Disable NPU plugin for now and enable it in a later change
- Drop backported patch which is now avialable in this version
- Drop patch which is already merged upstream
- Refresh patches
Release Notes:
https://github.com/openvinotoolkit/openvino/releases/tag/2024.1.0
Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch | 52 |
1 files changed, 24 insertions, 28 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch index 7ab31309..7f5b46c6 100644 --- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch +++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch | |||
@@ -1,11 +1,11 @@ | |||
1 | From bfcf5ae581ca4e7266cf7dc65b1c71754cd78cc0 Mon Sep 17 00:00:00 2001 | 1 | From e4edbdae9a2dbfec6fd0706bdfff8abdfe3363fc Mon Sep 17 00:00:00 2001 |
2 | From: Anuj Mittal <anuj.mittal@intel.com> | 2 | From: Anuj Mittal <anuj.mittal@intel.com> |
3 | Date: Wed, 29 Nov 2023 12:42:57 +0530 | 3 | Date: Wed, 29 Nov 2023 12:42:57 +0530 |
4 | Subject: [PATCH 1/4] cmake: yocto specific tweaks to the build process | 4 | Subject: [PATCH] cmake: yocto specific tweaks to the build process |
5 | 5 | ||
6 | * Dont try to detect glibc version as that doesn't work when cross compiling. | 6 | * Dont try to detect glibc version as that doesn't work when cross compiling. |
7 | * Dont try to detect CXX11_ABI | ||
7 | * Install sample binaries as well. | 8 | * Install sample binaries as well. |
8 | * Dont strip binaries. | ||
9 | * Dont try to write triggers for CPack. We package ourselves. | 9 | * Dont try to write triggers for CPack. We package ourselves. |
10 | * Fix the installation path for Python modules when baselib = lib64. | 10 | * Fix the installation path for Python modules when baselib = lib64. |
11 | 11 | ||
@@ -14,17 +14,16 @@ Upstream-Status: Inappropriate | |||
14 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | 14 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> |
15 | --- | 15 | --- |
16 | cmake/developer_package/packaging/rpm/rpm.cmake | 2 +- | 16 | cmake/developer_package/packaging/rpm/rpm.cmake | 2 +- |
17 | cmake/developer_package/target_flags.cmake | 2 +- | 17 | cmake/developer_package/target_flags.cmake | 4 ++-- |
18 | samples/cpp/CMakeLists.txt | 6 +++--- | 18 | samples/cpp/CMakeLists.txt | 6 +++--- |
19 | src/bindings/python/CMakeLists.txt | 2 +- | 19 | src/bindings/python/CMakeLists.txt | 2 +- |
20 | src/bindings/python/wheel/setup.py | 1 - | 20 | 4 files changed, 7 insertions(+), 7 deletions(-) |
21 | 5 files changed, 6 insertions(+), 7 deletions(-) | ||
22 | 21 | ||
23 | diff --git a/cmake/developer_package/packaging/rpm/rpm.cmake b/cmake/developer_package/packaging/rpm/rpm.cmake | 22 | diff --git a/cmake/developer_package/packaging/rpm/rpm.cmake b/cmake/developer_package/packaging/rpm/rpm.cmake |
24 | index a7c0ec2cf61..40448e8a962 100644 | 23 | index 99f11730983..1a1f61fcd3d 100644 |
25 | --- a/cmake/developer_package/packaging/rpm/rpm.cmake | 24 | --- a/cmake/developer_package/packaging/rpm/rpm.cmake |
26 | +++ b/cmake/developer_package/packaging/rpm/rpm.cmake | 25 | +++ b/cmake/developer_package/packaging/rpm/rpm.cmake |
27 | @@ -154,7 +154,7 @@ ov_rpm_specific_settings() | 26 | @@ -156,7 +156,7 @@ ov_rpm_specific_settings() |
28 | # needed to add triggers for packages with libraries | 27 | # needed to add triggers for packages with libraries |
29 | set(def_triggers "${OpenVINO_BINARY_DIR}/_CPack_Packages/triggers") | 28 | set(def_triggers "${OpenVINO_BINARY_DIR}/_CPack_Packages/triggers") |
30 | set(triggers_content "# /bin/sh -p\n/sbin/ldconfig\n") | 29 | set(triggers_content "# /bin/sh -p\n/sbin/ldconfig\n") |
@@ -34,17 +33,26 @@ index a7c0ec2cf61..40448e8a962 100644 | |||
34 | # | 33 | # |
35 | # Functions helpful for packaging your modules with RPM cpack | 34 | # Functions helpful for packaging your modules with RPM cpack |
36 | diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake | 35 | diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake |
37 | index 29f23e713e1..942dd445b19 100644 | 36 | index d047a1aebd9..4e8ca68c60f 100644 |
38 | --- a/cmake/developer_package/target_flags.cmake | 37 | --- a/cmake/developer_package/target_flags.cmake |
39 | +++ b/cmake/developer_package/target_flags.cmake | 38 | +++ b/cmake/developer_package/target_flags.cmake |
40 | @@ -145,4 +145,4 @@ function(ov_glibc_version) | 39 | @@ -149,7 +149,7 @@ function(ov_glibc_version) |
41 | endif() | 40 | endif() |
42 | endfunction() | 41 | endfunction() |
43 | 42 | ||
44 | -ov_glibc_version() | 43 | -ov_glibc_version() |
45 | +#ov_glibc_version() | 44 | +#ov_glibc_version() |
45 | |||
46 | # | ||
47 | # Detects default value for _GLIBCXX_USE_CXX11_ABI for current compiler | ||
48 | @@ -160,4 +160,4 @@ macro(ov_get_glibcxx_use_cxx11_abi) | ||
49 | endif() | ||
50 | endmacro() | ||
51 | |||
52 | -ov_get_glibcxx_use_cxx11_abi() | ||
53 | +#ov_get_glibcxx_use_cxx11_abi() | ||
46 | diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt | 54 | diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt |
47 | index c814cc37e2c..431e7bd2ed3 100644 | 55 | index 4d33bff944e..3e7f1458578 100644 |
48 | --- a/samples/cpp/CMakeLists.txt | 56 | --- a/samples/cpp/CMakeLists.txt |
49 | +++ b/samples/cpp/CMakeLists.txt | 57 | +++ b/samples/cpp/CMakeLists.txt |
50 | @@ -206,9 +206,9 @@ macro(ov_add_sample) | 58 | @@ -206,9 +206,9 @@ macro(ov_add_sample) |
@@ -61,30 +69,18 @@ index c814cc37e2c..431e7bd2ed3 100644 | |||
61 | # create global target with all samples / demo apps | 69 | # create global target with all samples / demo apps |
62 | if(NOT TARGET ov_samples) | 70 | if(NOT TARGET ov_samples) |
63 | diff --git a/src/bindings/python/CMakeLists.txt b/src/bindings/python/CMakeLists.txt | 71 | diff --git a/src/bindings/python/CMakeLists.txt b/src/bindings/python/CMakeLists.txt |
64 | index 58ff9b74302..4763994ba56 100644 | 72 | index 6cf43ec3fed..d539b9d003f 100644 |
65 | --- a/src/bindings/python/CMakeLists.txt | 73 | --- a/src/bindings/python/CMakeLists.txt |
66 | +++ b/src/bindings/python/CMakeLists.txt | 74 | +++ b/src/bindings/python/CMakeLists.txt |
67 | @@ -356,7 +356,7 @@ if(ENABLE_PYTHON_PACKAGING) | 75 | @@ -320,7 +320,7 @@ if(ENABLE_PYTHON_PACKAGING) |
68 | endif() | 76 | # install OpenVINO Python API |
69 | 77 | ||
70 | set(python_package_prefix "${CMAKE_CURRENT_BINARY_DIR}/install_${pyversion}") | 78 | set(python_package_prefix "${CMAKE_CURRENT_BINARY_DIR}/install_${pyversion}") |
71 | - set(install_lib "${python_package_prefix}/lib/${python_versioned_folder}/${ov_site_packages}") | 79 | - set(install_lib "${python_package_prefix}/lib/${python_versioned_folder}/${ov_site_packages}") |
72 | + set(install_lib "${python_package_prefix}/${CMAKE_INSTALL_LIBDIR}/${python_versioned_folder}/${ov_site_packages}") | 80 | + set(install_lib "${python_package_prefix}/${CMAKE_INSTALL_LIBDIR}/${python_versioned_folder}/${ov_site_packages}") |
73 | set(meta_info_subdir "openvino-${OpenVINO_VERSION}-py${python_xy}.egg-info") | 81 | set(openvino_meta_info_subdir "openvino-${OpenVINO_VERSION}-py${python_xy}.egg-info") |
74 | set(meta_info_file "${install_lib}/${meta_info_subdir}/PKG-INFO") | 82 | set(openvino_meta_info_file "${install_lib}/${openvino_meta_info_subdir}/PKG-INFO") |
75 | |||
76 | diff --git a/src/bindings/python/wheel/setup.py b/src/bindings/python/wheel/setup.py | ||
77 | index 4b056912212..5f05d891310 100644 | ||
78 | --- a/src/bindings/python/wheel/setup.py | ||
79 | +++ b/src/bindings/python/wheel/setup.py | ||
80 | @@ -270,7 +270,6 @@ class CustomBuild(build): | ||
81 | self.spawn(["cmake", "--install", binary_dir, | ||
82 | "--prefix", prefix, | ||
83 | "--config", CONFIG, | ||
84 | - "--strip", | ||
85 | "--component", cpack_comp_name]) | ||
86 | 83 | ||
87 | def run(self): | ||
88 | -- | 84 | -- |
89 | 2.34.1 | 85 | 2.34.1 |
90 | 86 | ||