diff options
author | Yogesh Tyagi <yogesh.tyagi@intel.com> | 2023-06-08 12:28:23 +0530 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2023-06-09 10:52:17 +0800 |
commit | 348511101c7095fef20aa46e21104e98bdaf44ba (patch) | |
tree | 29d72d9e924c310db1338ee6f0d2815de2fb48f9 /dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch | |
parent | eb696e99ff8c5be4f9b181da9f134499d96760e4 (diff) | |
download | meta-intel-348511101c7095fef20aa46e21104e98bdaf44ba.tar.gz |
openvino-inference-engine: upgrade 2022.3.0 -> 2023.0.0
* OpenVINO no longer supports vpu so remove the vpu PACKAGECONFIG and
references.
* Now allows snappy compression to be used for TF frontend so allow
system installed snappy.
* Flatbuffers is now needed for TF Lite frontend.
* Refresh patches.
Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch | 64 |
1 files changed, 19 insertions, 45 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch index 7089bc9c..4157c846 100644 --- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch +++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/fix-build-with-gcc13.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From aac55921864fa91fe8e394a25fc565f28ae5fc64 Mon Sep 17 00:00:00 2001 | 1 | From f8ad3f859aadc6c81ccc667eee1439cc2e6113cf Mon Sep 17 00:00:00 2001 |
2 | From: Anuj Mittal <anuj.mittal@intel.com> | 2 | From: Anuj Mittal <anuj.mittal@intel.com> |
3 | Date: Tue, 30 May 2023 09:31:09 +0800 | 3 | Date: Tue, 30 May 2023 09:31:09 +0800 |
4 | Subject: [PATCH] fix build with gcc13 | 4 | Subject: [PATCH] fix build with gcc13 |
@@ -29,50 +29,12 @@ https://gcc.gnu.org/gcc-13/porting_to.html | |||
29 | Upstream-Status: Pending | 29 | Upstream-Status: Pending |
30 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | 30 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> |
31 | --- | 31 | --- |
32 | src/common/itt/include/openvino/itt.hpp | 1 + | ||
33 | src/common/preprocessing/ie_preprocess_gapi_kernels.hpp | 1 + | ||
34 | src/common/util/include/openvino/util/file_util.hpp | 1 + | ||
35 | src/inference/include/ie/ie_precision.hpp | 2 +- | 32 | src/inference/include/ie/ie_precision.hpp | 2 +- |
36 | src/plugins/intel_gpu/CMakeLists.txt | 6 +++--- | 33 | src/plugins/intel_gpu/CMakeLists.txt | 6 +++--- |
34 | .../include/intel_gpu/graph/serialization/helpers.hpp | 1 + | ||
37 | .../intel_gpu/include/intel_gpu/runtime/device_info.hpp | 1 + | 35 | .../intel_gpu/include/intel_gpu/runtime/device_info.hpp | 1 + |
38 | 6 files changed, 8 insertions(+), 4 deletions(-) | 36 | 4 files changed, 6 insertions(+), 4 deletions(-) |
39 | 37 | ||
40 | diff --git a/src/common/itt/include/openvino/itt.hpp b/src/common/itt/include/openvino/itt.hpp | ||
41 | index c978ca1b138..f01d59a652a 100644 | ||
42 | --- a/src/common/itt/include/openvino/itt.hpp | ||
43 | +++ b/src/common/itt/include/openvino/itt.hpp | ||
44 | @@ -8,6 +8,7 @@ | ||
45 | */ | ||
46 | |||
47 | #pragma once | ||
48 | +#include <cstdint> | ||
49 | #include <openvino/function_name.hpp> | ||
50 | #include <openvino/util/pp.hpp> | ||
51 | #include <string> | ||
52 | diff --git a/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp b/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp | ||
53 | index dfbb182b7a0..0887cc60e34 100644 | ||
54 | --- a/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp | ||
55 | +++ b/src/common/preprocessing/ie_preprocess_gapi_kernels.hpp | ||
56 | @@ -8,6 +8,7 @@ | ||
57 | # error non standalone GAPI | ||
58 | # endif | ||
59 | |||
60 | +#include <cstdint> | ||
61 | #include <tuple> | ||
62 | |||
63 | #include <opencv2/gapi/opencv_includes.hpp> | ||
64 | diff --git a/src/common/util/include/openvino/util/file_util.hpp b/src/common/util/include/openvino/util/file_util.hpp | ||
65 | index d2f2e00ff60..88e641526ab 100644 | ||
66 | --- a/src/common/util/include/openvino/util/file_util.hpp | ||
67 | +++ b/src/common/util/include/openvino/util/file_util.hpp | ||
68 | @@ -4,6 +4,7 @@ | ||
69 | |||
70 | #pragma once | ||
71 | |||
72 | +#include <cstdint> | ||
73 | #include <fstream> | ||
74 | #include <functional> | ||
75 | #include <string> | ||
76 | diff --git a/src/inference/include/ie/ie_precision.hpp b/src/inference/include/ie/ie_precision.hpp | 38 | diff --git a/src/inference/include/ie/ie_precision.hpp b/src/inference/include/ie/ie_precision.hpp |
77 | index 48bdd945b13..96c29b73159 100644 | 39 | index 48bdd945b13..96c29b73159 100644 |
78 | --- a/src/inference/include/ie/ie_precision.hpp | 40 | --- a/src/inference/include/ie/ie_precision.hpp |
@@ -87,10 +49,10 @@ index 48bdd945b13..96c29b73159 100644 | |||
87 | } | 49 | } |
88 | 50 | ||
89 | diff --git a/src/plugins/intel_gpu/CMakeLists.txt b/src/plugins/intel_gpu/CMakeLists.txt | 51 | diff --git a/src/plugins/intel_gpu/CMakeLists.txt b/src/plugins/intel_gpu/CMakeLists.txt |
90 | index ab4d7618c30..4c93024eb3c 100644 | 52 | index 948aecfcfec..a1b9783068b 100644 |
91 | --- a/src/plugins/intel_gpu/CMakeLists.txt | 53 | --- a/src/plugins/intel_gpu/CMakeLists.txt |
92 | +++ b/src/plugins/intel_gpu/CMakeLists.txt | 54 | +++ b/src/plugins/intel_gpu/CMakeLists.txt |
93 | @@ -34,9 +34,9 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include") | 55 | @@ -36,9 +36,9 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include") |
94 | 56 | ||
95 | add_subdirectory(thirdparty) | 57 | add_subdirectory(thirdparty) |
96 | 58 | ||
@@ -103,8 +65,20 @@ index ab4d7618c30..4c93024eb3c 100644 | |||
103 | 65 | ||
104 | add_subdirectory(src/runtime) | 66 | add_subdirectory(src/runtime) |
105 | add_subdirectory(src/kernel_selector) | 67 | add_subdirectory(src/kernel_selector) |
68 | diff --git a/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp b/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp | ||
69 | index 391629baba2..40efe7011c6 100644 | ||
70 | --- a/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp | ||
71 | +++ b/src/plugins/intel_gpu/include/intel_gpu/graph/serialization/helpers.hpp | ||
72 | @@ -5,6 +5,7 @@ | ||
73 | #pragma once | ||
74 | #include <utility> | ||
75 | #include <type_traits> | ||
76 | +#include <cstdint> | ||
77 | |||
78 | namespace cldnn { | ||
79 | template <typename T> | ||
106 | diff --git a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp | 80 | diff --git a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp |
107 | index 0c5a7177d30..7119417185c 100644 | 81 | index 387a319cbe1..e2a7b1fc0fa 100644 |
108 | --- a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp | 82 | --- a/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp |
109 | +++ b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp | 83 | +++ b/src/plugins/intel_gpu/include/intel_gpu/runtime/device_info.hpp |
110 | @@ -4,6 +4,7 @@ | 84 | @@ -4,6 +4,7 @@ |
@@ -116,5 +90,5 @@ index 0c5a7177d30..7119417185c 100644 | |||
116 | #include <vector> | 90 | #include <vector> |
117 | #include <tuple> | 91 | #include <tuple> |
118 | -- | 92 | -- |
119 | 2.37.3 | 93 | 2.34.1 |
120 | 94 | ||