diff options
author | Naveen Saini <naveen.kumar.saini@intel.com> | 2024-04-09 12:52:42 +0800 |
---|---|---|
committer | Naveen Saini <naveen.kumar.saini@intel.com> | 2024-04-12 12:56:48 +0800 |
commit | c374b041cc4df7f5566b4eee143d50e57d3ca1b8 (patch) | |
tree | 110ebde614a104523a93929fd9ebd383af54ae50 /dynamic-layers/openembedded-layer | |
parent | 506aa18577c4a309633cfcf016141cd76c55fdae (diff) | |
download | meta-intel-c374b041cc4df7f5566b4eee143d50e57d3ca1b8.tar.gz |
lms: use python3native and depend on python3-packaging-native
Recipe incorrectly using python from host, which causing
following failure:
| import packaging.version
| ModuleNotFoundError: No module named 'packaging.version'
Ref:
https://git.yoctoproject.org/poky/commit/?id=bb4abe0e6468f8be3fdd6012a109ddd1db7b20a8
Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb | 6 |
1 files changed, 2 insertions, 4 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb index 63b69ce8..bdf32576 100644 --- a/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb +++ b/dynamic-layers/openembedded-layer/recipes-bsp/amt/lms_2406.0.0.0.bb | |||
@@ -10,11 +10,9 @@ COMPATIBLE_HOST = '(i.86|x86_64).*-linux' | |||
10 | 10 | ||
11 | COMPATIBLE_HOST:libc-musl = "null" | 11 | COMPATIBLE_HOST:libc-musl = "null" |
12 | 12 | ||
13 | inherit cmake systemd features_check | 13 | inherit cmake systemd features_check python3native |
14 | 14 | ||
15 | DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native pkgconfig-native" | 15 | DEPENDS = "metee ace xerces-c libnl libxml2 glib-2.0 glib-2.0-native pkgconfig-native python3-packaging-native" |
16 | |||
17 | EXTRA_OECMAKE += "-DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3" | ||
18 | 16 | ||
19 | # Enable either connman or networkmanager or none but not both. | 17 | # Enable either connman or networkmanager or none but not both. |
20 | PACKAGECONFIG ??= "connman" | 18 | PACKAGECONFIG ??= "connman" |