diff options
author | Yogesh Tyagi <yogesh.tyagi@intel.com> | 2024-06-27 12:14:27 +0530 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2024-07-12 16:40:57 +0800 |
commit | e97386254712047f27f5554da6470fe3fb65d07a (patch) | |
tree | d6e49969da310c1ac1edfce0451099a7aa91281c /dynamic-layers/openembedded-layer | |
parent | ea0a7de92f983fde57ae64d642fb7b534627cd82 (diff) | |
download | meta-intel-e97386254712047f27f5554da6470fe3fb65d07a.tar.gz |
openvino-inference-engine : Remove openvino related recipes and tests
* Remove all openvino related recipes, tests and other data from meta-intel
layer as a new layer (meta-oepnvino) specific to openvino has been created.
* Update openvino documentation
meta-openvino layer URL:
https://github.com/intel/meta-openvino
Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer')
6 files changed, 0 insertions, 391 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch deleted file mode 100644 index 7f5b46c6..00000000 --- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0001-cmake-yocto-specific-tweaks-to-the-build-process.patch +++ /dev/null | |||
@@ -1,86 +0,0 @@ | |||
1 | From e4edbdae9a2dbfec6fd0706bdfff8abdfe3363fc Mon Sep 17 00:00:00 2001 | ||
2 | From: Anuj Mittal <anuj.mittal@intel.com> | ||
3 | Date: Wed, 29 Nov 2023 12:42:57 +0530 | ||
4 | Subject: [PATCH] cmake: yocto specific tweaks to the build process | ||
5 | |||
6 | * Dont try to detect glibc version as that doesn't work when cross compiling. | ||
7 | * Dont try to detect CXX11_ABI | ||
8 | * Install sample binaries as well. | ||
9 | * Dont try to write triggers for CPack. We package ourselves. | ||
10 | * Fix the installation path for Python modules when baselib = lib64. | ||
11 | |||
12 | Upstream-Status: Inappropriate | ||
13 | |||
14 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
15 | --- | ||
16 | cmake/developer_package/packaging/rpm/rpm.cmake | 2 +- | ||
17 | cmake/developer_package/target_flags.cmake | 4 ++-- | ||
18 | samples/cpp/CMakeLists.txt | 6 +++--- | ||
19 | src/bindings/python/CMakeLists.txt | 2 +- | ||
20 | 4 files changed, 7 insertions(+), 7 deletions(-) | ||
21 | |||
22 | diff --git a/cmake/developer_package/packaging/rpm/rpm.cmake b/cmake/developer_package/packaging/rpm/rpm.cmake | ||
23 | index 99f11730983..1a1f61fcd3d 100644 | ||
24 | --- a/cmake/developer_package/packaging/rpm/rpm.cmake | ||
25 | +++ b/cmake/developer_package/packaging/rpm/rpm.cmake | ||
26 | @@ -156,7 +156,7 @@ ov_rpm_specific_settings() | ||
27 | # needed to add triggers for packages with libraries | ||
28 | set(def_triggers "${OpenVINO_BINARY_DIR}/_CPack_Packages/triggers") | ||
29 | set(triggers_content "# /bin/sh -p\n/sbin/ldconfig\n") | ||
30 | -file(WRITE "${def_triggers}" "${triggers_content}") | ||
31 | +#file(WRITE "${def_triggers}" "${triggers_content}") | ||
32 | |||
33 | # | ||
34 | # Functions helpful for packaging your modules with RPM cpack | ||
35 | diff --git a/cmake/developer_package/target_flags.cmake b/cmake/developer_package/target_flags.cmake | ||
36 | index d047a1aebd9..4e8ca68c60f 100644 | ||
37 | --- a/cmake/developer_package/target_flags.cmake | ||
38 | +++ b/cmake/developer_package/target_flags.cmake | ||
39 | @@ -149,7 +149,7 @@ function(ov_glibc_version) | ||
40 | endif() | ||
41 | endfunction() | ||
42 | |||
43 | -ov_glibc_version() | ||
44 | +#ov_glibc_version() | ||
45 | |||
46 | # | ||
47 | # Detects default value for _GLIBCXX_USE_CXX11_ABI for current compiler | ||
48 | @@ -160,4 +160,4 @@ macro(ov_get_glibcxx_use_cxx11_abi) | ||
49 | endif() | ||
50 | endmacro() | ||
51 | |||
52 | -ov_get_glibcxx_use_cxx11_abi() | ||
53 | +#ov_get_glibcxx_use_cxx11_abi() | ||
54 | diff --git a/samples/cpp/CMakeLists.txt b/samples/cpp/CMakeLists.txt | ||
55 | index 4d33bff944e..3e7f1458578 100644 | ||
56 | --- a/samples/cpp/CMakeLists.txt | ||
57 | +++ b/samples/cpp/CMakeLists.txt | ||
58 | @@ -206,9 +206,9 @@ macro(ov_add_sample) | ||
59 | target_link_libraries(${SAMPLE_NAME} PRIVATE ${ov_link_libraries} Threads::Threads ${SAMPLE_DEPENDENCIES}) | ||
60 | |||
61 | install(TARGETS ${SAMPLE_NAME} | ||
62 | - RUNTIME DESTINATION samples_bin/ | ||
63 | - COMPONENT samples_bin | ||
64 | - EXCLUDE_FROM_ALL) | ||
65 | + DESTINATION ${CMAKE_INSTALL_BINDIR} | ||
66 | + COMPONENT samples_bin) | ||
67 | + | ||
68 | |||
69 | # create global target with all samples / demo apps | ||
70 | if(NOT TARGET ov_samples) | ||
71 | diff --git a/src/bindings/python/CMakeLists.txt b/src/bindings/python/CMakeLists.txt | ||
72 | index 6cf43ec3fed..d539b9d003f 100644 | ||
73 | --- a/src/bindings/python/CMakeLists.txt | ||
74 | +++ b/src/bindings/python/CMakeLists.txt | ||
75 | @@ -320,7 +320,7 @@ if(ENABLE_PYTHON_PACKAGING) | ||
76 | # install OpenVINO Python API | ||
77 | |||
78 | set(python_package_prefix "${CMAKE_CURRENT_BINARY_DIR}/install_${pyversion}") | ||
79 | - set(install_lib "${python_package_prefix}/lib/${python_versioned_folder}/${ov_site_packages}") | ||
80 | + set(install_lib "${python_package_prefix}/${CMAKE_INSTALL_LIBDIR}/${python_versioned_folder}/${ov_site_packages}") | ||
81 | set(openvino_meta_info_subdir "openvino-${OpenVINO_VERSION}-py${python_xy}.egg-info") | ||
82 | set(openvino_meta_info_file "${install_lib}/${openvino_meta_info_subdir}/PKG-INFO") | ||
83 | |||
84 | -- | ||
85 | 2.34.1 | ||
86 | |||
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cmake-Fix-overloaded-virtual-error.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cmake-Fix-overloaded-virtual-error.patch deleted file mode 100644 index 8a1464d5..00000000 --- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0002-cmake-Fix-overloaded-virtual-error.patch +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | From 4a909a03b6dd336e7ea76e3f44d7cfb5d7e44798 Mon Sep 17 00:00:00 2001 | ||
2 | From: Anuj Mittal <anuj.mittal@intel.com> | ||
3 | Date: Wed, 29 Nov 2023 12:49:35 +0530 | ||
4 | Subject: [PATCH 2/3] cmake: Fix overloaded-virtual error | ||
5 | |||
6 | * Remove -Werror for: | ||
7 | |git/src/plugins/intel_gpu/src/kernel_selector/jitter.h:129:28: error: 'virtual kernel_selector::JitDefinitions kernel_selector::JitConstant::GetDefinitions() const' was hidden [-Werror=overloaded-virtual=] | ||
8 | | 129 | virtual JitDefinitions GetDefinitions() const = 0; | ||
9 | | | | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
14 | --- | ||
15 | src/plugins/intel_gpu/CMakeLists.txt | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/src/plugins/intel_gpu/CMakeLists.txt b/src/plugins/intel_gpu/CMakeLists.txt | ||
19 | index 2f3d9127dde..2fd4f5c1b3c 100644 | ||
20 | --- a/src/plugins/intel_gpu/CMakeLists.txt | ||
21 | +++ b/src/plugins/intel_gpu/CMakeLists.txt | ||
22 | @@ -47,7 +47,7 @@ add_subdirectory(thirdparty) | ||
23 | include(thirdparty/cmake/rapidjson.cmake) | ||
24 | |||
25 | if(CMAKE_COMPILER_IS_GNUCXX) | ||
26 | - ov_add_compiler_flags(-Werror) | ||
27 | + #ov_add_compiler_flags(-Werror) | ||
28 | endif() | ||
29 | |||
30 | add_subdirectory(src/runtime) | ||
31 | -- | ||
32 | 2.34.1 | ||
33 | |||
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-protobuf-allow-target-protoc-to-be-built.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-protobuf-allow-target-protoc-to-be-built.patch deleted file mode 100644 index bbdeaa2a..00000000 --- a/dynamic-layers/openembedded-layer/recipes-support/opencv/files/0003-protobuf-allow-target-protoc-to-be-built.patch +++ /dev/null | |||
@@ -1,45 +0,0 @@ | |||
1 | From 450d94b475460d1af32b207d0ced495794863f0d Mon Sep 17 00:00:00 2001 | ||
2 | From: Anuj Mittal <anuj.mittal@intel.com> | ||
3 | Date: Wed, 29 Nov 2023 12:55:19 +0530 | ||
4 | Subject: [PATCH 3/3] protobuf: allow target protoc to be built | ||
5 | |||
6 | We can run target binaries using a qemu wrapper so allow these to be | ||
7 | built and run. | ||
8 | |||
9 | Upstream-Status: Inappropriate | ||
10 | |||
11 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
12 | --- | ||
13 | cmake/developer_package/frontends/frontends.cmake | 2 +- | ||
14 | thirdparty/protobuf/CMakeLists.txt | 2 +- | ||
15 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
16 | |||
17 | diff --git a/cmake/developer_package/frontends/frontends.cmake b/cmake/developer_package/frontends/frontends.cmake | ||
18 | index f3b5520d6d2..7579f638c5a 100644 | ||
19 | --- a/cmake/developer_package/frontends/frontends.cmake | ||
20 | +++ b/cmake/developer_package/frontends/frontends.cmake | ||
21 | @@ -163,7 +163,7 @@ macro(ov_add_frontend) | ||
22 | set(OUTPUT_PB_HEADER ${CMAKE_CURRENT_BINARY_DIR}/${relative_path}/${FILE_WE}.pb.h) | ||
23 | add_custom_command( | ||
24 | OUTPUT "${OUTPUT_PB_SRC}" "${OUTPUT_PB_HEADER}" | ||
25 | - COMMAND ${PROTOC_EXECUTABLE} ARGS --cpp_out ${CMAKE_CURRENT_BINARY_DIR} -I ${protofiles_root_dir} ${proto_file} | ||
26 | + COMMAND protoc ARGS --cpp_out ${CMAKE_CURRENT_BINARY_DIR} -I ${protofiles_root_dir} ${proto_file} | ||
27 | DEPENDS ${PROTOC_DEPENDENCY} ${proto_file} | ||
28 | COMMENT "Running C++ protocol buffer compiler (${PROTOC_EXECUTABLE}) on ${proto_file_relative}" | ||
29 | VERBATIM | ||
30 | diff --git a/thirdparty/protobuf/CMakeLists.txt b/thirdparty/protobuf/CMakeLists.txt | ||
31 | index 15f32601f23..36853caf7dc 100644 | ||
32 | --- a/thirdparty/protobuf/CMakeLists.txt | ||
33 | +++ b/thirdparty/protobuf/CMakeLists.txt | ||
34 | @@ -31,7 +31,7 @@ unset(HAVE_ZLIB CACHE) | ||
35 | if(CMAKE_CROSSCOMPILING OR | ||
36 | (APPLE AND (HOST_X86_64 AND AARCH64)) OR | ||
37 | (MSVC AND (HOST_X86_64 AND (AARCH64 OR ARM)))) | ||
38 | - set(protobuf_BUILD_PROTOC_BINARIES OFF CACHE BOOL "Build protoc binaries" FORCE) | ||
39 | + set(protobuf_BUILD_PROTOC_BINARIES ON CACHE BOOL "Build protoc binaries" FORCE) | ||
40 | else() | ||
41 | set(protobuf_BUILD_PROTOC_BINARIES ON CACHE BOOL "Build protoc binaries" FORCE) | ||
42 | endif() | ||
43 | -- | ||
44 | 2.34.1 | ||
45 | |||
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch deleted file mode 100644 index 816a98a3..00000000 --- a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo/0001-use-oe-gflags.patch +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | From 804b08023b3f8e72b8e3eb09e464d6775c11d966 Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Fri, 21 Oct 2022 11:38:23 +0800 | ||
4 | Subject: [PATCH] demos: use gflags from meta-oe | ||
5 | |||
6 | Upstream-Status: Inappropriate | ||
7 | |||
8 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
9 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
10 | |||
11 | --- | ||
12 | demos/CMakeLists.txt | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/demos/CMakeLists.txt b/demos/CMakeLists.txt | ||
16 | index 51767051c..fb7e3d22f 100644 | ||
17 | --- a/demos/CMakeLists.txt | ||
18 | +++ b/demos/CMakeLists.txt | ||
19 | @@ -141,7 +141,7 @@ endmacro() | ||
20 | find_package(OpenCV REQUIRED COMPONENTS core highgui videoio imgproc imgcodecs) | ||
21 | find_package(OpenVINO REQUIRED COMPONENTS Runtime) | ||
22 | |||
23 | -add_subdirectory(thirdparty/gflags) | ||
24 | +#add_subdirectory(thirdparty/gflags) | ||
25 | add_subdirectory(common/cpp) | ||
26 | |||
27 | find_package(OpenCV QUIET COMPONENTS gapi) | ||
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2024.1.0.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2024.1.0.bb deleted file mode 100644 index a9422e70..00000000 --- a/dynamic-layers/openembedded-layer/recipes-support/opencv/open-model-zoo_2024.1.0.bb +++ /dev/null | |||
@@ -1,54 +0,0 @@ | |||
1 | SUMMARY = "OpenVINO(TM) Toolkit - Open Model Zoo repository" | ||
2 | HOMEPAGE = "https://github.com/opencv/open_model_zoo" | ||
3 | DESCRIPTION = "This repository includes optimized deep learning \ | ||
4 | models and a set of demos to expedite development of high-performance \ | ||
5 | deep learning inference applications." | ||
6 | |||
7 | SRC_URI = "git://github.com/opencv/open_model_zoo.git;protocol=https;branch=master \ | ||
8 | file://0001-use-oe-gflags.patch \ | ||
9 | " | ||
10 | |||
11 | SRCREV = "cf5141dad2a4f24e1c5d5b9d43219ed804c48bbf" | ||
12 | |||
13 | LICENSE = "Apache-2.0" | ||
14 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \ | ||
15 | " | ||
16 | |||
17 | inherit cmake | ||
18 | |||
19 | S = "${WORKDIR}/git" | ||
20 | OECMAKE_SOURCEPATH = "${S}/demos" | ||
21 | |||
22 | DEPENDS += "openvino-inference-engine opencv gflags" | ||
23 | |||
24 | RDEPENDS:${PN} += " \ | ||
25 | python3-decorator \ | ||
26 | python3-defusedxml \ | ||
27 | python3-networkx \ | ||
28 | python3-protobuf \ | ||
29 | python3-requests \ | ||
30 | python3-pyyaml \ | ||
31 | python3-numpy \ | ||
32 | bash \ | ||
33 | " | ||
34 | |||
35 | COMPATIBLE_HOST = '(x86_64).*-linux' | ||
36 | COMPATIBLE_HOST:libc-musl = "null" | ||
37 | |||
38 | EXTRA_OECMAKE += " \ | ||
39 | -DENABLE_SAMPLES=ON \ | ||
40 | " | ||
41 | |||
42 | do_install(){ | ||
43 | install -d ${D}${libdir} | ||
44 | install -d ${D}${bindir} | ||
45 | install -d ${D}${datadir}/openvino/open-model-zoo/tools | ||
46 | install -d ${D}${datadir}/openvino/open-model-zoo/demos | ||
47 | cp -rf ${B}/intel64/Release/*.a ${D}${libdir} | ||
48 | cp -rf ${B}/intel64/Release/*_demo* ${D}${bindir} | ||
49 | cp -rf ${S}/models ${D}${datadir}/openvino/open-model-zoo | ||
50 | cp -rf ${S}/demos ${D}${datadir}/openvino/open-model-zoo | ||
51 | cp -rf ${S}/tools/model_tools ${D}${datadir}/openvino/open-model-zoo/tools | ||
52 | } | ||
53 | |||
54 | FILES:${PN} += "${datadir}/openvino" | ||
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2024.1.0.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2024.1.0.bb deleted file mode 100644 index 675d9920..00000000 --- a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2024.1.0.bb +++ /dev/null | |||
@@ -1,146 +0,0 @@ | |||
1 | SUMMARY = "OpenVINO(TM) Toolkit - Deep Learning Deployment Toolkit" | ||
2 | HOMEPAGE = "https://github.com/opencv/dldt" | ||
3 | DESCRIPTION = "This toolkit allows developers to deploy pre-trained \ | ||
4 | deep learning models through a high-level C++ Inference Engine API \ | ||
5 | integrated with application logic." | ||
6 | |||
7 | SRC_URI = "git://github.com/openvinotoolkit/openvino.git;protocol=https;name=openvino;branch=releases/2024/1;lfs=0 \ | ||
8 | git://github.com/openvinotoolkit/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/onednn;name=mkl;nobranch=1 \ | ||
9 | git://github.com/oneapi-src/oneDNN.git;protocol=https;destsuffix=git/src/plugins/intel_gpu/thirdparty/onednn_gpu;name=onednn;nobranch=1 \ | ||
10 | git://github.com/herumi/xbyak.git;protocol=https;destsuffix=git/thirdparty/xbyak;name=xbyak;branch=master \ | ||
11 | git://github.com/nlohmann/json.git;protocol=https;destsuffix=git/thirdparty/json/nlohmann_json;name=json;branch=develop \ | ||
12 | git://github.com/opencv/ade.git;protocol=https;destsuffix=git/thirdparty/ade;name=ade;nobranch=1 \ | ||
13 | git://github.com/protocolbuffers/protobuf.git;protocol=https;destsuffix=git/thirdparty/protobuf/protobuf;name=protobuf;branch=3.20.x \ | ||
14 | git://github.com/gflags/gflags.git;protocol=https;destsuffix=git/thirdparty/gflags/gflags;name=gflags;nobranch=1 \ | ||
15 | git://github.com/madler/zlib.git;protocol=https;destsuffix=git/thirdparty/zlib/zlib;name=zlib;nobranch=1 \ | ||
16 | git://github.com/openvinotoolkit/mlas.git;protocol=https;destsuffix=git/src/plugins/intel_cpu/thirdparty/mlas;name=mlas;nobranch=1 \ | ||
17 | git://github.com/nodejs/node-api-headers.git;protocol=https;destsuffix=git/node-api-headers-src;name=node-api-headers;nobranch=1 \ | ||
18 | git://github.com/nodejs/node-addon-api.git;protocol=https;destsuffix=git/node-addon-api-src;name=node-addon-api;nobranch=1 \ | ||
19 | git://github.com/openvinotoolkit/telemetry.git;protocol=https;destsuffix=git/thirdparty/telemetry;name=telemetry;nobranch=1;lfs=0 \ | ||
20 | file://0001-cmake-yocto-specific-tweaks-to-the-build-process.patch \ | ||
21 | file://0002-cmake-Fix-overloaded-virtual-error.patch \ | ||
22 | file://0003-protobuf-allow-target-protoc-to-be-built.patch \ | ||
23 | " | ||
24 | |||
25 | SRCREV_openvino = "f4afc983258bcb2592d999ed6700043fdb58ad78" | ||
26 | SRCREV_mkl = "26633ae49edd4353a29b7170d9fcef6b2d79f4b3" | ||
27 | SRCREV_onednn = "4e6ff043c439652fcf6c400ac4e0c81bbac7c71c" | ||
28 | SRCREV_xbyak = "740dff2e866f3ae1a70dd42d6e8836847ed95cc2" | ||
29 | SRCREV_json = "9cca280a4d0ccf0c08f47a99aa71d1b0e52f8d03" | ||
30 | SRCREV_ade = "0e8a2ccdd34f29dba55894f5f3c5179809888b9e" | ||
31 | SRCREV_protobuf = "fe271ab76f2ad2b2b28c10443865d2af21e27e0e" | ||
32 | SRCREV_gflags = "e171aa2d15ed9eb17054558e0b3a6a413bb01067" | ||
33 | SRCREV_zlib = "09155eaa2f9270dc4ed1fa13e2b4b2613e6e4851" | ||
34 | SRCREV_mlas = "d1bc25ec4660cddd87804fcf03b2411b5dfb2e94" | ||
35 | SRCREV_node-api-headers = "186e04b5e40e54d7fd1655bc67081cc483f12488" | ||
36 | SRCREV_node-addon-api = "39a25bf27788ff7a7ea5c64978c4dcd1e7b9d80d" | ||
37 | SRCREV_telemetry = "58e16c257a512ec7f451c9fccf9ff455065b285b" | ||
38 | SRCREV_FORMAT = "openvino_mkl_onednn_xbyak_json_ade_protobuf_gflags_zlib_node-api-headers_node-addon-api_mlas_telemetry" | ||
39 | |||
40 | LICENSE = "Apache-2.0 & MIT & BSD-3-Clause & Zlib" | ||
41 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \ | ||
42 | file://thirdparty/xbyak/COPYRIGHT;md5=3c98edfaa50a86eeaef4c6109e803f16 \ | ||
43 | file://thirdparty/cnpy/LICENSE;md5=689f10b06d1ca2d4b1057e67b16cd580 \ | ||
44 | file://thirdparty/json/nlohmann_json/LICENSE.MIT;md5=f969127d7b7ed0a8a63c2bbeae002588 \ | ||
45 | file://thirdparty/ade/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \ | ||
46 | file://thirdparty/gflags/gflags/COPYING.txt;md5=c80d1a3b623f72bb85a4c75b556551df \ | ||
47 | file://thirdparty/zlib/zlib/LICENSE;md5=b51a40671bc46e961c0498897742c0b8 \ | ||
48 | file://src/plugins/intel_cpu/thirdparty/mlas/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \ | ||
49 | file://src/plugins/intel_cpu/thirdparty/onednn/LICENSE;md5=3b64000f6e7d52516017622a37a94ce9 \ | ||
50 | file://src/plugins/intel_gpu/thirdparty/onednn_gpu/LICENSE;md5=3b64000f6e7d52516017622a37a94ce9 \ | ||
51 | file://node-api-headers-src/LICENSE;md5=6adb2909701d4605b4b2ae1a9b25d8bd \ | ||
52 | file://node-addon-api-src/LICENSE.md;md5=0492ef29a9d558a3e9660e7accc9ca6a \ | ||
53 | file://thirdparty/telemetry/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327 \ | ||
54 | " | ||
55 | |||
56 | inherit cmake python3native pkgconfig qemu | ||
57 | |||
58 | S = "${WORKDIR}/git" | ||
59 | EXTRA_OECMAKE += " \ | ||
60 | -DCMAKE_CROSSCOMPILING_EMULATOR=${WORKDIR}/qemuwrapper \ | ||
61 | -DENABLE_OPENCV=OFF \ | ||
62 | -DENABLE_INTEL_GNA=OFF \ | ||
63 | -DENABLE_SYSTEM_TBB=ON \ | ||
64 | -DPYTHON_EXECUTABLE=${PYTHON} \ | ||
65 | -DCMAKE_BUILD_TYPE=RelWithDebInfo \ | ||
66 | -DTHREADING=TBB -DTBB_DIR="${STAGING_LIBDIR}/cmake/TBB" \ | ||
67 | -DTREAT_WARNING_AS_ERROR=FALSE \ | ||
68 | -DENABLE_DATA=FALSE \ | ||
69 | -DENABLE_SYSTEM_PUGIXML=TRUE \ | ||
70 | -DENABLE_OV_ONNX_FRONTEND=FALSE \ | ||
71 | -DUSE_BUILD_TYPE_SUBFOLDER=OFF \ | ||
72 | -DENABLE_FUZZING=OFF \ | ||
73 | -DENABLE_TBBBIND_2_5=OFF \ | ||
74 | -DCPACK_GENERATOR=RPM \ | ||
75 | -DENABLE_SYSTEM_FLATBUFFERS=ON \ | ||
76 | -DENABLE_SYSTEM_SNAPPY=ON \ | ||
77 | -DFETCHCONTENT_BASE_DIR="${S}" \ | ||
78 | -DENABLE_INTEL_NPU=OFF \ | ||
79 | " | ||
80 | |||
81 | DEPENDS += "\ | ||
82 | flatbuffers-native \ | ||
83 | pugixml \ | ||
84 | python3-pybind11 \ | ||
85 | python3-pybind11-native \ | ||
86 | qemu-native \ | ||
87 | snappy \ | ||
88 | tbb \ | ||
89 | " | ||
90 | |||
91 | COMPATIBLE_HOST = '(x86_64).*-linux' | ||
92 | COMPATIBLE_HOST:libc-musl = "null" | ||
93 | |||
94 | PACKAGECONFIG ?= "opencl samples" | ||
95 | PACKAGECONFIG[opencl] = "-DENABLE_INTEL_GPU=TRUE, -DENABLE_INTEL_GPU=FALSE, virtual/opencl-icd opencl-headers opencl-clhpp," | ||
96 | PACKAGECONFIG[python3] = "-DENABLE_PYTHON=ON -DPYTHON_LIBRARY=${PYTHON_LIBRARY} -DPYTHON_INCLUDE_DIR=${PYTHON_INCLUDE_DIR} -DENABLE_PYTHON_PACKAGING=ON, -DENABLE_PYTHON=OFF, patchelf-native, python3 python3-numpy python3-progress" | ||
97 | PACKAGECONFIG[samples] = "-DENABLE_SAMPLES=ON -DENABLE_COMPILE_TOOL=ON, -DENABLE_SAMPLES=OFF -DENABLE_COMPILE_TOOL=OFF, opencv" | ||
98 | PACKAGECONFIG[verbose] = "-DVERBOSE_BUILD=1,-DVERBOSE_BUILD=0" | ||
99 | |||
100 | do_configure:prepend() { | ||
101 | # Dont set PROJECT_ROOT_DIR | ||
102 | sed -i -e 's:\${OpenVINO_SOURCE_DIR}::;' ${S}/src/CMakeLists.txt | ||
103 | |||
104 | # qemu wrapper that can be used by cmake to run target binaries. | ||
105 | qemu_binary="${@qemu_wrapper_cmdline(d, d.getVar('STAGING_DIR_HOST'), [d.expand('${STAGING_DIR_HOST}${libdir}'),d.expand('${STAGING_DIR_HOST}${base_libdir}')])}" | ||
106 | cat > ${WORKDIR}/qemuwrapper << EOF | ||
107 | #!/bin/sh | ||
108 | $qemu_binary "\$@" | ||
109 | EOF | ||
110 | chmod +x ${WORKDIR}/qemuwrapper | ||
111 | } | ||
112 | |||
113 | do_install:append() { | ||
114 | rm -rf ${D}${prefix}/install_dependencies | ||
115 | rm -rf ${D}${prefix}/setupvars.sh | ||
116 | |||
117 | find ${B}/src/plugins/intel_cpu/cross-compiled/ -type f -name *_disp.cpp -exec sed -i -e 's%'"${S}"'%'"${TARGET_DBGSRC_DIR}"'%g' {} + | ||
118 | } | ||
119 | |||
120 | # Otherwise e.g. ros-openvino-toolkit-dynamic-vino-sample when using dldt-inference-engine uses dldt-inference-engine WORKDIR | ||
121 | # instead of RSS | ||
122 | SSTATE_SCAN_FILES:append = " *.cmake" | ||
123 | |||
124 | FILES:${PN} += "\ | ||
125 | ${libdir}/openvino-${PV}/lib*${SOLIBSDEV} \ | ||
126 | ${libdir}/openvino-${PV}/plugins.xml \ | ||
127 | ${libdir}/openvino-${PV}/cache.json \ | ||
128 | " | ||
129 | |||
130 | # Move inference engine samples into a separate package | ||
131 | PACKAGES =+ "${PN}-samples" | ||
132 | |||
133 | FILES:${PN}-samples = "${datadir}/openvino \ | ||
134 | ${bindir} \ | ||
135 | ${libdir}/libformat_reader.a \ | ||
136 | ${libdir}/libopencv_c_wrapper.a \ | ||
137 | " | ||
138 | |||
139 | RDEPENDS:${PN}-samples += "python3-core" | ||
140 | |||
141 | # Package for inference engine python API | ||
142 | PACKAGES =+ "${PN}-python3" | ||
143 | |||
144 | FILES:${PN}-python3 = "${PYTHON_SITEPACKAGES_DIR}" | ||
145 | |||
146 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+\.\d+\.\d+))$" | ||