diff options
author | Yogesh Tyagi <yogesh.tyagi@intel.com> | 2024-02-14 13:57:05 +0530 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2024-02-15 08:47:22 +0800 |
commit | 5c057b4fa322137b95fda6d8e61ec29a12ec2556 (patch) | |
tree | 37a71e4b7ffb124e0832ee2aa2dc4b9135bb2e15 /dynamic-layers | |
parent | 19a72dad311936ab337fc4a06df3ef8c732f1961 (diff) | |
download | meta-intel-5c057b4fa322137b95fda6d8e61ec29a12ec2556.tar.gz |
openvino-inference-engine: fix reproducibility issues
Prevent host paths from getting into target packages. Also prevents buildpaths warnings for files:
| File /usr/src/debug/openvino-inference-engine/2023.3.0/src/plugins/intel_cpu/cross-compiled/attn_memcpy_disp.cpp in package openvino-inference-engine-src contains reference to TMPDIR File
| File /usr/src/debug/openvino-inference-engine/2023.3.0/src/plugins/intel_cpu/cross-compiled/mha_single_token_disp.cpp in package openvino-inference-engine-src contains reference to TMPDIR
| File /usr/src/debug/openvino-inference-engine/2023.3.0/src/plugins/intel_cpu/cross-compiled/softmax_disp.cpp in package openvino-inference-engine-src contains reference to TMPDIR [buildpaths]
Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.3.0.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.3.0.bb b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.3.0.bb index 0ac9a625..ebb6f6f5 100644 --- a/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.3.0.bb +++ b/dynamic-layers/openembedded-layer/recipes-support/opencv/openvino-inference-engine_2023.3.0.bb | |||
@@ -109,7 +109,7 @@ do_install:append() { | |||
109 | rm -rf ${D}${prefix}/install_dependencies | 109 | rm -rf ${D}${prefix}/install_dependencies |
110 | rm -rf ${D}${prefix}/setupvars.sh | 110 | rm -rf ${D}${prefix}/setupvars.sh |
111 | 111 | ||
112 | sed -i -e 's:^#include.*imp.hpp"$:#include "/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/git/src/plugins/intel_cpu/src/nodes/proposal_imp.hpp":g;' ${B}/src/plugins/intel_cpu/cross-compiled/proposal_imp_disp.cpp | 112 | find ${B}/src/plugins/intel_cpu/cross-compiled/ -type f -name *_disp.cpp -exec sed -i -e 's%'"${S}"'%'"${TARGET_DBGSRC_DIR}"'%g' {} + |
113 | } | 113 | } |
114 | 114 | ||
115 | # Otherwise e.g. ros-openvino-toolkit-dynamic-vino-sample when using dldt-inference-engine uses dldt-inference-engine WORKDIR | 115 | # Otherwise e.g. ros-openvino-toolkit-dynamic-vino-sample when using dldt-inference-engine uses dldt-inference-engine WORKDIR |