diff options
author | Anuj Mittal <anuj.mittal@intel.com> | 2024-06-10 14:55:38 +0800 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2024-06-10 15:10:51 +0800 |
commit | 8cbeba772525847331d64aba8b42ce7eebdf7af2 (patch) | |
tree | 862c13122bb22198aaf79654d162de21284405a6 /dynamic-layers | |
parent | 6a2114ac03e39ac63f8de50cd3975935bcd6f0cf (diff) | |
download | meta-intel-8cbeba772525847331d64aba8b42ce7eebdf7af2.tar.gz |
ispc: upgrade 1.23.0 -> 1.24.0
Language changes:
- Added support for non-type template parameters. Uniform integers
and enums can be used now as template parameters.
- Added dot product functions for unsigned and signed int8 and int16
types. They leverage AVX-VNNI and AVX512-VNNI instructions if
supported by targets (docs).
- Added macro definitions for numeric limits.
New targets:
- avx2vnni-i32x4, avx2vnni-i32x8, avx2vnni-i32x16 with AVX-VNNI
instruction support,
- avx512icl-x4, avx512icl-x8, avx512icl-x16, avx512icl-x32 and
avx512icl-x64 with AVX512-VNNI instruction support.
Code generation:
- Fixed generation of code for GPU when unnecessary vectorized
instruction are used during address arithmetic, e.g., for
accessing fields of varying structures (#2846).
- Improved generated code for cases when foreach loop iteration
domain is less than the target width (#2836 ).
Compiler switches behavior:
- --pic command line flag now corresponds to the -fpic flag of Clang
and GCC, whereas the newly introduced --PIC corresponds to -fPIC.
Bug fixes:
- The implementation of round standard library function was aligned
across all targets. It may potentially affect the results of the
code that uses this function for the following targets: avx2-i16x16,
avx2-i8x32 and all avx512 targets (#2793).
- Fixed cases when unwind info were not generated for functions.
This impacted debugging and profiling on Windows (#2842).
- Fixed broken targets sse4-i8xN and avx2-i8xN (#2800).
More details:
https://github.com/ispc/ispc/releases/tag/v1.24.0
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.24.0.bb (renamed from dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.23.0.bb) | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.23.0.bb b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.24.0.bb index ed8df859..55107397 100644 --- a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.23.0.bb +++ b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.24.0.bb | |||
@@ -18,7 +18,7 @@ SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \ | |||
18 | file://run-ptest \ | 18 | file://run-ptest \ |
19 | " | 19 | " |
20 | 20 | ||
21 | SRCREV = "bcb2cf896c00f9a802a11cbf291ef6e44b205416" | 21 | SRCREV = "d394222aef59e4759b06e39ec160e4aba6ee5f40" |
22 | 22 | ||
23 | COMPATIBLE_HOST = '(x86_64).*-linux' | 23 | COMPATIBLE_HOST = '(x86_64).*-linux' |
24 | 24 | ||