diff options
author | Yogesh Tyagi <yogesh.tyagi@intel.com> | 2024-03-11 03:18:56 -0700 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2024-03-11 22:42:52 +0800 |
commit | 8ecf604af20dda1312af5925dc942b3e43c42441 (patch) | |
tree | a91d95218cfc54ca20d482eb3600d4bad11a49fc /dynamic-layers | |
parent | ce7818a5f58c9022c69bc452f7d95e6fc8b38fa9 (diff) | |
download | meta-intel-8ecf604af20dda1312af5925dc942b3e43c42441.tar.gz |
thermald : upgrade 2.5.4 -> 2.5.6
Create a separate variable for branch value and derive the value from PV
so AUH is able to upgrade the recipe.
Release Notes:
https://github.com/intel/thermal_daemon/releases/tag/v2.5.6
Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch | 39 | ||||
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.6.bb (renamed from dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.4.bb) | 3 |
2 files changed, 41 insertions, 1 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch new file mode 100644 index 00000000..270cc84d --- /dev/null +++ b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/files/0001-Makefile-Fix-build-Issue.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From c4c049481d48f33319b1d04cad56d622c4eed65f Mon Sep 17 00:00:00 2001 | ||
2 | From: Yogesh Tyagi <yogesh.tyagi@intel.com> | ||
3 | Date: Mon, 11 Mar 2024 13:13:32 +0800 | ||
4 | Subject: [PATCH] Makefile: Fix build Issue | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | In case build directory is different from source, make sure make is able to find the correct input files. | ||
10 | |||
11 | Fixes: | ||
12 | | dbus-binding-tool --prefix=thd_dbus_interface --mode=glib-server --output=thd_dbus_interface.h ../git/src/thd_dbus_interface.xml | ||
13 | | glib-compile-resources --generate-source thermald-resource.gresource.xml | ||
14 | | Failed to open file “thermald-resource.gresource.xml”: No such file or directory | ||
15 | |||
16 | |||
17 | Upstream-Status: Submitted | ||
18 | https://github.com/intel/thermal_daemon/pull/436 | ||
19 | |||
20 | Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com> | ||
21 | --- | ||
22 | Makefile.am | 2 +- | ||
23 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
24 | |||
25 | diff --git a/Makefile.am b/Makefile.am | ||
26 | index a0c051a..772e280 100644 | ||
27 | --- a/Makefile.am | ||
28 | +++ b/Makefile.am | ||
29 | @@ -95,6 +95,6 @@ thd_dbus_interface.h: $(top_srcdir)/src/thd_dbus_interface.xml | ||
30 | $(AM_V_GEN) dbus-binding-tool --prefix=thd_dbus_interface --mode=glib-server --output=$@ $< | ||
31 | |||
32 | thermald-resource.c: $(top_srcdir)/thermald-resource.gresource.xml | ||
33 | - $(AM_V_GEN) glib-compile-resources --generate-source thermald-resource.gresource.xml | ||
34 | + $(AM_V_GEN) glib-compile-resources --generate-source --sourcedir=${top_srcdir} $< | ||
35 | |||
36 | CLEANFILES = $(BUILT_SOURCES) | ||
37 | -- | ||
38 | 2.34.1 | ||
39 | |||
diff --git a/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.4.bb b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.6.bb index ad66d843..df242cdf 100644 --- a/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.4.bb +++ b/dynamic-layers/openembedded-layer/recipes-bsp/thermald/thermald_2.5.6.bb | |||
@@ -13,9 +13,10 @@ LICENSE = "GPL-2.0-only" | |||
13 | LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848" | 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=ea8831610e926e2e469075b52bf08848" |
14 | 14 | ||
15 | SRC_URI = "git://github.com/intel/thermal_daemon/;branch=master;protocol=https \ | 15 | SRC_URI = "git://github.com/intel/thermal_daemon/;branch=master;protocol=https \ |
16 | file://0001-Makefile-Fix-build-Issue.patch \ | ||
16 | " | 17 | " |
17 | 18 | ||
18 | SRCREV = "63b290f20da115f62f5bbd39a28fa5afe0f6efc2" | 19 | SRCREV = "3990ce2391e5c07293758c056e09e4f2453691b4" |
19 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
20 | 21 | ||
21 | inherit pkgconfig autotools systemd gtk-doc | 22 | inherit pkgconfig autotools systemd gtk-doc |