diff options
author | Yogesh Tyagi <yogesh.tyagi@intel.com> | 2024-08-28 09:55:04 +0530 |
---|---|---|
committer | Anuj Mittal <anuj.mittal@intel.com> | 2024-08-29 09:49:18 +0800 |
commit | 0a46de4a5dce0715727bb2c86f40166d623d5a48 (patch) | |
tree | 538975a857fc51af84815d1222677f1060a11727 /recipes-kernel | |
parent | d6be707bfb2f763c94e9b1e5d4e7317453c9f680 (diff) | |
download | meta-intel-0a46de4a5dce0715727bb2c86f40166d623d5a48.tar.gz |
linux-intel/6.6 : update to tag lts-v6.6.44-linux-240808T092831Z
Move the patches specific to kernel 6.6 to 6.6 recipe
Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-intel.inc | 2 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-intel/0001-6.6-lib-build_OID_registry-fix-reproducibility-issues.patch (renamed from recipes-kernel/linux/linux-intel/0001-lib-build_OID_registry-fix-reproducibility-issues.patch) | 14 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-intel/0001-6.6-vt-conmakehash-improve-reproducibility.patch (renamed from recipes-kernel/linux/linux-intel/0001-vt-conmakehash-improve-reproducibility.patch) | 6 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-intel_6.6.bb | 9 |
4 files changed, 16 insertions, 15 deletions
diff --git a/recipes-kernel/linux/linux-intel.inc b/recipes-kernel/linux/linux-intel.inc index f78f5205..bf42cf8d 100644 --- a/recipes-kernel/linux/linux-intel.inc +++ b/recipes-kernel/linux/linux-intel.inc | |||
@@ -7,8 +7,6 @@ KERNEL_CONFIG_URI ?= "git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;n | |||
7 | 7 | ||
8 | SRC_URI = " \ | 8 | SRC_URI = " \ |
9 | ${KERNEL_CONFIG_URI} \ | 9 | ${KERNEL_CONFIG_URI} \ |
10 | file://0001-vt-conmakehash-improve-reproducibility.patch \ | ||
11 | file://0001-lib-build_OID_registry-fix-reproducibility-issues.patch \ | ||
12 | file://fix-perf-reproducibility.patch \ | 10 | file://fix-perf-reproducibility.patch \ |
13 | file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \ | 11 | file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \ |
14 | file://0002-mconf-fix-output-of-cflags-and-libraries.patch \ | 12 | file://0002-mconf-fix-output-of-cflags-and-libraries.patch \ |
diff --git a/recipes-kernel/linux/linux-intel/0001-lib-build_OID_registry-fix-reproducibility-issues.patch b/recipes-kernel/linux/linux-intel/0001-6.6-lib-build_OID_registry-fix-reproducibility-issues.patch index d41c3f0b..6a734c9c 100644 --- a/recipes-kernel/linux/linux-intel/0001-lib-build_OID_registry-fix-reproducibility-issues.patch +++ b/recipes-kernel/linux/linux-intel/0001-6.6-lib-build_OID_registry-fix-reproducibility-issues.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 2fca0fd719812ea2ff67630b01355aa80481623e Mon Sep 17 00:00:00 2001 | 1 | From 879157a156dd90c8d4c678179d93a2d28766364c Mon Sep 17 00:00:00 2001 |
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | 2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> |
3 | Date: Sun, 10 Jul 2022 22:56:53 -0400 | 3 | Date: Sun, 10 Jul 2022 22:56:53 -0400 |
4 | Subject: [PATCH] lib/build_OID_registry: fix reproducibility issues | 4 | Subject: [PATCH] lib/build_OID_registry: fix reproducibility issues |
@@ -23,26 +23,26 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | |||
23 | 1 file changed, 2 insertions(+), 1 deletion(-) | 23 | 1 file changed, 2 insertions(+), 1 deletion(-) |
24 | 24 | ||
25 | diff --git a/lib/build_OID_registry b/lib/build_OID_registry | 25 | diff --git a/lib/build_OID_registry b/lib/build_OID_registry |
26 | index d7fc32ea8ac2..f6de0a7f7457 100755 | 26 | index 56d8bafeb848..1518e3790674 100755 |
27 | --- a/lib/build_OID_registry | 27 | --- a/lib/build_OID_registry |
28 | +++ b/lib/build_OID_registry | 28 | +++ b/lib/build_OID_registry |
29 | @@ -8,6 +8,7 @@ | 29 | @@ -9,6 +9,7 @@ |
30 | # | ||
31 | 30 | ||
32 | use strict; | 31 | use strict; |
32 | use Cwd qw(abs_path); | ||
33 | +use File::Basename; | 33 | +use File::Basename; |
34 | 34 | ||
35 | my @names = (); | 35 | my @names = (); |
36 | my @oids = (); | 36 | my @oids = (); |
37 | @@ -35,7 +36,7 @@ close IN_FILE || die; | 37 | @@ -38,7 +39,7 @@ close IN_FILE || die; |
38 | # | 38 | # |
39 | open C_FILE, ">$ARGV[1]" or die; | 39 | open C_FILE, ">$ARGV[1]" or die; |
40 | print C_FILE "/*\n"; | 40 | print C_FILE "/*\n"; |
41 | -print C_FILE " * Automatically generated by ", $0, ". Do not edit\n"; | 41 | -print C_FILE " * Automatically generated by ", $0 =~ s#^\Q$abs_srctree/\E##r, ". Do not edit\n"; |
42 | +print C_FILE " * Automatically generated by ", basename $0, ". Do not edit\n"; | 42 | +print C_FILE " * Automatically generated by ", basename $0, ". Do not edit\n"; |
43 | print C_FILE " */\n"; | 43 | print C_FILE " */\n"; |
44 | 44 | ||
45 | # | 45 | # |
46 | -- | 46 | -- |
47 | 2.36.1 | 47 | 2.34.1 |
48 | 48 | ||
diff --git a/recipes-kernel/linux/linux-intel/0001-vt-conmakehash-improve-reproducibility.patch b/recipes-kernel/linux/linux-intel/0001-6.6-vt-conmakehash-improve-reproducibility.patch index 33280063..0ecacb30 100644 --- a/recipes-kernel/linux/linux-intel/0001-vt-conmakehash-improve-reproducibility.patch +++ b/recipes-kernel/linux/linux-intel/0001-6.6-vt-conmakehash-improve-reproducibility.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 0f586f4ee8adacac79b64d1f3d47799a5eb7fbea Mon Sep 17 00:00:00 2001 | 1 | From 2f662283528bc003d0be988bf6590a271ebe7755 Mon Sep 17 00:00:00 2001 |
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | 2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> |
3 | Date: Sun, 10 Jul 2022 21:37:07 -0400 | 3 | Date: Sun, 10 Jul 2022 21:37:07 -0400 |
4 | Subject: [PATCH] vt/conmakehash: improve reproducibility | 4 | Subject: [PATCH] vt/conmakehash: improve reproducibility |
@@ -28,7 +28,7 @@ Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | |||
28 | 2 files changed, 2 insertions(+), 2 deletions(-) | 28 | 2 files changed, 2 insertions(+), 2 deletions(-) |
29 | 29 | ||
30 | diff --git a/drivers/tty/vt/Makefile b/drivers/tty/vt/Makefile | 30 | diff --git a/drivers/tty/vt/Makefile b/drivers/tty/vt/Makefile |
31 | index fe30ce512819..cb51c21b58f9 100644 | 31 | index b3dfe9d5717e..6ee3736776c8 100644 |
32 | --- a/drivers/tty/vt/Makefile | 32 | --- a/drivers/tty/vt/Makefile |
33 | +++ b/drivers/tty/vt/Makefile | 33 | +++ b/drivers/tty/vt/Makefile |
34 | @@ -15,7 +15,7 @@ clean-files := consolemap_deftbl.c defkeymap.c | 34 | @@ -15,7 +15,7 @@ clean-files := consolemap_deftbl.c defkeymap.c |
@@ -54,5 +54,5 @@ index cddd789fe46e..d62510b280e9 100644 | |||
54 | for ( i = 0 ; i < fontlen ; i++ ) | 54 | for ( i = 0 ; i < fontlen ; i++ ) |
55 | { | 55 | { |
56 | -- | 56 | -- |
57 | 2.36.1 | 57 | 2.34.1 |
58 | 58 | ||
diff --git a/recipes-kernel/linux/linux-intel_6.6.bb b/recipes-kernel/linux/linux-intel_6.6.bb index 5c262f5e..f6d6455d 100644 --- a/recipes-kernel/linux/linux-intel_6.6.bb +++ b/recipes-kernel/linux/linux-intel_6.6.bb | |||
@@ -2,6 +2,9 @@ require linux-intel.inc | |||
2 | 2 | ||
3 | SRC_URI:prepend = "git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \ | 3 | SRC_URI:prepend = "git://github.com/intel/linux-intel-lts.git;protocol=https;name=machine;branch=${KBRANCH}; \ |
4 | " | 4 | " |
5 | SRC_URI:append = "file://0001-6.6-vt-conmakehash-improve-reproducibility.patch \ | ||
6 | file://0001-6.6-lib-build_OID_registry-fix-reproducibility-issues.patch \ | ||
7 | " | ||
5 | KBRANCH = "6.6/linux" | 8 | KBRANCH = "6.6/linux" |
6 | KMETA_BRANCH = "yocto-6.6" | 9 | KMETA_BRANCH = "yocto-6.6" |
7 | 10 | ||
@@ -11,9 +14,9 @@ DEPENDS += "elfutils-native openssl-native util-linux-native" | |||
11 | 14 | ||
12 | LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}" | 15 | LINUX_VERSION_EXTENSION ??= "-intel-pk-${LINUX_KERNEL_TYPE}" |
13 | 16 | ||
14 | LINUX_VERSION ?= "6.6.30" | 17 | LINUX_VERSION ?= "6.6.44" |
15 | SRCREV_machine ?= "86a43fc66c95e24b7cc9e3adf2f4874b589bf9d5" | 18 | SRCREV_machine ?= "b013322897f67589f5806ea4c7db0665f7b99d9f" |
16 | SRCREV_meta ?= "66bebb6789d02e775d4c93d7ca4bf79c2ead4b28" | 19 | SRCREV_meta ?= "9901a21dd1f99c833d8e1a58b3fc057e57bda598" |
17 | 20 | ||
18 | # Functionality flags | 21 | # Functionality flags |
19 | KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc \ | 22 | KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc \ |