diff options
-rw-r--r-- | recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch | 15 | ||||
-rw-r--r-- | recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch | 42 | ||||
-rw-r--r-- | recipes-graphics/gmmlib/gmmlib_22.3.18.bb (renamed from recipes-graphics/gmmlib/gmmlib_22.3.15.bb) | 3 |
3 files changed, 7 insertions, 53 deletions
diff --git a/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch b/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch index 825c1f18..195b3c58 100644 --- a/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch +++ b/recipes-graphics/gmmlib/files/0001-Add-new-DG2-device-IDs-194.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 8729d66800995a9b7e693bd78249932bd12383e1 Mon Sep 17 00:00:00 2001 | 1 | From 683f3552e7d5089601bb37952641b1c7691cf475 Mon Sep 17 00:00:00 2001 |
2 | From: John Machado <john.machado@intel.com> | 2 | From: John Machado <john.machado@intel.com> |
3 | Date: Mon, 25 Mar 2024 11:13:27 +0530 | 3 | Date: Mon, 25 Mar 2024 11:13:27 +0530 |
4 | Subject: [PATCH] Add new DG2 device IDs (#194) | 4 | Subject: [PATCH] Add new DG2 device IDs (#194) |
@@ -11,10 +11,10 @@ Signed-off-by: Hoe, Sheng Yang <sheng.yang.hoe@intel.com> | |||
11 | 1 file changed, 4 insertions(+) | 11 | 1 file changed, 4 insertions(+) |
12 | 12 | ||
13 | diff --git a/Source/inc/common/igfxfmid.h b/Source/inc/common/igfxfmid.h | 13 | diff --git a/Source/inc/common/igfxfmid.h b/Source/inc/common/igfxfmid.h |
14 | index 7969779..8e2c955 100644 | 14 | index 1264087..e944e1e 100644 |
15 | --- a/Source/inc/common/igfxfmid.h | 15 | --- a/Source/inc/common/igfxfmid.h |
16 | +++ b/Source/inc/common/igfxfmid.h | 16 | +++ b/Source/inc/common/igfxfmid.h |
17 | @@ -1932,6 +1932,8 @@ typedef enum __NATIVEGTTYPE | 17 | @@ -1934,6 +1934,8 @@ typedef enum __NATIVEGTTYPE |
18 | #define DEV_ID_56BB 0x56BB | 18 | #define DEV_ID_56BB 0x56BB |
19 | #define DEV_ID_56BC 0x56BC | 19 | #define DEV_ID_56BC 0x56BC |
20 | #define DEV_ID_56BD 0x56BD | 20 | #define DEV_ID_56BD 0x56BD |
@@ -22,16 +22,13 @@ index 7969779..8e2c955 100644 | |||
22 | +#define DEV_ID_56BF 0x56BF | 22 | +#define DEV_ID_56BF 0x56BF |
23 | #define DEV_ID_56C0 0x56C0 | 23 | #define DEV_ID_56C0 0x56C0 |
24 | #define DEV_ID_56C1 0x56C1 | 24 | #define DEV_ID_56C1 0x56C1 |
25 | 25 | #define DEV_ID_56C2 0x56C2 | |
26 | @@ -1992,6 +1994,8 @@ typedef enum __NATIVEGTTYPE | 26 | @@ -2001,6 +2003,8 @@ typedef enum __NATIVEGTTYPE |
27 | ( d == DEV_ID_5690 ) || \ | 27 | ( d == DEV_ID_5690 ) || \ |
28 | ( d == DEV_ID_5691 ) || \ | 28 | ( d == DEV_ID_5691 ) || \ |
29 | ( d == DEV_ID_5692 ) || \ | 29 | ( d == DEV_ID_5692 ) || \ |
30 | + ( d == DEV_ID_56BE ) || \ | 30 | + ( d == DEV_ID_56BE ) || \ |
31 | + ( d == DEV_ID_56BF ) || \ | 31 | + ( d == DEV_ID_56BF ) || \ |
32 | ( d == DEV_ID_56C0 ) || \ | 32 | ( d == DEV_ID_56C0 ) || \ |
33 | ( d == DEV_ID_56C2 ) || \ | ||
33 | ( d == DEV_ID_4F80 ) || \ | 34 | ( d == DEV_ID_4F80 ) || \ |
34 | ( d == DEV_ID_4F81 ) || \ | ||
35 | -- | ||
36 | 2.34.1 | ||
37 | |||
diff --git a/recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch b/recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch deleted file mode 100644 index ab4cb178..00000000 --- a/recipes-graphics/gmmlib/files/0001-Introduce-ARL-H-support-172.patch +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | From 2b267b72d6aaa922861b120da9c1543161797046 Mon Sep 17 00:00:00 2001 | ||
2 | From: John Machado <john.machado@intel.com> | ||
3 | Date: Fri, 9 Feb 2024 13:10:18 +0530 | ||
4 | Subject: [PATCH] Introduce ARL-H support (#172) | ||
5 | |||
6 | Upstream-Status: Backport [https://github.com/intel/gmmlib/commit/544a8be6f66631e085c86c453aafd78b0e7f5179] | ||
7 | Signed-off-by: Lim Siew Hoon <siew.hoon.lim@intel.com> | ||
8 | --- | ||
9 | Source/inc/common/igfxfmid.h | 10 ++++++++++ | ||
10 | 1 file changed, 10 insertions(+) | ||
11 | |||
12 | diff --git a/Source/inc/common/igfxfmid.h b/Source/inc/common/igfxfmid.h | ||
13 | index 99fc624..19aa505 100644 | ||
14 | --- a/Source/inc/common/igfxfmid.h | ||
15 | +++ b/Source/inc/common/igfxfmid.h | ||
16 | @@ -1966,6 +1966,11 @@ typedef enum __NATIVEGTTYPE | ||
17 | // ARL-S | ||
18 | #define DEV_ID_7D67 0x7D67 | ||
19 | |||
20 | +// ARL-H | ||
21 | +#define DEV_ID_7D41 0x7D41 | ||
22 | +#define DEV_ID_7D51 0x7D51 | ||
23 | +#define DEV_ID_7DD1 0x7DD1 | ||
24 | + | ||
25 | #define MGM_HAS 0 | ||
26 | |||
27 | //#define SDG_HAS 1 //Reserve place for Springdale-G HAS | ||
28 | @@ -2012,6 +2017,11 @@ typedef enum __NATIVEGTTYPE | ||
29 | // Macro to identify ARL-S Device ID | ||
30 | #define GFX_IS_ARL_S(d) ( ( d == DEV_ID_7D67 ) ) | ||
31 | |||
32 | +// Macro to identify ARL-H Device ID | ||
33 | +#define GFX_IS_ARL_H(d) ( ( d == DEV_ID_7D41 ) || \ | ||
34 | + ( d == DEV_ID_7D51 ) || \ | ||
35 | + ( d == DEV_ID_7DD1 )) | ||
36 | + | ||
37 | //we define the highest cap and lower cap of stepping IDs | ||
38 | #define SI_REV_ID(lo,hi) (lo | hi<<16) | ||
39 | |||
40 | -- | ||
41 | 2.40.1 | ||
42 | |||
diff --git a/recipes-graphics/gmmlib/gmmlib_22.3.15.bb b/recipes-graphics/gmmlib/gmmlib_22.3.18.bb index 875fbaf5..134a6461 100644 --- a/recipes-graphics/gmmlib/gmmlib_22.3.15.bb +++ b/recipes-graphics/gmmlib/gmmlib_22.3.18.bb | |||
@@ -8,11 +8,10 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=465fe90caea3edd6a2cecb3f0c28a654" | |||
8 | 8 | ||
9 | SRC_URI = " \ | 9 | SRC_URI = " \ |
10 | git://github.com/intel/gmmlib.git;protocol=https;branch=master \ | 10 | git://github.com/intel/gmmlib.git;protocol=https;branch=master \ |
11 | file://0001-Introduce-ARL-H-support-172.patch \ | ||
12 | file://0001-Add-new-DG2-device-IDs-194.patch \ | 11 | file://0001-Add-new-DG2-device-IDs-194.patch \ |
13 | " | 12 | " |
14 | 13 | ||
15 | SRCREV = "5fb4180e22695ad4e3c155cf680119913c9f44bc" | 14 | SRCREV = "ac964bdffdda7730e8234511f61016071e63783b" |
16 | 15 | ||
17 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
18 | 17 | ||