diff options
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch | 43 |
1 files changed, 43 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch new file mode 100644 index 00000000..b886b95d --- /dev/null +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/dont-use-ld-library-path.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | From 2475dfc1350f73a243c9fc223a9f06af85321d56 Mon Sep 17 00:00:00 2001 | ||
2 | From: Anuj Mittal <anuj.mittal@intel.com> | ||
3 | Date: Tue, 2 Jul 2019 08:36:34 +0800 | ||
4 | Subject: [PATCH] don't use LD_LIBRARY_PATH for native offline compiler | ||
5 | |||
6 | Let us supply the correct path for it to be able to find the correct | ||
7 | libraries. | ||
8 | |||
9 | Upstream-Status: Inappropriate | ||
10 | |||
11 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
12 | |||
13 | --- | ||
14 | runtime/built_ins/kernels/CMakeLists.txt | 2 +- | ||
15 | runtime/scheduler/scheduler_binary.cmake | 2 +- | ||
16 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
17 | |||
18 | diff --git a/runtime/built_ins/kernels/CMakeLists.txt b/runtime/built_ins/kernels/CMakeLists.txt | ||
19 | index 5dc9fe1b..e258847d 100644 | ||
20 | --- a/runtime/built_ins/kernels/CMakeLists.txt | ||
21 | +++ b/runtime/built_ins/kernels/CMakeLists.txt | ||
22 | @@ -51,7 +51,7 @@ function(compile_builtin gen_type platform_type builtin) | ||
23 | if(DEFINED IGDRCL__IGC_LIBRARY_PATH) | ||
24 | set(cloc_cmd_prefix LD_LIBRARY_PATH=${IGDRCL__IGC_LIBRARY_PATH} $<TARGET_FILE:ocloc>) | ||
25 | else() | ||
26 | - set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc> $<TARGET_FILE:ocloc>) | ||
27 | + set(cloc_cmd_prefix ocloc) | ||
28 | endif() | ||
29 | endif() | ||
30 | list(APPEND __cloc__options__ "-cl-kernel-arg-info") | ||
31 | diff --git a/runtime/scheduler/scheduler_binary.cmake b/runtime/scheduler/scheduler_binary.cmake | ||
32 | index 1b12592b..ed9f375d 100644 | ||
33 | --- a/runtime/scheduler/scheduler_binary.cmake | ||
34 | +++ b/runtime/scheduler/scheduler_binary.cmake | ||
35 | @@ -37,7 +37,7 @@ function(compile_kernel target gen_type platform_type kernel) | ||
36 | if(DEFINED IGDRCL__IGC_LIBRARY_PATH) | ||
37 | set(cloc_cmd_prefix LD_LIBRARY_PATH=${IGDRCL__IGC_LIBRARY_PATH} $<TARGET_FILE:ocloc>) | ||
38 | else() | ||
39 | - set(cloc_cmd_prefix LD_LIBRARY_PATH=$<TARGET_FILE_DIR:ocloc> $<TARGET_FILE:ocloc>) | ||
40 | + set(cloc_cmd_prefix ocloc) | ||
41 | endif() | ||
42 | endif() | ||
43 | list(APPEND __cloc__options__ "-cl-kernel-arg-info") | ||