diff options
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.39.31294.12.bb')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.39.31294.12.bb | 64 |
1 files changed, 64 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.39.31294.12.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.39.31294.12.bb new file mode 100644 index 00000000..1d3c4951 --- /dev/null +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.39.31294.12.bb | |||
@@ -0,0 +1,64 @@ | |||
1 | SUMMARY = "The Intel(R) Graphics Compute Runtime for OpenCL(TM)" | ||
2 | DESCRIPTION = "The Intel(R) Graphics Compute Runtime for OpenCL(TM) \ | ||
3 | is an open source project to converge Intel's development efforts \ | ||
4 | on OpenCL(TM) compute stacks supporting the GEN graphics hardware \ | ||
5 | architecture." | ||
6 | |||
7 | LICENSE = "MIT & Apache-2.0" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eca6ec6997e18db166db7109cdbe611c \ | ||
9 | file://third_party/opencl_headers/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
10 | |||
11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/24.39 \ | ||
12 | file://0001-intel-compute-runtime-fix-build-with-gcc13.patch \ | ||
13 | file://0002-Build-not-able-to-locate-cpp_generation_tool.patch \ | ||
14 | file://0003-external-ocloc.patch \ | ||
15 | " | ||
16 | |||
17 | SRCREV = "625e7e0d87e3df7a0eb5dae88452092366c8f85b" | ||
18 | |||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | DEPENDS += " intel-graphics-compiler gmmlib libva qemu-native" | ||
22 | |||
23 | RDEPENDS:${PN} += " intel-graphics-compiler gmmlib" | ||
24 | |||
25 | inherit cmake pkgconfig qemu | ||
26 | |||
27 | COMPATIBLE_HOST = '(x86_64).*-linux' | ||
28 | COMPATIBLE_HOST:libc-musl = "null" | ||
29 | |||
30 | EXTRA_OECMAKE = " \ | ||
31 | -DIGC_DIR=${STAGING_INCDIR}/igc \ | ||
32 | -DBUILD_TYPE=Release \ | ||
33 | -DSKIP_UNIT_TESTS=1 \ | ||
34 | -DCCACHE_ALLOWED=FALSE \ | ||
35 | -DNEO_DISABLE_LD_LLD=ON \ | ||
36 | -DNEO_DISABLE_LD_GOLD=ON \ | ||
37 | " | ||
38 | |||
39 | EXTRA_OECMAKE:append:class-target = " \ | ||
40 | -Docloc_cmd_prefix=ocloc \ | ||
41 | -DCMAKE_CROSSCOMPILING_EMULATOR=${WORKDIR}/qemuwrapper \ | ||
42 | " | ||
43 | |||
44 | PACKAGECONFIG ??= "" | ||
45 | PACKAGECONFIG[levelzero] = "-DBUILD_WITH_L0=ON, -DBUILD_WITH_L0=OFF, level-zero" | ||
46 | |||
47 | do_configure:prepend:class-target () { | ||
48 | # Write out a qemu wrapper that will be used by cmake. | ||
49 | qemu_binary="${@qemu_wrapper_cmdline(d, d.getVar('STAGING_DIR_HOST'), [d.expand('${B}/bin'),d.expand('${STAGING_DIR_HOST}${libdir}'),d.expand('${STAGING_DIR_HOST}${base_libdir}')])}" | ||
50 | cat > ${WORKDIR}/qemuwrapper << EOF | ||
51 | #!/bin/sh | ||
52 | $qemu_binary "\$@" | ||
53 | EOF | ||
54 | chmod +x ${WORKDIR}/qemuwrapper | ||
55 | } | ||
56 | |||
57 | FILES:${PN} += " \ | ||
58 | ${libdir}/intel-opencl/libigdrcl.so \ | ||
59 | ${libdir}/libocloc.so \ | ||
60 | " | ||
61 | |||
62 | FILES:${PN}-dev = "${includedir}" | ||
63 | |||
64 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" | ||