diff options
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_25.13.33276.16.bb')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_25.13.33276.16.bb | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_25.13.33276.16.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_25.13.33276.16.bb new file mode 100644 index 00000000..635e8c2f --- /dev/null +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_25.13.33276.16.bb | |||
@@ -0,0 +1,63 @@ | |||
1 | SUMMARY = "The Intel(R) Graphics Compute Runtime for OpenCL(TM)" | ||
2 | DESCRIPTION = "The Intel(R) Graphics Compute Runtime for OpenCL(TM) \ | ||
3 | is an open source project to converge Intel's development efforts \ | ||
4 | on OpenCL(TM) compute stacks supporting the GEN graphics hardware \ | ||
5 | architecture." | ||
6 | |||
7 | LICENSE = "MIT & Apache-2.0" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eca6ec6997e18db166db7109cdbe611c \ | ||
9 | file://third_party/opencl_headers/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
10 | |||
11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/25.13 \ | ||
12 | file://0002-Build-not-able-to-locate-cpp_generation_tool.patch \ | ||
13 | file://0003-external-ocloc.patch \ | ||
14 | " | ||
15 | |||
16 | SRCREV = "a9961bdfaa07250fd52ff930bf8f31fb4e3b7799" | ||
17 | |||
18 | S = "${WORKDIR}/git" | ||
19 | |||
20 | DEPENDS += " intel-graphics-compiler gmmlib libva qemu-native" | ||
21 | |||
22 | RDEPENDS:${PN} += " intel-graphics-compiler gmmlib" | ||
23 | |||
24 | inherit cmake pkgconfig qemu | ||
25 | |||
26 | COMPATIBLE_HOST = '(x86_64).*-linux' | ||
27 | COMPATIBLE_HOST:libc-musl = "null" | ||
28 | |||
29 | EXTRA_OECMAKE = " \ | ||
30 | -DIGC_DIR=${STAGING_INCDIR}/igc \ | ||
31 | -DBUILD_TYPE=Release \ | ||
32 | -DSKIP_UNIT_TESTS=1 \ | ||
33 | -DCCACHE_ALLOWED=FALSE \ | ||
34 | -DNEO_DISABLE_LD_LLD=ON \ | ||
35 | -DNEO_DISABLE_LD_GOLD=ON \ | ||
36 | " | ||
37 | |||
38 | EXTRA_OECMAKE:append:class-target = " \ | ||
39 | -Docloc_cmd_prefix=ocloc \ | ||
40 | -DCMAKE_CROSSCOMPILING_EMULATOR=${WORKDIR}/qemuwrapper \ | ||
41 | " | ||
42 | |||
43 | PACKAGECONFIG ??= "" | ||
44 | PACKAGECONFIG[levelzero] = "-DBUILD_WITH_L0=ON, -DBUILD_WITH_L0=OFF, level-zero" | ||
45 | |||
46 | do_configure:prepend:class-target () { | ||
47 | # Write out a qemu wrapper that will be used by cmake. | ||
48 | qemu_binary="${@qemu_wrapper_cmdline(d, d.getVar('STAGING_DIR_HOST'), [d.expand('${B}/bin'),d.expand('${STAGING_DIR_HOST}${libdir}'),d.expand('${STAGING_DIR_HOST}${base_libdir}')])}" | ||
49 | cat > ${WORKDIR}/qemuwrapper << EOF | ||
50 | #!/bin/sh | ||
51 | $qemu_binary "\$@" | ||
52 | EOF | ||
53 | chmod +x ${WORKDIR}/qemuwrapper | ||
54 | } | ||
55 | |||
56 | FILES:${PN} += " \ | ||
57 | ${libdir}/intel-opencl/libigdrcl.so \ | ||
58 | ${libdir}/libocloc.so \ | ||
59 | " | ||
60 | |||
61 | FILES:${PN}-dev = "${includedir}" | ||
62 | |||
63 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)" | ||