summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/compute-runtime
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/compute-runtime')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch27
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_25.13.33276.16.bb (renamed from dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.39.31294.12.bb)5
2 files changed, 2 insertions, 30 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch
deleted file mode 100644
index bc718eed..00000000
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-intel-compute-runtime-fix-build-with-gcc13.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From a40ed1c5274f867385610bb57ceee75bf4722de9 Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Tue, 30 May 2023 09:03:01 +0800
4Subject: [PATCH 1/5] intel-compute-runtime: fix build with gcc13
5
6Upstream-Status: Inappropriate
7Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
8---
9 CMakeLists.txt | 2 +-
10 1 file changed, 1 insertion(+), 1 deletion(-)
11
12diff --git a/CMakeLists.txt b/CMakeLists.txt
13index 5e43b4ad76..619243913b 100644
14--- a/CMakeLists.txt
15+++ b/CMakeLists.txt
16@@ -811,7 +811,7 @@ if(NOT MSVC)
17 set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-noexcept-type") # Added for gtest
18 endif()
19 endif()
20- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Werror=vla")
21+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror=vla")
22
23 if(USE_SANITIZE_UB)
24 check_cxx_compiler_flag(-fsanitize=undefined COMPILER_SUPPORTS_UNDEFINED_BEHAVIOR_SANITIZER)
25--
262.34.1
27
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.39.31294.12.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_25.13.33276.16.bb
index 1d3c4951..635e8c2f 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_24.39.31294.12.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_25.13.33276.16.bb
@@ -8,13 +8,12 @@ LICENSE = "MIT & Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eca6ec6997e18db166db7109cdbe611c \ 8LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eca6ec6997e18db166db7109cdbe611c \
9 file://third_party/opencl_headers/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" 9 file://third_party/opencl_headers/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
10 10
11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/24.39 \ 11SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=releases/25.13 \
12 file://0001-intel-compute-runtime-fix-build-with-gcc13.patch \
13 file://0002-Build-not-able-to-locate-cpp_generation_tool.patch \ 12 file://0002-Build-not-able-to-locate-cpp_generation_tool.patch \
14 file://0003-external-ocloc.patch \ 13 file://0003-external-ocloc.patch \
15 " 14 "
16 15
17SRCREV = "625e7e0d87e3df7a0eb5dae88452092366c8f85b" 16SRCREV = "a9961bdfaa07250fd52ff930bf8f31fb4e3b7799"
18 17
19S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
20 19