summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/clang-layer/recipes-opencl/igc
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl/igc')
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-SPIRVutil-Include-cstdint-to-fix-GCC-13-build.patch29
-rw-r--r--dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11702.1.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-SPIRVutil-Include-cstdint-to-fix-GCC-13-build.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-SPIRVutil-Include-cstdint-to-fix-GCC-13-build.patch
new file mode 100644
index 00000000..4b1078e1
--- /dev/null
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/0001-SPIRVutil-Include-cstdint-to-fix-GCC-13-build.patch
@@ -0,0 +1,29 @@
1From 5ea17d8bcf3daa03ef95d0fed796f68cec7dc32d Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Franti=C5=A1ek=20Zatloukal?= <fzatlouk@redhat.com>
3Date: Wed, 18 Jan 2023 22:22:23 +0000
4Subject: [PATCH] SPIRVutil: Include cstdint to fix GCC 13 build
5
6SPIRVutil: Include cstdint to fix GCC 13 build
7
8Upstream-Status: Backport [https://github.com/intel-innersource/drivers.gpu.compiler.staging/commit/5ea17d8bcf3daa03ef95d0fed796f68cec7dc32d]
9
10Signed-off-by: Yogesh Tyagi <yogesh.tyagi@intel.com>
11---
12 IGC/AdaptorOCL/SPIRV/libSPIRV/SPIRVUtil.h | 1 +
13 1 file changed, 1 insertion(+)
14
15diff --git a/IGC/AdaptorOCL/SPIRV/libSPIRV/SPIRVUtil.h b/IGC/AdaptorOCL/SPIRV/libSPIRV/SPIRVUtil.h
16index 1076d5d42..9685e477f 100644
17--- a/IGC/AdaptorOCL/SPIRV/libSPIRV/SPIRVUtil.h
18+++ b/IGC/AdaptorOCL/SPIRV/libSPIRV/SPIRVUtil.h
19@@ -49,6 +49,7 @@ THE SOFTWARE.
20 #define SPIRVUTIL_H_
21
22 #include <algorithm>
23+#include <cstdint>
24 #include <functional>
25 #include <limits>
26 #include <map>
27--
282.34.1
29
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11702.1.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11702.1.bb
index 7a994ebe..354732d5 100644
--- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11702.1.bb
+++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.11702.1.bb
@@ -14,6 +14,7 @@ SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;nam
14 git://github.com/KhronosGroup/SPIRV-Headers.git;protocol=https;destsuffix=SPIRV-Headers;name=spirv-headers;branch=master \ 14 git://github.com/KhronosGroup/SPIRV-Headers.git;protocol=https;destsuffix=SPIRV-Headers;name=spirv-headers;branch=master \
15 file://0003-Improve-Reproducibility-for-src-package.patch \ 15 file://0003-Improve-Reproducibility-for-src-package.patch \
16 file://0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch \ 16 file://0001-BiF-CMakeLists.txt-remove-opt-from-DEPENDS.patch \
17 file://0001-SPIRVutil-Include-cstdint-to-fix-GCC-13-build.patch \
17 " 18 "
18 19
19SRC_URI:append:class-native = " file://0001-fix-tblgen.patch" 20SRC_URI:append:class-native = " file://0001-fix-tblgen.patch"