diff options
Diffstat (limited to 'dynamic-layers/clang-layer/recipes-opencl')
2 files changed, 26 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-fix-add-missing-zero-initialization-in-StackVec-clas.patch b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-fix-add-missing-zero-initialization-in-StackVec-clas.patch new file mode 100644 index 00000000..4aed37b8 --- /dev/null +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime/0001-fix-add-missing-zero-initialization-in-StackVec-clas.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From 894bab05efb447d249c9f0afdbf0ca62c82395c6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Mateusz Jablonski <mateusz.jablonski@intel.com> | ||
3 | Date: Tue, 22 Aug 2023 10:55:50 +0000 | ||
4 | Subject: [PATCH] fix: add missing zero-initialization in StackVec class | ||
5 | |||
6 | Upstream-Status: Backport [https://github.com/intel/compute-runtime/commit/894bab05efb447d249c9f0afdbf0ca62c82395c6] | ||
7 | |||
8 | Signed-off-by: Mateusz Jablonski <mateusz.jablonski@intel.com> | ||
9 | --- | ||
10 | shared/source/utilities/stackvec.h | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | Index: git/shared/source/utilities/stackvec.h | ||
14 | =================================================================== | ||
15 | --- git.orig/shared/source/utilities/stackvec.h | ||
16 | +++ git/shared/source/utilities/stackvec.h | ||
17 | @@ -431,7 +431,7 @@ class StackVec { // NOLINT(clang-analyze | ||
18 | DataType *onStackMem; | ||
19 | }; | ||
20 | |||
21 | - alignas(alignof(DataType)) char onStackMemRawBytes[sizeof(DataType[onStackCaps])]; | ||
22 | + alignas(alignof(DataType)) char onStackMemRawBytes[sizeof(DataType[onStackCaps])]{}; | ||
23 | SizeT onStackSize = 0U; | ||
24 | }; | ||
25 | |||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.31.23852.bb b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.31.23852.bb index ebf69af2..9bbbb3a7 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.31.23852.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/compute-runtime/intel-compute-runtime_22.31.23852.bb | |||
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9280143b568466d8fbe385f838078b93 \ | |||
9 | file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b" | 9 | file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=master \ | 11 | SRC_URI = "git://github.com/intel/compute-runtime.git;protocol=https;branch=master \ |
12 | file://0001-fix-add-missing-zero-initialization-in-StackVec-clas.patch \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | SRC_URI:append:class-target = "file://allow-to-find-cpp-generation-tool.patch \ | 15 | SRC_URI:append:class-target = "file://allow-to-find-cpp-generation-tool.patch \ |