diff options
Diffstat (limited to 'dynamic-layers/clang-layer')
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-build-with-llvm12.patch | 29 | ||||
-rw-r--r-- | dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.12812.9.bb | 1 |
2 files changed, 30 insertions, 0 deletions
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-build-with-llvm12.patch b/dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-build-with-llvm12.patch new file mode 100644 index 00000000..fb29c940 --- /dev/null +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/files/fix-build-with-llvm12.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | The condition should be checking for <= 11 since the change is available | ||
2 | in LLVM12: | ||
3 | https://github.com/llvm/llvm-project/commit/322d0afd875df66b36e4810a2b95c20a8f22ab9b | ||
4 | |||
5 | Upstream-Status: Submitted | ||
6 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | ||
7 | |||
8 | diff --git a/IGC/VectorCompiler/lib/GenXCodeGen/GenXSimdCFRegion.cpp b/IGC/VectorCompiler/lib/GenXCodeGen/GenXSimdCFRegion.cpp | ||
9 | index 363d622c2..bbb04be30 100644 | ||
10 | --- a/IGC/VectorCompiler/lib/GenXCodeGen/GenXSimdCFRegion.cpp | ||
11 | +++ b/IGC/VectorCompiler/lib/GenXCodeGen/GenXSimdCFRegion.cpp | ||
12 | @@ -395,7 +395,7 @@ public: | ||
13 | return GenXIntrinsic::getGenXIntrinsicID(V) == | ||
14 | GenXIntrinsic::genx_all || | ||
15 | CI->getIntrinsicID() == | ||
16 | -#if LLVM_VERSION_MAJOR <= 12 | ||
17 | +#if LLVM_VERSION_MAJOR <= 11 | ||
18 | Intrinsic::experimental_vector_reduce_and; | ||
19 | #else | ||
20 | Intrinsic::vector_reduce_and; | ||
21 | @@ -408,7 +408,7 @@ public: | ||
22 | if (const CallInst *CI = dyn_cast<CallInst>(V)) | ||
23 | return GenXIntrinsic::getGenXIntrinsicID(V) == | ||
24 | GenXIntrinsic::genx_any || CI->getIntrinsicID() == | ||
25 | -#if LLVM_VERSION_MAJOR <= 12 | ||
26 | +#if LLVM_VERSION_MAJOR <= 11 | ||
27 | Intrinsic::experimental_vector_reduce_or; | ||
28 | #else | ||
29 | Intrinsic::vector_reduce_or; | ||
diff --git a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.12812.9.bb b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.12812.9.bb index 4cfe7133..e5a3f858 100644 --- a/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.12812.9.bb +++ b/dynamic-layers/clang-layer/recipes-opencl/igc/intel-graphics-compiler_1.0.12812.9.bb | |||
@@ -17,6 +17,7 @@ SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https;nam | |||
17 | file://c707d1e2244aec988bdd5d2a7473ef3a32a5bac7.patch \ | 17 | file://c707d1e2244aec988bdd5d2a7473ef3a32a5bac7.patch \ |
18 | file://d1761dfc3ca6b54bac0ee213389a65f84d2aa9b7.patch \ | 18 | file://d1761dfc3ca6b54bac0ee213389a65f84d2aa9b7.patch \ |
19 | file://e09e752949e7af0231884d1b11ea907e3e8b1611.patch \ | 19 | file://e09e752949e7af0231884d1b11ea907e3e8b1611.patch \ |
20 | file://fix-build-with-llvm12.patch \ | ||
20 | " | 21 | " |
21 | 22 | ||
22 | SRC_URI:append:class-native = " file://0001-fix-tblgen.patch" | 23 | SRC_URI:append:class-native = " file://0001-fix-tblgen.patch" |