diff options
Diffstat (limited to 'recipes-core/microcode/intel-microcode_20250211.bb')
-rw-r--r-- | recipes-core/microcode/intel-microcode_20250211.bb | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/recipes-core/microcode/intel-microcode_20250211.bb b/recipes-core/microcode/intel-microcode_20250211.bb new file mode 100644 index 00000000..ee69a115 --- /dev/null +++ b/recipes-core/microcode/intel-microcode_20250211.bb | |||
@@ -0,0 +1,63 @@ | |||
1 | SUMMARY = "Intel Processor Microcode Datafile for Linux" | ||
2 | HOMEPAGE = "http://www.intel.com/" | ||
3 | DESCRIPTION = "The microcode data file contains the latest microcode\ | ||
4 | definitions for all Intel processors. Intel releases microcode updates\ | ||
5 | to correct processor behavior as documented in the respective processor\ | ||
6 | specification updates. While the regular approach to getting this microcode\ | ||
7 | update is via a BIOS upgrade, Intel realizes that this can be an\ | ||
8 | administrative hassle. The Linux operating system and VMware ESX\ | ||
9 | products have a mechanism to update the microcode after booting.\ | ||
10 | For example, this file will be used by the operating system mechanism\ | ||
11 | if the file is placed in the /etc/firmware directory of the Linux system." | ||
12 | |||
13 | LICENSE = "Intel-Microcode-License" | ||
14 | LIC_FILES_CHKSUM = "file://license;md5=d8405101ec6e90c1d84b082b0c40c721" | ||
15 | |||
16 | SRC_URI = "git://github.com/intel/Intel-Linux-Processor-Microcode-Data-Files.git;protocol=https;branch=main \ | ||
17 | " | ||
18 | |||
19 | SRCREV = "8a62de41c011615d749f8e72bb906dddc72e56a8" | ||
20 | |||
21 | DEPENDS = "iucode-tool-native" | ||
22 | S = "${WORKDIR}/git" | ||
23 | |||
24 | COMPATIBLE_HOST = "(i.86|x86_64).*-linux" | ||
25 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
26 | |||
27 | inherit deploy | ||
28 | |||
29 | # Use any of the iucode_tool parameters to filter specific microcodes from the data file | ||
30 | # For further information, check the iucode-tool's manpage : http://manned.org/iucode-tool | ||
31 | UCODE_FILTER_PARAMETERS ?= "" | ||
32 | |||
33 | do_compile() { | ||
34 | ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \ | ||
35 | ${UCODE_FILTER_PARAMETERS} \ | ||
36 | --overwrite \ | ||
37 | --write-earlyfw=${WORKDIR}/microcode_${PV}.cpio \ | ||
38 | ${S}/intel-ucode/* ${S}/intel-ucode-with-caveats/* | ||
39 | } | ||
40 | |||
41 | do_install() { | ||
42 | install -d ${D}${nonarch_base_libdir}/firmware/intel-ucode/ | ||
43 | ${STAGING_DIR_NATIVE}${sbindir_native}/iucode_tool \ | ||
44 | ${UCODE_FILTER_PARAMETERS} \ | ||
45 | --write-firmware=${D}${nonarch_base_libdir}/firmware/intel-ucode \ | ||
46 | ${S}/intel-ucode/* ${S}/intel-ucode-with-caveats/* | ||
47 | } | ||
48 | |||
49 | do_deploy() { | ||
50 | install -d ${DEPLOYDIR} | ||
51 | install ${WORKDIR}/microcode_${PV}.cpio ${DEPLOYDIR}/ | ||
52 | cd ${DEPLOYDIR} | ||
53 | rm -f microcode.cpio | ||
54 | ln -sf microcode_${PV}.cpio microcode.cpio | ||
55 | } | ||
56 | |||
57 | addtask deploy before do_build after do_compile | ||
58 | |||
59 | PACKAGES = "${PN}" | ||
60 | |||
61 | FILES:${PN} = "${nonarch_base_libdir}" | ||
62 | |||
63 | UPSTREAM_CHECK_GITTAGREGEX = "^microcode-(?P<pver>(\d+)[a-z]*)$" | ||