summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/vpl/libvpl-tools_1.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/vpl/libvpl-tools_1.3.0.bb')
-rw-r--r--recipes-multimedia/vpl/libvpl-tools_1.3.0.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-multimedia/vpl/libvpl-tools_1.3.0.bb b/recipes-multimedia/vpl/libvpl-tools_1.3.0.bb
new file mode 100644
index 00000000..b1558f83
--- /dev/null
+++ b/recipes-multimedia/vpl/libvpl-tools_1.3.0.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Intel Video Processing Library Tools"
2DESCRIPTION = "Intel Video Processing Library (VPL) Tools provides \
3access to hardware accelerated video decode, encode and video processing \
4capabilities on IntelĀ® GPUs use cases."
5
6HOMEPAGE = "https://github.com/intel/libvpl-tools"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=c18ea6bb4786a26bf4eee88a7424a408 \
9 file://third-party-programs.txt;md5=ddf05049184e74942f45b0ca4cc69b8a"
10
11SRC_URI = "git://github.com/intel/libvpl-tools.git;protocol=https;branch=main \
12 "
13
14SRCREV = "82eab13ecec99f34e0f1d5dac490611b604406c9"
15S = "${WORKDIR}/git"
16
17inherit cmake
18DEPENDS += "libva libvpl pkgconfig-native"
19
20PACKAGECONFIG ??= "tools"
21PACKAGECONFIG[tools] = "-DENABLE_WAYLAND=ON, -DENABLE_WAYLAND=OFF, wayland wayland-native wayland-protocols"
22
23do_install:append() {
24 mkdir -p ${D}${datadir}/VPL/samples
25 mv ${D}${bindir}/sample_* ${D}${datadir}/VPL/samples
26 mv ${D}${bindir}/metrics_monitor ${D}${datadir}/VPL/samples
27}
28
29COMPATIBLE_HOST = '(x86_64).*-linux'
30
31FILES_SOLIBSDEV = ""
32
33FILES:${PN} += " ${datadir}/VPL/samples \
34 ${libdir}/libcttmetrics.so \
35 ${libdir}/vpl-tools/libvpl_wayland.* \
36 "
37
38FILES:${PN}-dev += "${libdir}/vpl-tools/libvpl_wayland.so \
39 "
40
41FILES:${PN}-doc += " ${datadir}/vpl-tools \
42 "