diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2012-04-04 05:20:56 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2012-04-04 05:24:16 +0000 |
commit | 2538fdffd3f5728b788ede09e2b0b576ad362ce2 (patch) | |
tree | 0ba10d8ab1621de5dcffaa0906be47d7af28011a | |
parent | e90110b85733f9cdda26861bc29588257173c11c (diff) | |
download | meta-java-2538fdffd3f5728b788ede09e2b0b576ad362ce2.tar.gz |
classpath-initial: fix installation of tools.zip file
This fixes an unpredicability of sysroot tools.zip version as
classpath-initial and classpath-native were installing the tools.zip
at same path.
We also bump PR of affected recipes to force them to rebuild.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-core/classpath/classpath-initial_0.93.bb | 3 | ||||
-rw-r--r-- | recipes-core/classpath/classpath-native.inc | 2 | ||||
-rw-r--r-- | recipes-core/classpath/classpath.inc | 2 | ||||
-rw-r--r-- | recipes-core/icedtea/icedtea6-native.inc | 2 | ||||
-rw-r--r-- | recipes-core/jamvm/jamvm-initial_1.4.5.bb | 2 | ||||
-rw-r--r-- | recipes-core/jamvm/jamvm_git.bb | 2 |
6 files changed, 12 insertions, 1 deletions
diff --git a/recipes-core/classpath/classpath-initial_0.93.bb b/recipes-core/classpath/classpath-initial_0.93.bb index 77831c1..13ede10 100644 --- a/recipes-core/classpath/classpath-initial_0.93.bb +++ b/recipes-core/classpath/classpath-initial_0.93.bb | |||
@@ -32,6 +32,9 @@ EXTRA_OECONF = " \ | |||
32 | --with-vm=java \ | 32 | --with-vm=java \ |
33 | " | 33 | " |
34 | 34 | ||
35 | # Ensure tools.zip is not installed at same path as classpath-native | ||
36 | EXTRA_OEMAKE += "pkgdatadir=${STAGING_DATADIR_NATIVE}/classpath-initial" | ||
37 | |||
35 | SRC_URI[md5sum] = "ffa9e9cac31c5acbf0ea9eff9efa923d" | 38 | SRC_URI[md5sum] = "ffa9e9cac31c5acbf0ea9eff9efa923d" |
36 | SRC_URI[sha256sum] = "df2d093612abd23fe67e9409d89bb2a8e79b1664fe2b2da40e1c8ed693e32945" | 39 | SRC_URI[sha256sum] = "df2d093612abd23fe67e9409d89bb2a8e79b1664fe2b2da40e1c8ed693e32945" |
37 | 40 | ||
diff --git a/recipes-core/classpath/classpath-native.inc b/recipes-core/classpath/classpath-native.inc index aefbf6d..16c1498 100644 --- a/recipes-core/classpath/classpath-native.inc +++ b/recipes-core/classpath/classpath-native.inc | |||
@@ -4,6 +4,8 @@ LICENSE = "Classpath" | |||
4 | 4 | ||
5 | DEPENDS = "ecj-initial fastjar-native zip-native gettext-native" | 5 | DEPENDS = "ecj-initial fastjar-native zip-native gettext-native" |
6 | 6 | ||
7 | PR = "r1" | ||
8 | |||
7 | inherit autotools native | 9 | inherit autotools native |
8 | 10 | ||
9 | SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz" | 11 | SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz" |
diff --git a/recipes-core/classpath/classpath.inc b/recipes-core/classpath/classpath.inc index 38037f3..55a3f6c 100644 --- a/recipes-core/classpath/classpath.inc +++ b/recipes-core/classpath/classpath.inc | |||
@@ -21,6 +21,8 @@ RPROVIDES_${PN} = "${PBN}" | |||
21 | RPROVIDES_${PN}-common = "${PBN}-common" | 21 | RPROVIDES_${PN}-common = "${PBN}-common" |
22 | RPROVIDES_${PN}-gtk = "${PBN}-awt" | 22 | RPROVIDES_${PN}-gtk = "${PBN}-awt" |
23 | 23 | ||
24 | PR = "r1" | ||
25 | |||
24 | SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz" | 26 | SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz" |
25 | 27 | ||
26 | S = "${WORKDIR}/${PBN}-${PV}" | 28 | S = "${WORKDIR}/${PBN}-${PV}" |
diff --git a/recipes-core/icedtea/icedtea6-native.inc b/recipes-core/icedtea/icedtea6-native.inc index 7287462..700bfb0 100644 --- a/recipes-core/icedtea/icedtea6-native.inc +++ b/recipes-core/icedtea/icedtea6-native.inc | |||
@@ -1,7 +1,7 @@ | |||
1 | DESCRIPTION = "Harness to build the source code from OpenJDK using Free Software build tools" | 1 | DESCRIPTION = "Harness to build the source code from OpenJDK using Free Software build tools" |
2 | HOMEPAGE = "http://icedtea.classpath.org" | 2 | HOMEPAGE = "http://icedtea.classpath.org" |
3 | LICENSE = "GPL with Classpath Exception" | 3 | LICENSE = "GPL with Classpath Exception" |
4 | INC_PR = "r4" | 4 | INC_PR = "r5" |
5 | 5 | ||
6 | DEPENDS = "virtual/javac-native virtual/java-native classpath-native \ | 6 | DEPENDS = "virtual/javac-native virtual/java-native classpath-native \ |
7 | xalan-j-native xerces-j-native rhino-native \ | 7 | xalan-j-native xerces-j-native rhino-native \ |
diff --git a/recipes-core/jamvm/jamvm-initial_1.4.5.bb b/recipes-core/jamvm/jamvm-initial_1.4.5.bb index 5fa9080..ea5a9d2 100644 --- a/recipes-core/jamvm/jamvm-initial_1.4.5.bb +++ b/recipes-core/jamvm/jamvm-initial_1.4.5.bb | |||
@@ -7,6 +7,8 @@ DEPENDS = "zlib-native classpath-initial jikes-initial libffi-native" | |||
7 | 7 | ||
8 | PROVIDES = "virtual/java-initial" | 8 | PROVIDES = "virtual/java-initial" |
9 | 9 | ||
10 | PR = "r1" | ||
11 | |||
10 | S = "${WORKDIR}/jamvm-${PV}" | 12 | S = "${WORKDIR}/jamvm-${PV}" |
11 | 13 | ||
12 | SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz \ | 14 | SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz \ |
diff --git a/recipes-core/jamvm/jamvm_git.bb b/recipes-core/jamvm/jamvm_git.bb index e6b6132..2a4213b 100644 --- a/recipes-core/jamvm/jamvm_git.bb +++ b/recipes-core/jamvm/jamvm_git.bb | |||
@@ -6,6 +6,8 @@ require jamvm.inc | |||
6 | SRCREV = "4617da717ecb05654ea5bb9572338061106a414d" | 6 | SRCREV = "4617da717ecb05654ea5bb9572338061106a414d" |
7 | PV = "1.5.5+1.6.0-devel+git${SRCPV}" | 7 | PV = "1.5.5+1.6.0-devel+git${SRCPV}" |
8 | 8 | ||
9 | PR = "r1" | ||
10 | |||
9 | SRC_URI = "git://git.berlios.de/jamvm;protocol=git \ | 11 | SRC_URI = "git://git.berlios.de/jamvm;protocol=git \ |
10 | file://jamvm-jni_h-noinst.patch \ | 12 | file://jamvm-jni_h-noinst.patch \ |
11 | file://libffi.patch \ | 13 | file://libffi.patch \ |