diff options
author | Ting Liu <ting.liu@freescale.com> | 2015-01-21 16:23:03 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-01-25 16:55:03 -0200 |
commit | 58c5f41799bec30a5576137d5477e8ba14a0a802 (patch) | |
tree | 86d60d7698625cada9aa5c55f70307864d38a3b8 | |
parent | 7b66216905c9420032e8a7b97e6a4466f6ec6118 (diff) | |
download | meta-java-58c5f41799bec30a5576137d5477e8ba14a0a802.tar.gz |
openjdk-6: Remove currency data generation expiration date
As the openjdk source was extracted during 'make patch-ecj' in
do_configure, apply the patch via do_configure_append.
icedtea6-1.13.4/Makefile.am:1200:stamps/extract-openjdk.stamp: stamps/download.stamp
| if OPENJDK_SRC_DIR_FOUND
| if ! test -d openjdk ; then \
| cp -pPR $(OPENJDK_SRC_DIR_LINK) $(OPENJDK_SRC_DIR) openjdk ; \
| fi
| else
| if USE_HG
| if ! test -d openjdk ; then \
| cp -pPRl openjdk.hg openjdk ; \
| fi
| else
| set -e ; \
| if ! test -d openjdk ; \
| then \
| mkdir openjdk ; \
| $(TAR) xf $(OPENJDK_SRC_ZIP) -C openjdk; \
| chmod -R ug+w openjdk ; \
| sh $(abs_top_srcdir)/fsg.sh ; \
| fi
| endif
| endif
Signed-off-by: Ting Liu <ting.liu@freescale.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-core/openjdk/openjdk-6-6b32/icedtea-openjdk-remove-currency-data-generation-expi.patch | 25 | ||||
-rw-r--r-- | recipes-core/openjdk/openjdk-6-release-6b32.inc | 8 |
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-6-6b32/icedtea-openjdk-remove-currency-data-generation-expi.patch b/recipes-core/openjdk/openjdk-6-6b32/icedtea-openjdk-remove-currency-data-generation-expi.patch new file mode 100644 index 0000000..6dd36af --- /dev/null +++ b/recipes-core/openjdk/openjdk-6-6b32/icedtea-openjdk-remove-currency-data-generation-expi.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From 7df2fd1014a0c31f518be4f6a0018533f469d584 Mon Sep 17 00:00:00 2001 | ||
2 | From: Alex Gonzalez <alex.gonzalez@digi.com> | ||
3 | Date: Wed, 31 Dec 2014 16:07:32 +0100 | ||
4 | Subject: [PATCH] icedtea: openjdk: remove currency data generation expiration | ||
5 | date | ||
6 | |||
7 | Signed-off-by: Alex Gonzalez <alex.gonzalez@digi.com> | ||
8 | --- | ||
9 | .../src/build/tools/generatecurrencydata/GenerateCurrencyData.java | 3 --- | ||
10 | 1 file changed, 3 deletions(-) | ||
11 | |||
12 | diff --git openjdk/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java openjdk/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java | ||
13 | index bf335fa22c1d..0e421360fef9 100644 | ||
14 | --- openjdk/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java | ||
15 | +++ openjdk/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java | ||
16 | @@ -281,9 +281,6 @@ public class GenerateCurrencyData { | ||
17 | checkCurrencyCode(newCurrency); | ||
18 | String timeString = currencyInfo.substring(4, length - 4); | ||
19 | long time = format.parse(timeString).getTime(); | ||
20 | - if (Math.abs(time - System.currentTimeMillis()) > ((long) 10) * 365 * 24 * 60 * 60 * 1000) { | ||
21 | - throw new RuntimeException("time is more than 10 years from present: " + time); | ||
22 | - } | ||
23 | specialCaseCutOverTimes[specialCaseCount] = time; | ||
24 | specialCaseOldCurrencies[specialCaseCount] = oldCurrency; | ||
25 | specialCaseOldCurrenciesDefaultFractionDigits[specialCaseCount] = getDefaultFractionDigits(oldCurrency); | ||
diff --git a/recipes-core/openjdk/openjdk-6-release-6b32.inc b/recipes-core/openjdk/openjdk-6-release-6b32.inc index fb7fb35..bf5e675 100644 --- a/recipes-core/openjdk/openjdk-6-release-6b32.inc +++ b/recipes-core/openjdk/openjdk-6-release-6b32.inc | |||
@@ -4,12 +4,20 @@ DEPENDS += "krb5" | |||
4 | 4 | ||
5 | FILESPATH =. "${FILE_DIRNAME}/openjdk-6-6b32:" | 5 | FILESPATH =. "${FILE_DIRNAME}/openjdk-6-6b32:" |
6 | 6 | ||
7 | ICEDTEAPATCHES += "file://icedtea-openjdk-remove-currency-data-generation-expi.patch;apply=no" | ||
8 | |||
7 | EXTRA_OECONF += "--disable-downloading \ | 9 | EXTRA_OECONF += "--disable-downloading \ |
8 | --enable-system-zlib \ | 10 | --enable-system-zlib \ |
9 | --enable-system-jpeg \ | 11 | --enable-system-jpeg \ |
10 | --enable-system-png \ | 12 | --enable-system-png \ |
11 | --enable-system-gif \ | 13 | --enable-system-gif \ |
12 | " | 14 | " |
15 | do_configure_append () { | ||
16 | patch -p0 <${WORKDIR}/icedtea-openjdk-remove-currency-data-generation-expi.patch | ||
17 | cd openjdk-ecj | ||
18 | patch -p1 <${WORKDIR}/icedtea-openjdk-remove-currency-data-generation-expi.patch | ||
19 | cd .. | ||
20 | } | ||
13 | 21 | ||
14 | OPENJDK_VERSION = "b32" | 22 | OPENJDK_VERSION = "b32" |
15 | OPENJDK_DATE = "15_jul_2014" | 23 | OPENJDK_DATE = "15_jul_2014" |