diff options
author | Max Krummenacher <max.oss.09@gmail.com> | 2015-02-17 10:57:15 +0100 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-02-17 10:53:34 -0200 |
commit | 9b33eee75b70bd431f6cac098e97d3b6dd220b51 (patch) | |
tree | 86ac2b7b9c613846707105a6ea6ba2b969c7789e | |
parent | c7f2b7dd60bff9092eeae6b7df7f8cae16994a21 (diff) | |
download | meta-java-9b33eee75b70bd431f6cac098e97d3b6dd220b51.tar.gz |
antlr: fix override for native build
The override virtclass_native has been deprecated and removed from the
buildsystem, use class-native instead.
While at it fix whitespace issues.
Signed-off-by: Max Krummenacher <max.oss.09@gmail.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-core/antlr/antlr_2.7.7.bb | 18 |
1 files changed, 9 insertions, 9 deletions
diff --git a/recipes-core/antlr/antlr_2.7.7.bb b/recipes-core/antlr/antlr_2.7.7.bb index 2c7ab8e..9d9d2d4 100644 --- a/recipes-core/antlr/antlr_2.7.7.bb +++ b/recipes-core/antlr/antlr_2.7.7.bb | |||
@@ -5,25 +5,25 @@ LICENSE = "PD" | |||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=361934e706423915b4d9f413ad37fb65" | 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=361934e706423915b4d9f413ad37fb65" |
6 | 6 | ||
7 | SRC_URI = "http://www.antlr2.org/download/${BP}.tar.gz" | 7 | SRC_URI = "http://www.antlr2.org/download/${BP}.tar.gz" |
8 | SRC_URI_virtclass_native += "file://runantlr" | 8 | SRC_URI_append_class-native = " file://runantlr" |
9 | 9 | ||
10 | inherit java-library | 10 | inherit java-library |
11 | 11 | ||
12 | do_configure_virtclass_native() { | 12 | do_configure_class-native() { |
13 | sed -i -e"s|@JAR_FILE@|${STAGING_DATADIR_JAVA_NATIVE}/antlr.jar|" ${WORKDIR}/runantlr | 13 | sed -i -e"s|@JAR_FILE@|${STAGING_DATADIR_JAVA_NATIVE}/antlr.jar|" ${WORKDIR}/runantlr |
14 | } | 14 | } |
15 | 15 | ||
16 | do_compile() { | 16 | do_compile() { |
17 | mkdir -p build | 17 | mkdir -p build |
18 | 18 | ||
19 | javac -sourcepath . -d build `find antlr -name "*.java"` | 19 | javac -sourcepath . -d build `find antlr -name "*.java"` |
20 | 20 | ||
21 | fastjar cf ${JARFILENAME} -C build . | 21 | fastjar cf ${JARFILENAME} -C build . |
22 | } | 22 | } |
23 | 23 | ||
24 | do_install_virtclass_native() { | 24 | do_install_class-native() { |
25 | install ${D}${bindir} | 25 | install -d ${D}${bindir} |
26 | install -m 0755 ${WORKDIR}/runantlr {D}${bindir}/ | 26 | install -m 0755 ${WORKDIR}/runantlr ${D}${bindir}/ |
27 | } | 27 | } |
28 | 28 | ||
29 | SRC_URI[md5sum] = "01cc9a2a454dd33dcd8c856ec89af090" | 29 | SRC_URI[md5sum] = "01cc9a2a454dd33dcd8c856ec89af090" |