diff options
author | Henning Heinold <heinold@inf.fu-berlin.de> | 2013-01-10 19:42:26 +0100 |
---|---|---|
committer | Henning Heinold <heinold@inf.fu-berlin.de> | 2013-01-24 22:32:08 +0100 |
commit | 74770df7e31271be5056ab757cc3d5875ef002e8 (patch) | |
tree | 6e7f4a39fe65bf278491543f69ee0465291bd82e /recipes-core/jamvm/jamvm-initial/jamvm-initial.patch | |
parent | f861d37eb4851245d36889c2d5f44177dfe873f0 (diff) | |
download | meta-java-74770df7e31271be5056ab757cc3d5875ef002e8.tar.gz |
jamvm-initial: rename patches directory for newer bitbake
Diffstat (limited to 'recipes-core/jamvm/jamvm-initial/jamvm-initial.patch')
-rw-r--r-- | recipes-core/jamvm/jamvm-initial/jamvm-initial.patch | 63 |
1 files changed, 0 insertions, 63 deletions
diff --git a/recipes-core/jamvm/jamvm-initial/jamvm-initial.patch b/recipes-core/jamvm/jamvm-initial/jamvm-initial.patch deleted file mode 100644 index fb069f8..0000000 --- a/recipes-core/jamvm/jamvm-initial/jamvm-initial.patch +++ /dev/null | |||
@@ -1,63 +0,0 @@ | |||
1 | Index: jamvm-1.4.5/configure.ac | ||
2 | =================================================================== | ||
3 | --- jamvm-1.4.5.orig/configure.ac | ||
4 | +++ jamvm-1.4.5/configure.ac | ||
5 | @@ -1,6 +1,6 @@ | ||
6 | dnl Process this file with autoconf to produce a configure script. | ||
7 | AC_INIT(src/jam.c) | ||
8 | -AM_INIT_AUTOMAKE(jamvm, 1.4.5) | ||
9 | +AM_INIT_AUTOMAKE(jamvm-initial, 1.4.5) | ||
10 | AC_CONFIG_HEADERS([src/config.h]) | ||
11 | AC_PREFIX_DEFAULT(/usr/local/jamvm) | ||
12 | |||
13 | Index: jamvm-1.4.5/lib/Makefile.am | ||
14 | =================================================================== | ||
15 | --- jamvm-1.4.5.orig/lib/Makefile.am | ||
16 | +++ jamvm-1.4.5/lib/Makefile.am | ||
17 | @@ -1,4 +1,4 @@ | ||
18 | -@use_zip_yes@ GLIBJ_ZIP = ${with_classpath_install_dir}/share/classpath/glibj.zip | ||
19 | +@use_zip_yes@ GLIBJ_ZIP = ${with_classpath_install_dir}/share/classpath-initial/glibj.zip | ||
20 | @use_zip_no@ GLIBJ_ZIP = ${with_classpath_install_dir}/share/classpath/ | ||
21 | |||
22 | SUBDIRS = jamvm java gnu sun | ||
23 | Index: jamvm-1.4.5/src/dll.c | ||
24 | =================================================================== | ||
25 | --- jamvm-1.4.5.orig/src/dll.c | ||
26 | +++ jamvm-1.4.5/src/dll.c | ||
27 | @@ -294,7 +294,7 @@ char *getDllPath() { | ||
28 | } | ||
29 | |||
30 | char *getBootDllPath() { | ||
31 | - return CLASSPATH_INSTALL_DIR"/lib/classpath"; | ||
32 | + return CLASSPATH_INSTALL_DIR"/lib/classpath-initial"; | ||
33 | } | ||
34 | |||
35 | char *getDllName(char *name) { | ||
36 | Index: jamvm-1.4.5/src/Makefile.am | ||
37 | =================================================================== | ||
38 | --- jamvm-1.4.5.orig/src/Makefile.am | ||
39 | +++ jamvm-1.4.5/src/Makefile.am | ||
40 | @@ -2,7 +2,7 @@ SUBDIRS = os | ||
41 | DIST_SUBDIRS = os arch | ||
42 | |||
43 | bin_PROGRAMS = jamvm | ||
44 | -include_HEADERS = jni.h | ||
45 | +noinst_HEADERS = jni.h | ||
46 | |||
47 | lib_LTLIBRARIES = libjvm.la | ||
48 | noinst_LTLIBRARIES = libcore.la | ||
49 | Index: jamvm-1.4.5/src/class.c | ||
50 | =================================================================== | ||
51 | --- jamvm-1.4.5.orig/src/class.c | ||
52 | +++ jamvm-1.4.5/src/class.c | ||
53 | @@ -1653,8 +1653,8 @@ void scanDirsForJars(char *directories) | ||
54 | } | ||
55 | |||
56 | #ifdef USE_ZIP | ||
57 | -#define JAMVM_CLASSES INSTALL_DIR"/share/jamvm/classes.zip" | ||
58 | -#define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath/glibj.zip" | ||
59 | +#define JAMVM_CLASSES INSTALL_DIR"/share/jamvm-initial/classes.zip" | ||
60 | +#define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath-initial/glibj.zip" | ||
61 | #else | ||
62 | #define JAMVM_CLASSES INSTALL_DIR"/share/jamvm/classes" | ||
63 | #define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath" | ||