diff options
author | Henning Heinold <heinold@inf.fu-berlin.de> | 2011-11-12 20:58:34 +0100 |
---|---|---|
committer | Henning Heinold <heinold@inf.fu-berlin.de> | 2011-11-26 23:41:44 +0100 |
commit | 57e069cde6617f00ca8834a82c6f360af43d5067 (patch) | |
tree | 48cbe15e96d217c45acfa64b0c13aad8c6424980 /recipes-core/jamvm/jamvm-initial/libffi.patch | |
download | meta-java-57e069cde6617f00ca8834a82c6f360af43d5067.tar.gz |
meta-java: initial commit
* taken over mostly stuff from oe classic
* cleaned up recipes
* added license checksums
* bump icedtea6-native to 1.8.11
* use jamvm from git as native
Diffstat (limited to 'recipes-core/jamvm/jamvm-initial/libffi.patch')
-rw-r--r-- | recipes-core/jamvm/jamvm-initial/libffi.patch | 68 |
1 files changed, 68 insertions, 0 deletions
diff --git a/recipes-core/jamvm/jamvm-initial/libffi.patch b/recipes-core/jamvm/jamvm-initial/libffi.patch new file mode 100644 index 0000000..216f03c --- /dev/null +++ b/recipes-core/jamvm/jamvm-initial/libffi.patch | |||
@@ -0,0 +1,68 @@ | |||
1 | Index: jamvm-1.4.5/configure.ac | ||
2 | =================================================================== | ||
3 | --- jamvm-1.4.5.orig/configure.ac 2007-02-05 04:18:05.000000000 +0100 | ||
4 | +++ jamvm-1.4.5/configure.ac 2011-11-25 19:34:58.473683844 +0100 | ||
5 | @@ -166,10 +166,25 @@ | ||
6 | enable_zip=no | ||
7 | fi]) | ||
8 | |||
9 | -AC_CHECK_LIB(ffi,ffi_call,, | ||
10 | - [if test "$enable_ffi" != no; then | ||
11 | - AC_MSG_ERROR(cannot find libffi) | ||
12 | - fi]) | ||
13 | +LIBFFI_FOUND=no | ||
14 | +if test "$enable_ffi" = yes | ||
15 | +then | ||
16 | +PKG_CHECK_MODULES([LIBFFI], [libffi], [LIBFFI_FOUND=yes], [LIBFFI_FOUND=no]) | ||
17 | +if test "x${LIBFFI_FOUND}" = xno | ||
18 | +then | ||
19 | + LIBFFI_FOUND= | ||
20 | + AC_CHECK_HEADER([ffi.h],[LIBFFI_CFLAGS=],[LIBFFI_FOUND=no]) | ||
21 | + AC_SEARCH_LIBS([ffi_call], [ffi],[LIBFFI_LIBS=-lffi],[LIBFFI_FOUND=no]) | ||
22 | + if test "x${LIBFFI_FOUND}" = xno | ||
23 | + then | ||
24 | + AC_MSG_ERROR([Could not find libffi headers - \ | ||
25 | + Instal libffi-devel or libffi-dev.]) | ||
26 | + fi | ||
27 | +fi | ||
28 | +fi | ||
29 | +AC_SUBST(LIBFFI_CFLAGS) | ||
30 | +AC_SUBST(LIBFFI_LIBS) | ||
31 | + | ||
32 | |||
33 | dnl Checks for header files. | ||
34 | AC_HEADER_STDC | ||
35 | @@ -180,11 +195,6 @@ | ||
36 | enable_zip=no | ||
37 | fi]) | ||
38 | |||
39 | -AC_CHECK_HEADER(ffi.h,, | ||
40 | - [if test "$enable_ffi" != no; then | ||
41 | - AC_MSG_ERROR(cannot find ffi.h) | ||
42 | - fi]) | ||
43 | - | ||
44 | if test "$enable_zip" != no; then | ||
45 | AC_DEFINE([USE_ZIP],1,[use zip]) | ||
46 | use_zip_yes= | ||
47 | @@ -197,7 +207,7 @@ | ||
48 | AC_SUBST(use_zip_yes) | ||
49 | AC_SUBST(use_zip_no) | ||
50 | |||
51 | -if test "$enable_ffi" != no; then | ||
52 | +if test "x${LIBFFI_FOUND}" != no; then | ||
53 | AC_DEFINE([USE_FFI],1,[use FFI]) | ||
54 | fi | ||
55 | |||
56 | Index: jamvm-1.4.5/src/Makefile.am | ||
57 | =================================================================== | ||
58 | --- jamvm-1.4.5.orig/src/Makefile.am 2006-12-25 05:10:18.000000000 +0100 | ||
59 | +++ jamvm-1.4.5/src/Makefile.am 2011-11-25 19:35:26.537723112 +0100 | ||
60 | @@ -19,6 +19,7 @@ | ||
61 | |||
62 | jamvm_LDADD = libcore.la | ||
63 | libjvm_la_LIBADD = libcore.la | ||
64 | -libcore_la_LIBADD = os/@os@/@arch@/libnative.la os/@os@/libos.la | ||
65 | +libcore_la_LIBADD = os/@os@/@arch@/libnative.la os/@os@/libos.la $(LIBFFI_LIBS) | ||
66 | +libcore_la_CPPFLAGS = $(LIBFFI_CFLAGS) | ||
67 | |||
68 | DISTCLEANFILES = arch.h | ||