summaryrefslogtreecommitdiffstats
path: root/recipes-core/rxtx/files/uninstall_target.patch
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-03-05 22:01:08 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2012-03-05 22:01:25 +0000
commitc72df728b4cd93e7af06d966f1365e532febf06f (patch)
tree467b3702099ee43b09e3c708b33026d70a0e6801 /recipes-core/rxtx/files/uninstall_target.patch
parenta6abe2cec3c302eda39e5a724ae14dee002624a5 (diff)
downloadmeta-java-c72df728b4cd93e7af06d966f1365e532febf06f.tar.gz
rxtx: add 2.2.0 pre2
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/rxtx/files/uninstall_target.patch')
-rw-r--r--recipes-core/rxtx/files/uninstall_target.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-core/rxtx/files/uninstall_target.patch b/recipes-core/rxtx/files/uninstall_target.patch
new file mode 100644
index 0000000..a0e8c55
--- /dev/null
+++ b/recipes-core/rxtx/files/uninstall_target.patch
@@ -0,0 +1,18 @@
1Description: adds uninstall target to Makefile
2Author: Scott Howard <showard@debian.org>
3Bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=646069
4Index: rxtx/Makefile.am
5===================================================================
6--- rxtx.orig/Makefile.am 2011-10-31 02:43:21.532963961 -0400
7+++ rxtx/Makefile.am 2011-10-31 02:46:03.348967808 -0400
8@@ -129,6 +129,10 @@
9 done` $(RXTX_PATH)
10 $(INSTALL_PROGRAM) $(JARTARGET) $(JHOME)/
11
12+uninstall:
13+ cd $(RXTX_PATH) && $(RM) librxtx*
14+ $(RM) $(JHOME)/$(JARTARGET)
15+
16 clean-generic:
17 rm -rf $(DEST) $(TOP)/$(CLASSTOP)
18 -test -z "$(CLEANFILES)" || rm -f $(CLEANFILES)