diff options
author | Tim Orling <timothy.t.orling@linux.intel.com> | 2017-05-21 16:25:52 -0700 |
---|---|---|
committer | Maxin B. John <maxin.john@intel.com> | 2017-05-29 13:47:09 +0300 |
commit | c45ed0f8ddf613ce7f1ad9e5c80b8b2db3df4912 (patch) | |
tree | cc676b2b20929e6c6d177d7d3da677290144ef03 /recipes-core/xml-commons | |
parent | b1992e05e14788cd9d88ece41f9695747c4b7e53 (diff) | |
download | meta-java-c45ed0f8ddf613ce7f1ad9e5c80b8b2db3df4912.tar.gz |
xom: unblacklist and update to v1.2.10
- License checksum changed (updated year)
- Add SUMMARY and expand DESCRIPTION
- Clone jaxen dependency from github, update to v1.1.6
- Move SRC_URI checksums to recommended location in recipe
- Add virtual/javac-native to DEPENDS for RSS
Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Maxin B. John <maxin.john@intel.com>
Diffstat (limited to 'recipes-core/xml-commons')
-rw-r--r-- | recipes-core/xml-commons/xom-1.2.10/04_remove_sun_import.patch (renamed from recipes-core/xml-commons/xom-1.1/04_remove_sun_import.patch) | 0 | ||||
-rw-r--r-- | recipes-core/xml-commons/xom_1.1.bb | 54 | ||||
-rw-r--r-- | recipes-core/xml-commons/xom_1.2.10.bb | 50 |
3 files changed, 50 insertions, 54 deletions
diff --git a/recipes-core/xml-commons/xom-1.1/04_remove_sun_import.patch b/recipes-core/xml-commons/xom-1.2.10/04_remove_sun_import.patch index 71f659d..71f659d 100644 --- a/recipes-core/xml-commons/xom-1.1/04_remove_sun_import.patch +++ b/recipes-core/xml-commons/xom-1.2.10/04_remove_sun_import.patch | |||
diff --git a/recipes-core/xml-commons/xom_1.1.bb b/recipes-core/xml-commons/xom_1.1.bb deleted file mode 100644 index c37965b..0000000 --- a/recipes-core/xml-commons/xom_1.1.bb +++ /dev/null | |||
@@ -1,54 +0,0 @@ | |||
1 | DESCRIPTION = "Tree-based API for processing XML with Java" | ||
2 | LICENSE = "LGPL-2.1" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=456080cf80cd56d4d58118c1d10d824f" | ||
4 | |||
5 | HOMEPAGE = "http://xom.nu" | ||
6 | |||
7 | SRC_URI = "\ | ||
8 | http://www.cafeconleche.org/XOM/${P}-src.tar.gz;name=archive \ | ||
9 | http://dist.codehaus.org/jaxen/distributions/jaxen-1.1.1-src.tar.gz;name=jaxen \ | ||
10 | file://04_remove_sun_import.patch \ | ||
11 | " | ||
12 | |||
13 | # DEBUG: Executing shell function do_compile | ||
14 | # ---------- | ||
15 | # 1. ERROR in src/nu/xom/UnicodeUtil.java (at line 0) | ||
16 | # /* Copyright 2005 Elliotte Rusty Harold | ||
17 | # ^ | ||
18 | # Internal compiler error: java.lang.StackOverflowError at org.eclipse.jdt.internal.compiler.ast.Expression.checkNPE(Expression.java:511) | ||
19 | # ---------- | ||
20 | # Exception in thread "main" java.lang.StackOverflowError | ||
21 | # at org.eclipse.jdt.internal.compiler.ast.Expression.checkNPE(Expression.java:511) | ||
22 | PNBLACKLIST[xom] ?= "BROKEN: do_compile fails with internal javac error" | ||
23 | |||
24 | S = "${WORKDIR}/XOM" | ||
25 | |||
26 | inherit java-library | ||
27 | |||
28 | DEPENDS = "fastjar-native xerces-j xalan-j" | ||
29 | |||
30 | do_compile() { | ||
31 | mkdir -p build | ||
32 | |||
33 | oe_makeclasspath cp -s xercesImpl xalan2 | ||
34 | cp=build:$cp | ||
35 | |||
36 | scp="${WORKDIR}/jaxen-1.1.1/src/java/main" | ||
37 | |||
38 | javac -sourcepath src:$scp -cp $cp -d build `find src -name "*.java" -and -not \( -wholename "*tests*" -or -wholename "*samples*" -or -wholename "*tools*" \)` | ||
39 | javac -sourcepath fatsrc:$scp -cp $cp -d build `find fatsrc -name "*.java" -and -not \( -wholename "*tests*" -or -wholename "*samples*" -or -wholename "*tools*" \)` | ||
40 | javac -sourcepath src15:$scp -cp $cp -d build `find src15 -name "*.java" -and -not \( -wholename "*tests*" -or -wholename "*samples*" -or -wholename "*tools*" \)` | ||
41 | |||
42 | (cd src && find . -name "*.properties" -exec cp {} ../build/{} \;) | ||
43 | |||
44 | # Remove Jaxen classes from build | ||
45 | rm -rf build/org/jaxen | ||
46 | rm -rf build/org/w3c | ||
47 | |||
48 | fastjar -C build -c -f ${JARFILENAME} . | ||
49 | } | ||
50 | |||
51 | SRC_URI[archive.md5sum] = "e5ae82568d7b1faeb950140c34fbbcb1" | ||
52 | SRC_URI[archive.sha256sum] = "d648fd1f7b7437123afa63df06f6a6409a0487c99ca8f8beba75aaa474d65818" | ||
53 | SRC_URI[jaxen.md5sum] = "b598ae6b7e765a92e13667b0a80392f4" | ||
54 | SRC_URI[jaxen.sha256sum] = "f24ae604a20da87e3716bb1d441c483e56479eaef4e99888f41be06059790bca" | ||
diff --git a/recipes-core/xml-commons/xom_1.2.10.bb b/recipes-core/xml-commons/xom_1.2.10.bb new file mode 100644 index 0000000..0e923d4 --- /dev/null +++ b/recipes-core/xml-commons/xom_1.2.10.bb | |||
@@ -0,0 +1,50 @@ | |||
1 | SUMMARY = "Tree-based API for processing XML with Java" | ||
2 | DESCRIPTION = "XML object model which is a tree-based API for processing XML \ | ||
3 | with Java that strives for correctness, simplicity, and performance." | ||
4 | LICENSE = "LGPL-2.1" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3f18f166096348ef9d457214a2484816" | ||
6 | |||
7 | HOMEPAGE = "http://xom.nu" | ||
8 | |||
9 | # jaxen recipe depends on xom, avoid circular dependency | ||
10 | # upstream jaxen moved to github, do not count on ephemeral github archives | ||
11 | SRCNAME_jaxen = "jaxen" | ||
12 | SRCREV_jaxen = "7d7755ac8b19daa2ff6f319f432b864cc72d89b6" | ||
13 | PV_jaxen = "1.1.6" | ||
14 | |||
15 | SRC_URI = "\ | ||
16 | http://www.cafeconleche.org/XOM/${P}-src.tar.gz;name=archive \ | ||
17 | git://github.com/codehaus/${SRCNAME_jaxen};name=jaxen \ | ||
18 | file://04_remove_sun_import.patch \ | ||
19 | " | ||
20 | SRC_URI[archive.md5sum] = "9f3a2ae827a9f6826fe76e4b7b0c22b3" | ||
21 | SRC_URI[archive.sha256sum] = "39985c2debb8044005fd07b09cb06f10e75652b3c048c9b4431434215332bc85" | ||
22 | |||
23 | S = "${WORKDIR}/XOM" | ||
24 | |||
25 | inherit java-library | ||
26 | |||
27 | DEPENDS = "fastjar-native virtual/javac-native xerces-j xalan-j" | ||
28 | |||
29 | do_compile() { | ||
30 | mkdir -p build | ||
31 | |||
32 | oe_makeclasspath cp -s xercesImpl xalan2 | ||
33 | cp=build:$cp | ||
34 | |||
35 | mv ${WORKDIR}/git/jaxen ${WORKDIR}/jaxen-${PV_jaxen} | ||
36 | rm -rf ${WORKDIR}/git | ||
37 | scp="${WORKDIR}/jaxen-${PV_jaxen}/src/java/main" | ||
38 | |||
39 | javac -sourcepath src:$scp -cp $cp -d build `find src -name "*.java" -and -not \( -wholename "*tests*" -or -wholename "*samples*" -or -wholename "*tools*" \)` | ||
40 | javac -sourcepath fatsrc:$scp -cp $cp -d build `find fatsrc -name "*.java" -and -not \( -wholename "*tests*" -or -wholename "*samples*" -or -wholename "*tools*" \)` | ||
41 | javac -sourcepath src15:$scp -cp $cp -d build `find src15 -name "*.java" -and -not \( -wholename "*tests*" -or -wholename "*samples*" -or -wholename "*tools*" \)` | ||
42 | |||
43 | (cd src && find . -name "*.properties" -exec cp {} ../build/{} \;) | ||
44 | |||
45 | # Remove Jaxen classes from build | ||
46 | rm -rf build/org/jaxen | ||
47 | rm -rf build/org/w3c | ||
48 | |||
49 | fastjar -C build -c -f ${JARFILENAME} . | ||
50 | } | ||