diff options
author | Steffen Sledz <sledz@dresearch-fe.de> | 2012-10-05 15:22:33 +0200 |
---|---|---|
committer | Henning Heinold <heinold@inf.fu-berlin.de> | 2012-11-09 11:59:51 +0100 |
commit | 99bd206eb1c8ca285e676886a7d6329b40ae4c66 (patch) | |
tree | aa767b6905c78db5c260636edb560cd2b0ef81db /recipes-core | |
parent | 819348073b54148c1dd24f0f11725b89f6965818 (diff) | |
download | meta-java-99bd206eb1c8ca285e676886a7d6329b40ae4c66.tar.gz |
icedtea6-native: fix compile error
Don't return booleans from methods returning pointers.
see also: <http://hg.openjdk.java.net/hsx/hotspot-rt/hotspot/rev/f457154eee8b>
- commit was modified, removed the 1.7 version stuff
Signed-off-by: Steffen Sledz <sledz@dresearch-fe.de>
Signed-off-by: Henning Heinold <heinold@inf.fu-berlin.de>
Diffstat (limited to 'recipes-core')
-rw-r--r-- | recipes-core/icedtea/icedtea6-native-1.8.11/icedtea-hotspot-dont-return-booleans.patch | 12 | ||||
-rw-r--r-- | recipes-core/icedtea/icedtea6-native_1.8.11.bb | 4 |
2 files changed, 15 insertions, 1 deletions
diff --git a/recipes-core/icedtea/icedtea6-native-1.8.11/icedtea-hotspot-dont-return-booleans.patch b/recipes-core/icedtea/icedtea6-native-1.8.11/icedtea-hotspot-dont-return-booleans.patch new file mode 100644 index 0000000..73f90b3 --- /dev/null +++ b/recipes-core/icedtea/icedtea6-native-1.8.11/icedtea-hotspot-dont-return-booleans.patch | |||
@@ -0,0 +1,12 @@ | |||
1 | diff -Nurd openjdk/hotspot/src/share/vm/opto/loopnode.cpp openjdk/hotspot/src/share/vm/opto/loopnode.cpp | ||
2 | --- openjdk/hotspot/src/share/vm/opto/loopnode.cpp 2012-10-05 14:18:19.725747261 +0200 | ||
3 | +++ openjdk/hotspot/src/share/vm/opto/loopnode.cpp 2012-10-05 14:18:40.751035242 +0200 | ||
4 | @@ -534,7 +534,7 @@ | ||
5 | Node* CountedLoopNode::match_incr_with_optional_truncation( | ||
6 | Node* expr, Node** trunc1, Node** trunc2, const TypeInt** trunc_type) { | ||
7 | // Quick cutouts: | ||
8 | - if (expr == NULL || expr->req() != 3) return false; | ||
9 | + if (expr == NULL || expr->req() != 3) return NULL; | ||
10 | |||
11 | Node *t1 = NULL; | ||
12 | Node *t2 = NULL; | ||
diff --git a/recipes-core/icedtea/icedtea6-native_1.8.11.bb b/recipes-core/icedtea/icedtea6-native_1.8.11.bb index 7c2e6ea..65f29ea 100644 --- a/recipes-core/icedtea/icedtea6-native_1.8.11.bb +++ b/recipes-core/icedtea/icedtea6-native_1.8.11.bb | |||
@@ -4,7 +4,7 @@ require ${PN}.inc | |||
4 | 4 | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
6 | 6 | ||
7 | PR = "${INC_PR}.2" | 7 | PR = "${INC_PR}.3" |
8 | 8 | ||
9 | SRC_URI = "\ | 9 | SRC_URI = "\ |
10 | http://icedtea.classpath.org/download/source/icedtea6-${PV}.tar.gz;name=iced \ | 10 | http://icedtea.classpath.org/download/source/icedtea6-${PV}.tar.gz;name=iced \ |
@@ -44,6 +44,7 @@ ICEDTEA_PATCHES = "\ | |||
44 | file://icedtea-jdk-sane-x86-arch.patch;apply=no \ | 44 | file://icedtea-jdk-sane-x86-arch.patch;apply=no \ |
45 | file://icedtea-unbreak-float.patch;apply=no \ | 45 | file://icedtea-unbreak-float.patch;apply=no \ |
46 | file://icedtea-jdk-avoid-cdef-collision.patch;apply=no \ | 46 | file://icedtea-jdk-avoid-cdef-collision.patch;apply=no \ |
47 | file://icedtea-hotspot-dont-return-booleans.patch;apply=no \ | ||
47 | " | 48 | " |
48 | 49 | ||
49 | export DISTRIBUTION_PATCHES = "\ | 50 | export DISTRIBUTION_PATCHES = "\ |
@@ -54,6 +55,7 @@ export DISTRIBUTION_PATCHES = "\ | |||
54 | patches/icedtea-jdk-sane-x86-arch.patch \ | 55 | patches/icedtea-jdk-sane-x86-arch.patch \ |
55 | patches/icedtea-unbreak-float.patch \ | 56 | patches/icedtea-unbreak-float.patch \ |
56 | patches/icedtea-jdk-avoid-cdef-collision.patch \ | 57 | patches/icedtea-jdk-avoid-cdef-collision.patch \ |
58 | patches/icedtea-hotspot-dont-return-booleans.patch \ | ||
57 | " | 59 | " |
58 | 60 | ||
59 | EXTRA_OECONF += " --with-jaxws-drop-zip=${DL_DIR}/jdk6-jaxws-2009_10_27.zip \ | 61 | EXTRA_OECONF += " --with-jaxws-drop-zip=${DL_DIR}/jdk6-jaxws-2009_10_27.zip \ |