summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-08-04 15:23:50 -0700
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-11-22 18:30:30 +0100
commitfe6f342de963a55f565dfdbb7de20d29977b4ad1 (patch)
treeadbed5edf6e2bac592901cc7b4046d9a20e5f9d4 /recipes-core
parent510c0446a3d69d123305d67a62d26a35630bfce4 (diff)
downloadmeta-java-fe6f342de963a55f565dfdbb7de20d29977b4ad1.tar.gz
llvm2.8: Fix build break discovred by unanchored regexp fix in bitbake
commit 23bd5300b4a99218a15f4f6b0ab4091d63a602a5 fixed a bug in bitbake which exposed this latent problem where we were using EXTRA_OECMAKE_append-arm it was being treated as EXTRA_OECMAKE_append before the above mentioned fix and hence all was fine but after this fix behavior changed and it was just EXTRA_OECMAKE_append-arm and was causing build breaks | ../../lib/libLLVMTransformUtils.so: undefined reference to `llvm::CallGraphNode::removeCallEdgeFor(llvm::CallSite)' | ../../lib/libLLVMTransformUtils.so: undefined reference to `llvm::CallGraph::getOrInsertFunction(llvm::Function const*)' | ../../lib/libLLVMTransformUtils.so: undefined reference to `llvm::CallGraphLinkVar' | ../../lib/libLLVMScalarOpts.so: undefined reference to `llvm::createInstructionCombiningPass()' | collect2: error: ld returned 1 exit status | make[2]: *** [bin/llc] Error 1 | make[2]: Leaving directory `/work/yocto/poky/build/tmp/work/x86_64-poky-linux/llvm2.8-2.8-r2.1/llvm-2.8/build' | make[1]: *** [tools/llc/CMakeFiles/llc.dir/all] Error 2 | make[1]: *** Waiting for unfinished jobs.... It also fixes the llvm-mc build for arm architecture modified for INC-PR bumped PR Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Henning Heinold <heinold@inf.fu-berlin.de> Conflicts: recipes-core/llvm/llvm2.8_2.8.bb
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/llvm/llvm2.8/llvm-mc_disable.patch12
-rw-r--r--recipes-core/llvm/llvm2.8_2.8.bb6
2 files changed, 2 insertions, 16 deletions
diff --git a/recipes-core/llvm/llvm2.8/llvm-mc_disable.patch b/recipes-core/llvm/llvm2.8/llvm-mc_disable.patch
deleted file mode 100644
index fddc674..0000000
--- a/recipes-core/llvm/llvm2.8/llvm-mc_disable.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1Index: llvm-2.8/tools/CMakeLists.txt
2===================================================================
3--- llvm-2.8.orig/tools/CMakeLists.txt 2010-08-24 11:16:51.000000000 +0200
4+++ llvm-2.8/tools/CMakeLists.txt 2011-12-21 16:47:47.718508763 +0100
5@@ -14,7 +14,6 @@
6 add_subdirectory(opt)
7 add_subdirectory(llvm-as)
8 add_subdirectory(llvm-dis)
9-add_subdirectory(llvm-mc)
10
11 add_subdirectory(llc)
12 add_subdirectory(llvm-ranlib)
diff --git a/recipes-core/llvm/llvm2.8_2.8.bb b/recipes-core/llvm/llvm2.8_2.8.bb
index 85469bb..1788b87 100644
--- a/recipes-core/llvm/llvm2.8_2.8.bb
+++ b/recipes-core/llvm/llvm2.8_2.8.bb
@@ -4,7 +4,7 @@ require llvm.inc
4LICENSE = "NCSA" 4LICENSE = "NCSA"
5LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=0ac5f799a2d89477c75b0a378b221855" 5LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=0ac5f799a2d89477c75b0a378b221855"
6 6
7PR = "${INC_PR}.0" 7PR = "${INC_PR}.1"
8 8
9SRC_URI += " \ 9SRC_URI += " \
10 file://30may-llvm2.8-pr399-ppc-arm.patch \ 10 file://30may-llvm2.8-pr399-ppc-arm.patch \
@@ -12,11 +12,9 @@ SRC_URI += " \
12 file://add-unistd.patch \ 12 file://add-unistd.patch \
13 " 13 "
14 14
15SRC_URI_append_arm = " file://llvm-mc_disable.patch "
16
17LLVM_RELEASE = "2.8" 15LLVM_RELEASE = "2.8"
18 16
19EXTRA_OECMAKE_append_arm = " -DBUILD_SHARED_LIBS:BOOL=OFF " 17EXTRA_OECMAKE += " -DBUILD_SHARED_LIBS:BOOL=OFF "
20 18
21SRC_URI[md5sum] = "220d361b4d17051ff4bb21c64abe05ba" 19SRC_URI[md5sum] = "220d361b4d17051ff4bb21c64abe05ba"
22SRC_URI[sha256sum] = "25addb742f1c6cc12877ed0ee924dda962d848368ee095be8e48342ae613d43b" 20SRC_URI[sha256sum] = "25addb742f1c6cc12877ed0ee924dda962d848368ee095be8e48342ae613d43b"