summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/cacao/cacao_1.6.1.bb4
-rw-r--r--recipes-core/classpath/classpath.inc4
-rw-r--r--recipes-core/jamvm/jamvm.inc4
-rw-r--r--recipes-core/openjdk/openjdk-common.inc4
4 files changed, 12 insertions, 4 deletions
diff --git a/recipes-core/cacao/cacao_1.6.1.bb b/recipes-core/cacao/cacao_1.6.1.bb
index 14ff019..d52f339 100644
--- a/recipes-core/cacao/cacao_1.6.1.bb
+++ b/recipes-core/cacao/cacao_1.6.1.bb
@@ -15,7 +15,9 @@ SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-
15SRC_URI[md5sum] = "2c18478404afd1cffdd15ad1e9d85a57" 15SRC_URI[md5sum] = "2c18478404afd1cffdd15ad1e9d85a57"
16SRC_URI[sha256sum] = "eecc8bd1b528a028f43d9d1d0c06b97855bbf1d40e03826d911ebbc0b6971e12" 16SRC_URI[sha256sum] = "eecc8bd1b528a028f43d9d1d0c06b97855bbf1d40e03826d911ebbc0b6971e12"
17 17
18inherit java autotools-brokensep update-alternatives pkgconfig 18inherit java autotools-brokensep update-alternatives pkgconfig distro_features_check
19
20REQUIRED_DISTRO_FEATURES = "x11"
19 21
20EXTRA_OECONF_class-native = "\ 22EXTRA_OECONF_class-native = "\
21 --enable-debug \ 23 --enable-debug \
diff --git a/recipes-core/classpath/classpath.inc b/recipes-core/classpath/classpath.inc
index 1bdfd78..0f760fe 100644
--- a/recipes-core/classpath/classpath.inc
+++ b/recipes-core/classpath/classpath.inc
@@ -7,7 +7,9 @@ LICENSE = "Classpath"
7 7
8PBN = "classpath" 8PBN = "classpath"
9 9
10inherit autotools java gettext 10inherit autotools java gettext distro_features_check
11
12REQUIRED_DISTRO_FEATURES = "x11"
11 13
12DEPENDS = "virtual/javac-native fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst file" 14DEPENDS = "virtual/javac-native fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst file"
13 15
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc
index bed1c5d..9d9fef6 100644
--- a/recipes-core/jamvm/jamvm.inc
+++ b/recipes-core/jamvm/jamvm.inc
@@ -21,7 +21,9 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz \
21 " 21 "
22 22
23 23
24inherit java autotools update-alternatives pkgconfig 24inherit java autotools update-alternatives pkgconfig distro_features_check
25
26REQUIRED_DISTRO_FEATURES = "x11"
25 27
26# This uses 32 bit arm, so force the instruction set to arm, not thumb 28# This uses 32 bit arm, so force the instruction set to arm, not thumb
27ARM_INSTRUCTION_SET = "arm" 29ARM_INSTRUCTION_SET = "arm"
diff --git a/recipes-core/openjdk/openjdk-common.inc b/recipes-core/openjdk/openjdk-common.inc
index dc26522..e3e597a 100644
--- a/recipes-core/openjdk/openjdk-common.inc
+++ b/recipes-core/openjdk/openjdk-common.inc
@@ -17,7 +17,9 @@ DEPENDS_append_libc-uclibc = " virtual/libiconv "
17# because structure sizes and/or alignment may differ. 17# because structure sizes and/or alignment may differ.
18DEPENDS_append = " qemu-native " 18DEPENDS_append = " qemu-native "
19 19
20inherit java autotools gettext qemu pkgconfig 20inherit java autotools gettext qemu pkgconfig distro_features_check
21
22REQUIRED_DISTRO_FEATURES = "x11"
21 23
22# OpenJDK uses slightly different names for certain arches. We need to know 24# OpenJDK uses slightly different names for certain arches. We need to know
23# this to create some files which are expected by the build. 25# this to create some files which are expected by the build.