diff options
-rw-r--r-- | recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch | 15 | ||||
-rw-r--r-- | recipes-core/jamvm/jamvm_git.bb | 3 |
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch b/recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch new file mode 100644 index 0000000..bf0fda5 --- /dev/null +++ b/recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | diff --git a/src/jam.c b/src/jam.c | ||
2 | index b76ce8b..dc5eac3 100644 | ||
3 | --- a/src/jam.c | ||
4 | +++ b/src/jam.c | ||
5 | @@ -133,9 +133,7 @@ int parseCommandLine(int argc, char *argv[], InitArgs *args) { | ||
6 | for(i = 1; i < argc; i++) { | ||
7 | if(*argv[i] != '-') { | ||
8 | if(args->min_heap > args->max_heap) { | ||
9 | - printf("Minimum heap size greater than max!\n"); | ||
10 | - status = 1; | ||
11 | - goto exit; | ||
12 | + args->min_heap = args->max_heap; | ||
13 | } | ||
14 | |||
15 | if(args->props_count) { | ||
diff --git a/recipes-core/jamvm/jamvm_git.bb b/recipes-core/jamvm/jamvm_git.bb index 2a4213b..7b28600 100644 --- a/recipes-core/jamvm/jamvm_git.bb +++ b/recipes-core/jamvm/jamvm_git.bb | |||
@@ -6,11 +6,12 @@ require jamvm.inc | |||
6 | SRCREV = "4617da717ecb05654ea5bb9572338061106a414d" | 6 | SRCREV = "4617da717ecb05654ea5bb9572338061106a414d" |
7 | PV = "1.5.5+1.6.0-devel+git${SRCPV}" | 7 | PV = "1.5.5+1.6.0-devel+git${SRCPV}" |
8 | 8 | ||
9 | PR = "r1" | 9 | PR = "r2" |
10 | 10 | ||
11 | SRC_URI = "git://git.berlios.de/jamvm;protocol=git \ | 11 | SRC_URI = "git://git.berlios.de/jamvm;protocol=git \ |
12 | file://jamvm-jni_h-noinst.patch \ | 12 | file://jamvm-jni_h-noinst.patch \ |
13 | file://libffi.patch \ | 13 | file://libffi.patch \ |
14 | file://jamvm-minmax-heap.patch \ | ||
14 | " | 15 | " |
15 | 16 | ||
16 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |