diff options
-rw-r--r-- | recipes-core/classpath/classpath-0.99/use_libdir.patch | 19 | ||||
-rw-r--r-- | recipes-core/classpath/classpath.inc | 2 | ||||
-rw-r--r-- | recipes-core/classpath/classpath_0.99.bb | 1 | ||||
-rw-r--r-- | recipes-core/dbus/dbus-java_2.7.bb | 92 | ||||
-rw-r--r-- | recipes-core/ecj/libecj-bootstrap.inc | 9 | ||||
-rw-r--r-- | recipes-core/fastjar/fastjar.inc | 5 | ||||
-rw-r--r-- | recipes-core/icedtea/icedtea7-native.inc | 3 | ||||
-rw-r--r-- | recipes-core/jakarta-libs/log4j1.2_1.2.17.bb | 4 | ||||
-rw-r--r-- | recipes-core/junit/junit_3.8.2.bb | 5 | ||||
-rw-r--r-- | recipes-core/libmatthew/files/Makefile-0.7.patch | 15 | ||||
-rw-r--r-- | recipes-core/libmatthew/libmatthew.inc | 68 | ||||
-rw-r--r-- | recipes-core/libmatthew/libmatthew_0.8.bb | 12 | ||||
-rw-r--r-- | recipes-core/openjdk/openjdk-7-03b21/icedtea-jdk-powerpc-atomic64.patch | 65 | ||||
-rw-r--r-- | recipes-core/openjdk/openjdk-7-release-03b21.inc | 2 |
14 files changed, 293 insertions, 9 deletions
diff --git a/recipes-core/classpath/classpath-0.99/use_libdir.patch b/recipes-core/classpath/classpath-0.99/use_libdir.patch new file mode 100644 index 0000000..3b4df90 --- /dev/null +++ b/recipes-core/classpath/classpath-0.99/use_libdir.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | on some arches we use lib64 for libdir so hardcoding to lib | ||
2 | is not gonna work always | ||
3 | |||
4 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
5 | |||
6 | Index: classpath-0.99/resource/Makefile.am | ||
7 | =================================================================== | ||
8 | --- classpath-0.99.orig/resource/Makefile.am 2006-01-12 12:15:43.000000000 -0800 | ||
9 | +++ classpath-0.99/resource/Makefile.am 2012-11-21 14:28:02.433005139 -0800 | ||
10 | @@ -1,7 +1,7 @@ | ||
11 | ## used by automake to generate Makefile.in | ||
12 | |||
13 | logging_DATA = java/util/logging/logging.properties | ||
14 | -loggingdir = $(prefix)/lib | ||
15 | +loggingdir = $(libdir) | ||
16 | |||
17 | security_DATA = java/security/classpath.security | ||
18 | -securitydir = $(prefix)/lib/security | ||
19 | +securitydir = $(libdir)/security | ||
diff --git a/recipes-core/classpath/classpath.inc b/recipes-core/classpath/classpath.inc index 1a8093e..214c9cd 100644 --- a/recipes-core/classpath/classpath.inc +++ b/recipes-core/classpath/classpath.inc | |||
@@ -21,7 +21,7 @@ RPROVIDES_${PN} = "${PBN}" | |||
21 | RPROVIDES_${PN}-common = "${PBN}-common" | 21 | RPROVIDES_${PN}-common = "${PBN}-common" |
22 | RPROVIDES_${PN}-gtk = "${PBN}-awt" | 22 | RPROVIDES_${PN}-gtk = "${PBN}-awt" |
23 | 23 | ||
24 | PR = "r1" | 24 | PR = "r2" |
25 | 25 | ||
26 | SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz" | 26 | SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz" |
27 | 27 | ||
diff --git a/recipes-core/classpath/classpath_0.99.bb b/recipes-core/classpath/classpath_0.99.bb index ee38992..7839519 100644 --- a/recipes-core/classpath/classpath_0.99.bb +++ b/recipes-core/classpath/classpath_0.99.bb | |||
@@ -8,6 +8,7 @@ SRC_URI += " \ | |||
8 | file://autotools.patch \ | 8 | file://autotools.patch \ |
9 | file://miscompilation.patch \ | 9 | file://miscompilation.patch \ |
10 | file://toolwrapper-exithook.patch \ | 10 | file://toolwrapper-exithook.patch \ |
11 | file://use_libdir.patch \ | ||
11 | " | 12 | " |
12 | 13 | ||
13 | SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4" | 14 | SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4" |
diff --git a/recipes-core/dbus/dbus-java_2.7.bb b/recipes-core/dbus/dbus-java_2.7.bb new file mode 100644 index 0000000..2fae051 --- /dev/null +++ b/recipes-core/dbus/dbus-java_2.7.bb | |||
@@ -0,0 +1,92 @@ | |||
1 | DESCRIPTION = "A pure Java D-Bus Implementation" | ||
2 | DESCRIPTION_dbus-java-viewer = "${DESCRIPTION} (DBusViewer Binary)" | ||
3 | DESCRIPTION_dbus-java-bin = "${DESCRIPTION} (Binaries)" | ||
4 | AUTHOR = "Matthew Johnson <dbus@matthew.ath.cx>" | ||
5 | HOMEPAGE = "http://dbus.freedesktop.org/doc/dbus-java" | ||
6 | SECTION = "libs" | ||
7 | LICENSE = "LGPL-2.1 & AFL-2.1" | ||
8 | |||
9 | DEPENDS = "libmatthew docbook-utils-native docbook-sgml-dtd-4.1-native fastjar-native" | ||
10 | RDEPENDS_dbus-java-viewer = "java2-runtime libunixsocket-java dbus-java-bin libmatthew-debug-java ${JPN}" | ||
11 | RDEPENDS_dbus-java-bin = "java2-runtime libunixsocket-java libmatthew-debug-java ${JPN}" | ||
12 | RSUGGESTS_libdbus-java = "libunixsocket-java" | ||
13 | |||
14 | PR = "r0" | ||
15 | LIC_FILES_CHKSUM = "file://COPYING;md5=72cc739fb93ae32741edbae802490e92" | ||
16 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus-java/dbus-java-${PV}.tar.gz" | ||
17 | |||
18 | SRC_URI[md5sum] = "8b8470db5cd657591bac245e3b6e18e4" | ||
19 | SRC_URI[sha256sum] = "be404ea36284d938646192d0ee42e146853064217d4e3aaf89b56bd351ebca33" | ||
20 | |||
21 | S = "${WORKDIR}/dbus-java-${PV}" | ||
22 | |||
23 | inherit java-library | ||
24 | |||
25 | # jamvm-native unfortunately contains non-generificed java/lang/reflect classes | ||
26 | # which are accessed in this package. Work around this by setting the bootclasspath | ||
27 | # explicitly. | ||
28 | JCFLAGS = "-bootclasspath ${STAGING_DATADIR}/classpath/glibj.zip" | ||
29 | |||
30 | do_compile () { | ||
31 | oe_runmake \ | ||
32 | JCFLAGS="-source 1.5 ${JCFLAGS}" \ | ||
33 | JAVAC="javac" \ | ||
34 | JARPREFIX="${STAGING_DATADIR_JAVA}" \ | ||
35 | JAVAUNIXJARDIR="${STAGING_DATADIR_JAVA}" \ | ||
36 | JAVAUNIXLIBDIR="${STAGING_DIR_TARGET}${libdir_jni}" \ | ||
37 | CLASSPATH="${S}/classes" \ | ||
38 | JAR="fastjar" \ | ||
39 | bin | ||
40 | |||
41 | # Generated shell scripts will have staging paths inside them. | ||
42 | rm bin/* | ||
43 | |||
44 | # Generate them again with target paths. | ||
45 | oe_runmake \ | ||
46 | JAVAC="oefatal \"No Java compilation expected here.\"" \ | ||
47 | JAR="oefatal \"No jar invocation expected here.\"" \ | ||
48 | JARPREFIX=${datadir_java} \ | ||
49 | JAVAUNIXJARDIR=${datadir_java} \ | ||
50 | JAVAUNIXLIBDIR=${libdir_jni} \ | ||
51 | bin | ||
52 | |||
53 | # Generate man pages. | ||
54 | oe_runmake \ | ||
55 | JAVAC="oefatal \"No Java compilation expected here.\"" \ | ||
56 | JAR="oefatal \"No jar invocation expected here.\"" \ | ||
57 | JARPREFIX=${datadir_java} \ | ||
58 | JAVAUNIXJARDIR=${datadir_java} \ | ||
59 | JAVAUNIXLIBDIR=${libdir_jni} \ | ||
60 | man | ||
61 | } | ||
62 | |||
63 | JARFILENAME = "${JPN}-${PV}.jar" | ||
64 | |||
65 | do_install () { | ||
66 | oe_jarinstall ${JPN}-${PV}.jar ${JPN}.jar dbus.jar | ||
67 | oe_jarinstall dbus-java-viewer-${PV}.jar dbus-java-viewer.jar dbus-viewer.jar | ||
68 | oe_jarinstall dbus-java-bin-${PV}.jar dbus-java-bin.jar dbus-bin.jar | ||
69 | |||
70 | install -d ${D}${bindir} | ||
71 | install bin/DBusViewer ${D}${bindir} | ||
72 | install bin/DBusCall ${D}${bindir} | ||
73 | install bin/CreateInterface ${D}${bindir} | ||
74 | install bin/ListDBus ${D}${bindir} | ||
75 | install bin/DBusDaemon ${D}${bindir} | ||
76 | |||
77 | oe_runmake \ | ||
78 | JAVAC="oefatal \"No Java compilation expected here.\"" \ | ||
79 | JAR="oefatal \"No jar invocation expected here.\"" \ | ||
80 | MANPREFIX=${D}${mandir} \ | ||
81 | DOCPREFIX=${D}${docdir}/${JPN} \ | ||
82 | install-man | ||
83 | } | ||
84 | |||
85 | # ${JPN} must be last otherwise it would pick up dbus-viewer*.jar | ||
86 | # and dbus-bin*.jar | ||
87 | PACKAGES = "dbus-java-viewer dbus-java-viewer-doc dbus-java-bin dbus-java-bin-doc ${JPN}" | ||
88 | |||
89 | FILES_dbus-java-viewer = "${datadir}/java/dbus-java-viewer*.jar ${bindir}/DBusViewer" | ||
90 | FILES_dbus-java-viewer-doc = "${mandir}/DBusViewer*" | ||
91 | FILES_dbus-java-bin = "${datadir}/java/dbus-java-bin*.jar ${bindir}" | ||
92 | FILES_dbus-java-bin-doc = "${mandir} ${docdir}/${JPN}" | ||
diff --git a/recipes-core/ecj/libecj-bootstrap.inc b/recipes-core/ecj/libecj-bootstrap.inc index 4f85ba9..9e1cc1d 100644 --- a/recipes-core/ecj/libecj-bootstrap.inc +++ b/recipes-core/ecj/libecj-bootstrap.inc | |||
@@ -25,17 +25,18 @@ do_unpackpost() { | |||
25 | fi | 25 | fi |
26 | 26 | ||
27 | # Remove crap. | 27 | # Remove crap. |
28 | rm about.html build.xml | 28 | rm -f about.html build.xml |
29 | rm -rf META-INF | 29 | rm -rf META-INF |
30 | 30 | ||
31 | # Move source into separate subdir. | 31 | # Move source into separate subdir. |
32 | mv org source/ | 32 | if [ -d org ]; then |
33 | 33 | mv org source/ | |
34 | fi | ||
34 | # Remove stuff unneeded for the bootstrap compiler. | 35 | # Remove stuff unneeded for the bootstrap compiler. |
35 | rm -rf source/org/eclipse/jdt/internal/compiler/apt | 36 | rm -rf source/org/eclipse/jdt/internal/compiler/apt |
36 | rm -rf source/org/eclipse/jdt/internal/compiler/tool | 37 | rm -rf source/org/eclipse/jdt/internal/compiler/tool |
37 | rm -rf source/org/eclipse/jdt/internal/antadapter | 38 | rm -rf source/org/eclipse/jdt/internal/antadapter |
38 | rm source/org/eclipse/jdt/core/JDTCompilerAdapter.java | 39 | rm -f source/org/eclipse/jdt/core/JDTCompilerAdapter.java |
39 | 40 | ||
40 | # Make a copy of the remaining source to get the embedded | 41 | # Make a copy of the remaining source to get the embedded |
41 | # resources. | 42 | # resources. |
diff --git a/recipes-core/fastjar/fastjar.inc b/recipes-core/fastjar/fastjar.inc index efbc226..eb3d354 100644 --- a/recipes-core/fastjar/fastjar.inc +++ b/recipes-core/fastjar/fastjar.inc | |||
@@ -19,4 +19,9 @@ ALTERNATIVE_NAME = "jar" | |||
19 | ALTERNATIVE_LINK = "${bindir}/jar" | 19 | ALTERNATIVE_LINK = "${bindir}/jar" |
20 | ALTERNATIVE_PATH = "${bindir}/fastjar" | 20 | ALTERNATIVE_PATH = "${bindir}/fastjar" |
21 | 21 | ||
22 | # update-aternatives does not work for native class | ||
23 | do_install_append_class-native () { | ||
24 | ln -s fastjar ${D}${bindir}/jar | ||
25 | } | ||
26 | |||
22 | BBCLASSEXTEND = "native" | 27 | BBCLASSEXTEND = "native" |
diff --git a/recipes-core/icedtea/icedtea7-native.inc b/recipes-core/icedtea/icedtea7-native.inc index e209a68..b9e2056 100644 --- a/recipes-core/icedtea/icedtea7-native.inc +++ b/recipes-core/icedtea/icedtea7-native.inc | |||
@@ -1,7 +1,7 @@ | |||
1 | DESCRIPTION = "Harness to build the source code from OpenJDK using Free Software build tools" | 1 | DESCRIPTION = "Harness to build the source code from OpenJDK using Free Software build tools" |
2 | HOMEPAGE = "http://icedtea.classpath.org" | 2 | HOMEPAGE = "http://icedtea.classpath.org" |
3 | LICENSE = "GPL-2.0-with-classpath-exception" | 3 | LICENSE = "GPL-2.0-with-classpath-exception" |
4 | INC_PR = "r0" | 4 | INC_PR = "r1" |
5 | 5 | ||
6 | DEPENDS = "virtual/javac-native virtual/java-native classpath-native \ | 6 | DEPENDS = "virtual/javac-native virtual/java-native classpath-native \ |
7 | rhino-native ant-native \ | 7 | rhino-native ant-native \ |
@@ -9,6 +9,7 @@ DEPENDS = "virtual/javac-native virtual/java-native classpath-native \ | |||
9 | giflib-native jpeg-native libpng-native \ | 9 | giflib-native jpeg-native libpng-native \ |
10 | glib-2.0-native freetype-native zlib-native \ | 10 | glib-2.0-native freetype-native zlib-native \ |
11 | fontconfig-native zip-native alsa-lib-native \ | 11 | fontconfig-native zip-native alsa-lib-native \ |
12 | unzip-native \ | ||
12 | " | 13 | " |
13 | 14 | ||
14 | inherit native java autotools | 15 | inherit native java autotools |
diff --git a/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb b/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb index b37eb05..ec1aa55 100644 --- a/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb +++ b/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb | |||
@@ -3,6 +3,8 @@ AUTHOR = "Apache Software Foundation" | |||
3 | LICENSE = "AL2.0" | 3 | LICENSE = "AL2.0" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f4ce41a6d1028498fcacde12f589bce7" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f4ce41a6d1028498fcacde12f589bce7" |
5 | 5 | ||
6 | PR = "r1" | ||
7 | |||
6 | SRC_URI = "http://archive.apache.org/dist/logging/log4j/${PV}/log4j-${PV}.tar.gz" | 8 | SRC_URI = "http://archive.apache.org/dist/logging/log4j/${PV}/log4j-${PV}.tar.gz" |
7 | 9 | ||
8 | inherit java-library | 10 | inherit java-library |
@@ -18,7 +20,7 @@ ALTJARFILENAMES = "log4j-1.2.jar log4j1.2.jar" | |||
18 | do_compile() { | 20 | do_compile() { |
19 | mkdir -p build | 21 | mkdir -p build |
20 | 22 | ||
21 | oe_makeclasspath cp -s activation gnumail | 23 | oe_makeclasspath cp -s activation gnumail gnujaf |
22 | 24 | ||
23 | # Built everything but the JMS and JMX classes (like in Debian) | 25 | # Built everything but the JMS and JMX classes (like in Debian) |
24 | javac -sourcepath src/main/java -cp $cp -d build `find src/main/java -name "*.java" -and -not \( -iwholename "*jms*" -or -iwholename "*jmx*" \)` | 26 | javac -sourcepath src/main/java -cp $cp -d build `find src/main/java -name "*.java" -and -not \( -iwholename "*jms*" -or -iwholename "*jmx*" \)` |
diff --git a/recipes-core/junit/junit_3.8.2.bb b/recipes-core/junit/junit_3.8.2.bb index 9d56618..ded03f2 100644 --- a/recipes-core/junit/junit_3.8.2.bb +++ b/recipes-core/junit/junit_3.8.2.bb | |||
@@ -14,8 +14,9 @@ do_unpackpost() { | |||
14 | mkdir -p src | 14 | mkdir -p src |
15 | 15 | ||
16 | # Prevent deletion by do_removebinaries. | 16 | # Prevent deletion by do_removebinaries. |
17 | mv src.jar src.zip | 17 | if [ -e src.jar ]; then |
18 | 18 | mv src.jar src.zip | |
19 | fi | ||
19 | unzip src.zip -d src | 20 | unzip src.zip -d src |
20 | } | 21 | } |
21 | 22 | ||
diff --git a/recipes-core/libmatthew/files/Makefile-0.7.patch b/recipes-core/libmatthew/files/Makefile-0.7.patch new file mode 100644 index 0000000..4a91cd5 --- /dev/null +++ b/recipes-core/libmatthew/files/Makefile-0.7.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | Index: libmatthew-java-0.7/Makefile | ||
2 | =================================================================== | ||
3 | --- libmatthew-java-0.7.orig/Makefile 2008-05-27 13:17:47.000000000 +0800 | ||
4 | +++ libmatthew-java-0.7/Makefile 2008-05-27 13:18:04.000000000 +0800 | ||
5 | @@ -8,8 +8,8 @@ | ||
6 | PPFLAGS+=-C -P | ||
7 | CFLAGS+=-fpic -Wall -Os -pedantic -std=c99 -Werror | ||
8 | GCJFLAGS+=-fjni | ||
9 | -JCFLAGS+=-source 5.0 | ||
10 | -INCLUDES+=-I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux | ||
11 | +#JCFLAGS+=-source 5.0 | ||
12 | +#INCLUDES+=-I$(JAVA_HOME)/include -I$(JAVA_HOME)/include/linux | ||
13 | JAVADOCFLAGS?=-quiet -author -link http://java.sun.com/j2se/1.4.2/docs/api/ | ||
14 | |||
15 | LDVER?=$(shell ld -v | cut -d' ' -f1) | ||
diff --git a/recipes-core/libmatthew/libmatthew.inc b/recipes-core/libmatthew/libmatthew.inc new file mode 100644 index 0000000..d0ea00a --- /dev/null +++ b/recipes-core/libmatthew/libmatthew.inc | |||
@@ -0,0 +1,68 @@ | |||
1 | DESCRIPTION = "Unix socket, debug and hexdump JAVA libraries" | ||
2 | AUTHOR = "Matthew Johnson <web@matthew.ath.cx>" | ||
3 | HOMEPAGE = "http://www.matthew.ath.cx/projects/java" | ||
4 | SECTION = "libs" | ||
5 | LICENSE = "MIT" | ||
6 | DEPENDS = "virtual/java-native classpath-native classpath" | ||
7 | |||
8 | S = "${WORKDIR}/libmatthew-java-${PV}" | ||
9 | |||
10 | inherit java-library | ||
11 | |||
12 | # Some internal version numbers which change from time to time. | ||
13 | # Allowing to override them makes this include file more | ||
14 | # versatile. | ||
15 | VER_CGI ?= "0.6" | ||
16 | VER_DEBUG ?= "1.1" | ||
17 | VER_HEXDUMP ?= "0.2" | ||
18 | VER_IO ?= "0.1" | ||
19 | VER_UNIX ?= "0.5" | ||
20 | |||
21 | do_compile() { | ||
22 | oe_runmake \ | ||
23 | JAVAC="javac" \ | ||
24 | JAR="fastjar" \ | ||
25 | JAVAH="gjavah" \ | ||
26 | INCLUDES="-I${STAGING_INCDIR}/classpath" \ | ||
27 | LDFLAGS="-fpic -shared -lc ${LDFLAGS}" \ | ||
28 | LD="${CC}" \ | ||
29 | CFLAGS="-fpic -Wall -Os -pedantic -std=c99 -Werror" | ||
30 | } | ||
31 | |||
32 | # we do not have jar name corresponding to JPN | ||
33 | # which will be installed via JARFILENAME see java-library.bbclass | ||
34 | # create a dummy for install to succeed | ||
35 | |||
36 | JARFILENAME = "unix-${VER_UNIX}.jar" | ||
37 | |||
38 | do_install() { | ||
39 | oe_jarinstall cgi-${VER_CGI}.jar cgi.jar | ||
40 | oe_jarinstall debug-disable-${VER_DEBUG}.jar debug-disable.jar | ||
41 | oe_jarinstall debug-enable-${VER_DEBUG}.jar debug-enable.jar | ||
42 | oe_jarinstall hexdump-${VER_HEXDUMP}.jar hexdump.jar | ||
43 | oe_jarinstall io-${VER_IO}.jar io.jar | ||
44 | oe_jarinstall unix-${VER_UNIX}.jar unix.jar | ||
45 | oe_libinstall -so libcgi-java ${D}${libdir_jni} | ||
46 | oe_libinstall -so libunix-java ${D}${libdir_jni} | ||
47 | } | ||
48 | |||
49 | PACKAGES = "\ | ||
50 | libcgi-java libcgi-jni libcgi-jni-dbg \ | ||
51 | libunixsocket-java libunixsocket-jni libunixsocket-jni-dbg \ | ||
52 | ${PN}-io-java ${PN}-debug-java \ | ||
53 | " | ||
54 | |||
55 | FILES_libcgi-java = "${datadir_java}/cgi*.jar" | ||
56 | FILES_libcgi-jni = "${libdir_jni}/libcgi-java.so" | ||
57 | FILES_libcgi-jni-dbg = "${libdir_jni}/.debug/libcgi-java.so" | ||
58 | RDEPENDS_libcgi-java = "libcgi-jni" | ||
59 | |||
60 | FILES_libunixsocket-java = "${datadir_java}/unix*.jar" | ||
61 | FILES_libunixsocket-jni = "${libdir_jni}/libunix-java.so" | ||
62 | FILES_libunixsocket-jni-dbg = "${libdir_jni}/.debug/libunix-java.so" | ||
63 | RDEPENDS_libunixsocket-java = "libunixsocket-jni" | ||
64 | |||
65 | FILES_${PN}-io-java = "${datadir_java}/io*.jar" | ||
66 | |||
67 | FILES_${PN}-debug-java = "${datadir_java}/debug-*.jar ${datadir_java}/hexdump*.jar" | ||
68 | |||
diff --git a/recipes-core/libmatthew/libmatthew_0.8.bb b/recipes-core/libmatthew/libmatthew_0.8.bb new file mode 100644 index 0000000..c4ace08 --- /dev/null +++ b/recipes-core/libmatthew/libmatthew_0.8.bb | |||
@@ -0,0 +1,12 @@ | |||
1 | require libmatthew.inc | ||
2 | |||
3 | PR = "r0" | ||
4 | |||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=48a42f2f9747f02bf40a0bce2655b509" | ||
6 | |||
7 | SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/libmatthew-java/libmatthew-java-0.8.tar.gz/8455b8751083ce25c99c2840609271f5/libmatthew-java-${PV}.tar.gz \ | ||
8 | " | ||
9 | # file://Makefile-0.7.patch" | ||
10 | SRC_URI[md5sum] = "8455b8751083ce25c99c2840609271f5" | ||
11 | SRC_URI[sha256sum] = "05d1d3d9b5e33bd3642102aae10bba904e296c5c01a10854200ad4df349c8dfa" | ||
12 | |||
diff --git a/recipes-core/openjdk/openjdk-7-03b21/icedtea-jdk-powerpc-atomic64.patch b/recipes-core/openjdk/openjdk-7-03b21/icedtea-jdk-powerpc-atomic64.patch new file mode 100644 index 0000000..cc5e4e8 --- /dev/null +++ b/recipes-core/openjdk/openjdk-7-03b21/icedtea-jdk-powerpc-atomic64.patch | |||
@@ -0,0 +1,65 @@ | |||
1 | http://mail.openjdk.java.net/pipermail/zero-dev/2010-June/000346.html | ||
2 | |||
3 | this cute C code does the same thing on powerpc as the assembly code that | ||
4 | was here before. If the compiler was built with the SPE extensions instead | ||
5 | of traditional FPU and double operations are performed in HW then we are | ||
6 | one step further: The compiler turns this into evldd & evstdd. Voila :) | ||
7 | |||
8 | This C code could also be activated on s390. The compiler turns this into | ||
9 | a single mvc instruction which does the copy operation. I don't know if | ||
10 | mvc's copy ability is atomic _or_ not and therefore I leave it as it. | ||
11 | |||
12 | Signed-off-by: Sebastian Andrzej Siewior <bigeasy at linutronix.de> | ||
13 | |||
14 | ./openjdk-src-dir/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.hpp | ||
15 | Index: openjdk/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.hpp | ||
16 | =================================================================== | ||
17 | --- openjdk/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.hpp.org 2011-11-14 14:07:32.000000000 -0800 | ||
18 | +++ openjdk/hotspot/src/os_cpu/linux_zero/vm/os_linux_zero.hpp 2012-07-19 07:28:26.208405923 -0700 | ||
19 | @@ -25,6 +25,16 @@ | ||
20 | |||
21 | #ifndef OS_CPU_LINUX_ZERO_VM_OS_LINUX_ZERO_HPP | ||
22 | #define OS_CPU_LINUX_ZERO_VM_OS_LINUX_ZERO_HPP | ||
23 | +#if defined(PPC) && !defined(_LP64) | ||
24 | + | ||
25 | +#ifndef __NO_FPRS__ | ||
26 | +#define ATOMIC64_COPY_THROUGH_DOUBLE 1 | ||
27 | + | ||
28 | +#elif defined(__SPE__) && !defined(_SOFT_DOUBLE) | ||
29 | +#define ATOMIC64_COPY_THROUGH_DOUBLE 1 | ||
30 | + | ||
31 | +#endif | ||
32 | +#endif | ||
33 | |||
34 | static void setup_fpu() {} | ||
35 | |||
36 | @@ -36,12 +46,23 @@ | ||
37 | |||
38 | // Atomically copy 64 bits of data | ||
39 | static void atomic_copy64(volatile void *src, volatile void *dst) { | ||
40 | -#if defined(PPC) && !defined(_LP64) | ||
41 | - double tmp; | ||
42 | - asm volatile ("lfd %0, 0(%1)\n" | ||
43 | - "stfd %0, 0(%2)\n" | ||
44 | - : "=f"(tmp) | ||
45 | - : "b"(src), "b"(dst)); | ||
46 | +#if ATOMIC64_COPY_THROUGH_DOUBLE | ||
47 | + /* | ||
48 | + * In order to copy 8 bytes atomicly we rely on the trick that some | ||
49 | + * architectures can load and store a double as a single operation. | ||
50 | + * gcc picks the correct opcode here and with optimization turned on | ||
51 | + * all temporary assignments are gone. - bigeasy | ||
52 | + */ | ||
53 | + union { | ||
54 | + double *d; | ||
55 | + volatile void *v; | ||
56 | + } s, d; | ||
57 | + | ||
58 | + s.v = src; | ||
59 | + d.v = dst; | ||
60 | + | ||
61 | + *d.d = *s.d; | ||
62 | + | ||
63 | #elif defined(S390) && !defined(_LP64) | ||
64 | double tmp; | ||
65 | asm volatile ("ld %0, 0(%1)\n" | ||
diff --git a/recipes-core/openjdk/openjdk-7-release-03b21.inc b/recipes-core/openjdk/openjdk-7-release-03b21.inc index 40c1cf6..2038e07 100644 --- a/recipes-core/openjdk/openjdk-7-release-03b21.inc +++ b/recipes-core/openjdk/openjdk-7-release-03b21.inc | |||
@@ -96,6 +96,7 @@ ICEDTEAPATCHES = "\ | |||
96 | ICEDTEAPATCHES_append_powerpc = " \ | 96 | ICEDTEAPATCHES_append_powerpc = " \ |
97 | file://icedtea-jdk-nio-use-host-cc.patch;apply=no \ | 97 | file://icedtea-jdk-nio-use-host-cc.patch;apply=no \ |
98 | file://icedtea-jdk-ppc64-jvm-cfg.patch;apply=no \ | 98 | file://icedtea-jdk-ppc64-jvm-cfg.patch;apply=no \ |
99 | file://icedtea-jdk-powerpc-atomic64.patch;apply=no \ | ||
99 | " | 100 | " |
100 | ICEDTEAPATCHES_append_powerpc64 = " \ | 101 | ICEDTEAPATCHES_append_powerpc64 = " \ |
101 | file://icedtea-jdk-nio-use-host-cc.patch;apply=no \ | 102 | file://icedtea-jdk-nio-use-host-cc.patch;apply=no \ |
@@ -139,6 +140,7 @@ DISTRIBUTION_PATCHES_append_libc-uclibc = "\ | |||
139 | DISTRIBUTION_PATCHES_append_powerpc = " \ | 140 | DISTRIBUTION_PATCHES_append_powerpc = " \ |
140 | patches/icedtea-jdk-nio-use-host-cc.patch \ | 141 | patches/icedtea-jdk-nio-use-host-cc.patch \ |
141 | patches/icedtea-jdk-ppc64-jvm-cfg.patch \ | 142 | patches/icedtea-jdk-ppc64-jvm-cfg.patch \ |
143 | patches/icedtea-jdk-powerpc-atomic64.patch \ | ||
142 | " | 144 | " |
143 | DISTRIBUTION_PATCHES_append_powerpc64 = " \ | 145 | DISTRIBUTION_PATCHES_append_powerpc64 = " \ |
144 | patches/icedtea-jdk-nio-use-host-cc.patch \ | 146 | patches/icedtea-jdk-nio-use-host-cc.patch \ |