diff options
-rw-r--r-- | recipes-core/classpath/classpath.inc | 4 | ||||
-rw-r--r-- | recipes-core/jamvm/jamvm-initial_1.4.5.bb | 5 | ||||
-rw-r--r-- | recipes-core/jamvm/jamvm.inc | 3 |
3 files changed, 9 insertions, 3 deletions
diff --git a/recipes-core/classpath/classpath.inc b/recipes-core/classpath/classpath.inc index 214c9cd..1bdfd78 100644 --- a/recipes-core/classpath/classpath.inc +++ b/recipes-core/classpath/classpath.inc | |||
@@ -9,7 +9,7 @@ PBN = "classpath" | |||
9 | 9 | ||
10 | inherit autotools java gettext | 10 | inherit autotools java gettext |
11 | 11 | ||
12 | DEPENDS = "virtual/javac-native fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst" | 12 | DEPENDS = "virtual/javac-native fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst file" |
13 | 13 | ||
14 | RPROVIDES_${PN} = "" | 14 | RPROVIDES_${PN} = "" |
15 | 15 | ||
@@ -21,7 +21,7 @@ RPROVIDES_${PN} = "${PBN}" | |||
21 | RPROVIDES_${PN}-common = "${PBN}-common" | 21 | RPROVIDES_${PN}-common = "${PBN}-common" |
22 | RPROVIDES_${PN}-gtk = "${PBN}-awt" | 22 | RPROVIDES_${PN}-gtk = "${PBN}-awt" |
23 | 23 | ||
24 | PR = "r2" | 24 | PR = "r3" |
25 | 25 | ||
26 | SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz" | 26 | SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz" |
27 | 27 | ||
diff --git a/recipes-core/jamvm/jamvm-initial_1.4.5.bb b/recipes-core/jamvm/jamvm-initial_1.4.5.bb index ea5a9d2..d317695 100644 --- a/recipes-core/jamvm/jamvm-initial_1.4.5.bb +++ b/recipes-core/jamvm/jamvm-initial_1.4.5.bb | |||
@@ -20,7 +20,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz \ | |||
20 | # This uses 32 bit arm, so force the instruction set to arm, not thumb | 20 | # This uses 32 bit arm, so force the instruction set to arm, not thumb |
21 | ARM_INSTRUCTION_SET = "arm" | 21 | ARM_INSTRUCTION_SET = "arm" |
22 | 22 | ||
23 | inherit native autotools | 23 | inherit native autotools pkgconfig |
24 | 24 | ||
25 | # libdir must be modified so that jamvm-initial and -native | 25 | # libdir must be modified so that jamvm-initial and -native |
26 | # do not interfere | 26 | # do not interfere |
@@ -45,3 +45,6 @@ do_install_append() { | |||
45 | 45 | ||
46 | SRC_URI[md5sum] = "3f538bab6e1c77aed331e5e71f754f5b" | 46 | SRC_URI[md5sum] = "3f538bab6e1c77aed331e5e71f754f5b" |
47 | SRC_URI[sha256sum] = "f329d1c8f42c06b53a3e82763d33900b100b8e9acd7afe02f7583c51253fd6e5" | 47 | SRC_URI[sha256sum] = "f329d1c8f42c06b53a3e82763d33900b100b8e9acd7afe02f7583c51253fd6e5" |
48 | # shared state for jamvm-native does not work | ||
49 | # since the paths are hardcoded | ||
50 | SSTATE_MIRRORS_class-native = "" | ||
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc index bf2bc4b..ee0e5c0 100644 --- a/recipes-core/jamvm/jamvm.inc +++ b/recipes-core/jamvm/jamvm.inc | |||
@@ -47,4 +47,7 @@ FILES_${PN} += "${libdir}/jamvm/lib*.so" | |||
47 | ALTERNATIVE_NAME = "java" | 47 | ALTERNATIVE_NAME = "java" |
48 | ALTERNATIVE_PATH = "${bindir}/jamvm" | 48 | ALTERNATIVE_PATH = "${bindir}/jamvm" |
49 | ALTERNATIVE_PRIORITY = "4" | 49 | ALTERNATIVE_PRIORITY = "4" |
50 | # shared state for jamvm-native does not work | ||
51 | # since the paths are hardcoded | ||
52 | SSTATE_MIRRORS_class-native = "" | ||
50 | 53 | ||