summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/openjdk/openjdk-6-6b24/icedtea-jdk-sizers-crosscompile-hack.patch61
-rw-r--r--recipes-core/openjdk/openjdk-6-release-6b24.inc13
2 files changed, 73 insertions, 1 deletions
diff --git a/recipes-core/openjdk/openjdk-6-6b24/icedtea-jdk-sizers-crosscompile-hack.patch b/recipes-core/openjdk/openjdk-6-6b24/icedtea-jdk-sizers-crosscompile-hack.patch
new file mode 100644
index 0000000..54d6a19
--- /dev/null
+++ b/recipes-core/openjdk/openjdk-6-6b24/icedtea-jdk-sizers-crosscompile-hack.patch
@@ -0,0 +1,61 @@
1Disable xawt and jawt along with sizes generation which does not work well if
2you cant generated sizes in cross env. So for architectures which dont have
3working qemu this is an option
4
5Signed-off-by: Khem Raj <raj.khem@gmail.com>
6Upstream-Status: Inappropriate [Cross-compile specific hack]
7
8--- openjdk/jdk/make/sun/xawt/Makefile.khem 2012-07-21 23:54:47.396405922 -0700
9+++ openjdk/jdk/make/sun/xawt/Makefile 2012-07-21 23:55:52.032405922 -0700
10@@ -245,18 +245,19 @@
11 $(SIZER_DIR) $(XLIBTYPES) "sizer" $(subst .,,$(suffix $(basename $@)))
12
13 $(SIZES): $(SIZERS)
14- @if [ "$(DOHACK)$@" = "true$(PREDEFINED_SIZES)" ]; then \
15- $(ECHO) COPYING $(PREDEFINED_SIZES_TMPL) into $@; \
16- $(CP) $(PREDEFINED_SIZES_TMPL) $@; \
17- $(CHMOD) +w $@;\
18- else \
19- $(ECHO) GENERATING $@; \
20- $(QEMU) $(WRAPPER_GENERATOR_DIR)/sizer$(suffix $@) > $@; \
21- fi
22- @if [ "$(DOCOMPARE)$(suffix $@)" = "true.64" ]; then \
23- $(ECHO) COMPARING $@ and $(STORED_SIZES_TMPL_$(PLATFORM)_$(LIBARCH)); \
24- $(DIFF) $@ $(STORED_SIZES_TMPL_$(PLATFORM)_$(LIBARCH)); \
25- fi
26+ touch $(SIZES)
27+# @if [ "$(DOHACK)$@" = "true$(PREDEFINED_SIZES)" ]; then \
28+# $(ECHO) COPYING $(PREDEFINED_SIZES_TMPL) into $@; \
29+# $(CP) $(PREDEFINED_SIZES_TMPL) $@; \
30+# $(CHMOD) +w $@;\
31+# else \
32+# $(ECHO) GENERATING $@; \
33+# $(QEMU) $(WRAPPER_GENERATOR_DIR)/sizer$(suffix $@) > $@; \
34+# fi
35+# @if [ "$(DOCOMPARE)$(suffix $@)" = "true.64" ]; then \
36+# $(ECHO) COMPARING $@ and $(STORED_SIZES_TMPL_$(PLATFORM)_$(LIBARCH)); \
37+# $(DIFF) $@ $(STORED_SIZES_TMPL_$(PLATFORM)_$(LIBARCH)); \
38+# fi
39
40 $(TEMPDIR)/.gen.wrappers: $(SIZES) $(WRAPPER_GENERATOR_CLASS) $(XLIBTYPES)
41 $(BOOT_JAVA_CMD) -cp $(WRAPPER_GENERATOR_TEMPDIR) WrapperGenerator \
42--- openjdk/jdk/make/sun/Makefile.khem 2011-11-14 14:11:40.000000000 -0800
43+++ openjdk/jdk/make/sun/Makefile 2012-07-22 00:42:04.980409296 -0700
44@@ -50,7 +50,7 @@
45 MOTIF_SUBDIRS = motif12 motif21
46 endif
47 HEADLESS_SUBDIR = headless
48- XAWT_SUBDIR = xawt
49+ XAWT_SUBDIR =
50 endif
51
52 ifndef OPENJDK
53@@ -65,7 +65,7 @@
54 awt splashscreen $(XAWT_SUBDIR) $(MOTIF_SUBDIRS) \
55 $(HEADLESS_SUBDIR) $(DGA_SUBDIR) \
56 font jpeg cmm applet rmi beans $(JDBC_SUBDIR) \
57- jawt text nio launcher management $(ORG_SUBDIR) \
58+ text nio launcher management $(ORG_SUBDIR) \
59 native2ascii serialver tools jconsole
60
61 all build clean clobber::
diff --git a/recipes-core/openjdk/openjdk-6-release-6b24.inc b/recipes-core/openjdk/openjdk-6-release-6b24.inc
index b867fb3..1da7ffb 100644
--- a/recipes-core/openjdk/openjdk-6-release-6b24.inc
+++ b/recipes-core/openjdk/openjdk-6-release-6b24.inc
@@ -83,7 +83,12 @@ ICEDTEAPATCHES = "\
83 file://icedtea-zero-hotspotfix.patch;apply=no \ 83 file://icedtea-zero-hotspotfix.patch;apply=no \
84 file://icedtea-jdk-powerpc-atomic64.patch;apply=no \ 84 file://icedtea-jdk-powerpc-atomic64.patch;apply=no \
85 " 85 "
86 86ICEDTEAPATCHES_append_e5500-64b = " \
87 file://icedtea-jdk-sizers-crosscompile-hack.patch;apply=no \
88 "
89ICEDTEAPATCHES_append_e5500 = " \
90 file://icedtea-jdk-sizers-crosscompile-hack.patch;apply=no \
91 "
87ICEDTEAPATCHES_append_libc-uclibc = " \ 92ICEDTEAPATCHES_append_libc-uclibc = " \
88 file://icedtea-hotspot-isfinte.patch;apply=no \ 93 file://icedtea-hotspot-isfinte.patch;apply=no \
89 file://icedtea-hotspot-glibc-version.patch;apply=no \ 94 file://icedtea-hotspot-glibc-version.patch;apply=no \
@@ -119,5 +124,11 @@ DISTRIBUTION_PATCHES_append_libc-uclibc = "\
119 patches/icedtea-jdk-unpack-uclibc.patch \ 124 patches/icedtea-jdk-unpack-uclibc.patch \
120 patches/icedtea-hotspot-dlvsym-uclibc.patch \ 125 patches/icedtea-hotspot-dlvsym-uclibc.patch \
121 " 126 "
127DISTRIBUTION_PATCHES_append_e5500-64b = " \
128 patches/icedtea-jdk-sizers-crosscompile-hack.patch \
129 "
122 130
131DISTRIBUTION_PATCHES_append_e5500 = " \
132 patches/icedtea-jdk-sizers-crosscompile-hack.patch \
133 "
123export DISTRIBUTION_PATCHES 134export DISTRIBUTION_PATCHES