diff options
Diffstat (limited to 'recipes-core/openjdk/openjdk-7-25b30/build-hacks.patch')
-rw-r--r-- | recipes-core/openjdk/openjdk-7-25b30/build-hacks.patch | 60 |
1 files changed, 60 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-7-25b30/build-hacks.patch b/recipes-core/openjdk/openjdk-7-25b30/build-hacks.patch new file mode 100644 index 0000000..5eccc68 --- /dev/null +++ b/recipes-core/openjdk/openjdk-7-25b30/build-hacks.patch | |||
@@ -0,0 +1,60 @@ | |||
1 | Index: icedtea-2.3.12/Makefile.am | ||
2 | =================================================================== | ||
3 | --- icedtea-2.3.12.orig/Makefile.am 2013-07-26 18:17:45.499466367 +0000 | ||
4 | +++ icedtea-2.3.12/Makefile.am 2013-07-30 21:04:46.761410713 +0000 | ||
5 | @@ -471,6 +471,12 @@ | ||
6 | JAVAC="" \ | ||
7 | JAVA_HOME="" \ | ||
8 | JDK_HOME="" \ | ||
9 | + OE_CFLAGS="$(OE_CFLAGS)" \ | ||
10 | + OE_CPPFLAGS="$(OE_CPPFLAGS)" \ | ||
11 | + OE_CXXFLAGS="$(OE_CXXFLAGS)" \ | ||
12 | + OE_LDFLAGS="$(OE_LDFLAGS)" \ | ||
13 | + OE_LAUNCHER_LDFLAGS="$(OE_LAUNCHER_LDFLAGS)" \ | ||
14 | + DISTRIBUTION_ID="$(DIST_ID)" \ | ||
15 | QUIETLY="" \ | ||
16 | ANT_RESPECT_JAVA_HOME="TRUE" \ | ||
17 | DISTRIBUTION_ID="$(DIST_ID)" \ | ||
18 | @@ -2028,7 +2034,11 @@ | ||
19 | if BUILD_JAMVM | ||
20 | cd jamvm/jamvm && \ | ||
21 | ./autogen.sh --with-java-runtime-library=openjdk7 \ | ||
22 | - --prefix=$(abs_top_builddir)/jamvm/install ; \ | ||
23 | + --prefix=$(abs_top_builddir)/jamvm/install \ | ||
24 | + --host=$(host_alias) \ | ||
25 | + --build=$(build_alias) \ | ||
26 | + --target=$(target_alias) \ | ||
27 | + --with-libtool-sysroot ; \ | ||
28 | $(MAKE) ; \ | ||
29 | $(MAKE) install | ||
30 | mkdir -p $(abs_top_builddir)/jamvm/install/hotspot/jre/lib/$(INSTALL_ARCH_DIR)/server | ||
31 | @@ -2093,6 +2103,7 @@ | ||
32 | --host=$(host_alias) \ | ||
33 | --build=$(build_alias) \ | ||
34 | --target=$(target_alias) \ | ||
35 | + --with-libtool-sysroot \ | ||
36 | --prefix=$(abs_top_builddir)/cacao/install \ | ||
37 | --with-java-runtime-library=openjdk7 \ | ||
38 | --with-java-runtime-library-prefix=$(abs_top_builddir)/openjdk \ | ||
39 | @@ -2160,7 +2171,7 @@ | ||
40 | # configure script arguments, quoted in single quotes | ||
41 | CONFIGURE_ARGS = @CONFIGURE_ARGS@ | ||
42 | ADD_ZERO_CONFIGURE_ARGS = \ | ||
43 | - --with-jdk-home=$(BUILD_OUTPUT_DIR)/j2sdk-image \ | ||
44 | + --with-jdk-home=$(abs_top_builddir)/bootstrap/jdk1.6.0 \ | ||
45 | --disable-bootstrap --enable-zero | ||
46 | if ADD_SHARK_BUILD | ||
47 | ADD_ZERO_CONFIGURE_ARGS += \ | ||
48 | Index: icedtea-2.3.12/javac.in | ||
49 | =================================================================== | ||
50 | --- icedtea-2.3.12.orig/javac.in 2013-07-24 21:33:57.224612327 +0000 | ||
51 | +++ icedtea-2.3.12/javac.in 2013-07-30 19:41:56.240277496 +0000 | ||
52 | @@ -77,5 +77,7 @@ | ||
53 | my @CLASSPATH = ('@ECJ_JAR@'); | ||
54 | push @CLASSPATH, split /:/, $ENV{"CLASSPATH"} if exists $ENV{"CLASSPATH"}; | ||
55 | $ENV{"CLASSPATH"} = join ':', @CLASSPATH; | ||
56 | - exec '@JAVA@', 'org.eclipse.jdt.internal.compiler.batch.Main', @ecj_parms, @ecj_args; | ||
57 | + # Compiling hotspot-tools consumes tons of memory and exceeds any default | ||
58 | + # limits for jamvm and cacao. | ||
59 | + exec '@JAVA@', '-Xmx1024m', 'org.eclipse.jdt.internal.compiler.batch.Main', @ecj_parms, @ecj_args; | ||
60 | } | ||