diff options
Diffstat (limited to 'recipes-core/openjdk/openjdk-7-75b13/icedtea-jdk-nio-use-host-cc.patch')
-rw-r--r-- | recipes-core/openjdk/openjdk-7-75b13/icedtea-jdk-nio-use-host-cc.patch | 74 |
1 files changed, 74 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-7-75b13/icedtea-jdk-nio-use-host-cc.patch b/recipes-core/openjdk/openjdk-7-75b13/icedtea-jdk-nio-use-host-cc.patch new file mode 100644 index 0000000..f966093 --- /dev/null +++ b/recipes-core/openjdk/openjdk-7-75b13/icedtea-jdk-nio-use-host-cc.patch | |||
@@ -0,0 +1,74 @@ | |||
1 | Index: openjdk/jdk/make/java/nio/Makefile | ||
2 | =================================================================== | ||
3 | --- openjdk/jdk/make/java/nio/Makefile 2013-10-01 21:20:11.000000000 -0700 | ||
4 | +++ openjdk/jdk/make/java/nio/Makefile 2013-10-01 21:30:40.901837422 -0700 | ||
5 | @@ -918,7 +918,7 @@ | ||
6 | ifeq ($(PLATFORM), macosx) | ||
7 | NIO_CC=$(HOST_CC) | ||
8 | else | ||
9 | - NIO_CC=$(CC) | ||
10 | + NIO_CC=$(CC_FOR_BUILD) | ||
11 | endif | ||
12 | |||
13 | $(GENSOR_EXE) : $(TEMPDIR)/$(GENSOR_SRC) | ||
14 | @@ -934,12 +934,8 @@ | ||
15 | $(SCH_GEN)/SocketOptionRegistry.java: $(GENSOR_EXE) | ||
16 | $(prep-target) | ||
17 | NAWK="$(NAWK)" SH="$(SH)" $(SH) -e addNotices.sh "$(SOR_COPYRIGHT_YEARS)" > $@ | ||
18 | -ifdef CROSS_COMPILE_ARCH | ||
19 | - $(QEMU) $(GENSOR_EXE) >> $@ | ||
20 | -else | ||
21 | $(GENSOR_EXE) >> $@ | ||
22 | endif | ||
23 | -endif | ||
24 | # | ||
25 | # Generated sun.nio.cs SingleByte classes | ||
26 | # | ||
27 | @@ -973,12 +969,8 @@ | ||
28 | $(SFS_GEN)/UnixConstants.java: $(GENUC_EXE) | ||
29 | $(prep-target) | ||
30 | NAWK="$(NAWK)" SH="$(SH)" $(SH) -e addNotices.sh "$(GENUC_COPYRIGHT_YEARS)" > $@ | ||
31 | -ifdef CROSS_COMPILE_ARCH | ||
32 | - $(QEMU) $(GENUC_EXE) >> $@ | ||
33 | -else | ||
34 | $(GENUC_EXE) >> $@ | ||
35 | endif | ||
36 | -endif | ||
37 | |||
38 | GENSC_SRC = $(PLATFORM_SRC)/native/sun/nio/fs/genSolarisConstants.c | ||
39 | |||
40 | @@ -999,11 +991,7 @@ | ||
41 | $(SFS_GEN)/SolarisConstants.java: $(GENSC_EXE) | ||
42 | $(prep-target) | ||
43 | NAWK="$(NAWK)" SH="$(SH)" $(SH) -e addNotices.sh "$(GENSC_COPYRIGHT_YEARS)" > $@ | ||
44 | -ifdef CROSS_COMPILE_ARCH | ||
45 | - $(QEMU) $(GENSC_EXE) >> $@ | ||
46 | -else | ||
47 | $(GENSC_EXE) >> $@ | ||
48 | endif | ||
49 | -endif | ||
50 | |||
51 | .PHONY: sources | ||
52 | Index: openjdk/jdk/make/sun/Makefile | ||
53 | =================================================================== | ||
54 | --- openjdk/jdk/make/sun/Makefile 2013-07-25 09:10:09.000000000 -0700 | ||
55 | +++ openjdk/jdk/make/sun/Makefile 2013-10-01 21:32:01.625839149 -0700 | ||
56 | @@ -55,7 +55,7 @@ | ||
57 | endif | ||
58 | endif | ||
59 | HEADLESS_SUBDIR = headless | ||
60 | - XAWT_SUBDIR = xawt gtk | ||
61 | + XAWT_SUBDIR = | ||
62 | endif | ||
63 | |||
64 | ifeq ($(PLATFORM), macosx) | ||
65 | @@ -87,7 +87,7 @@ | ||
66 | endif | ||
67 | SUBDIRS_desktop = audio $(RENDER_SUBDIR) image \ | ||
68 | $(LWAWT_PRE_SUBDIR) $(DISPLAY_LIBS) $(DGA_SUBDIR) $(LWAWT_SUBDIR) \ | ||
69 | - jawt font jpeg cmm $(DISPLAY_TOOLS) beans | ||
70 | + font jpeg cmm $(DISPLAY_TOOLS) beans | ||
71 | SUBDIRS_management = management | ||
72 | SUBDIRS_misc = $(ORG_SUBDIR) rmi $(JDBC_SUBDIR) tracing | ||
73 | SUBDIRS_tools = native2ascii serialver tools jconsole | ||
74 | \ No newline at end of file | ||