diff options
author | Tudor Florea <tudor.florea@enea.com> | 2015-10-08 22:46:13 +0200 |
---|---|---|
committer | Tudor Florea <tudor.florea@enea.com> | 2015-10-08 22:46:13 +0200 |
commit | 8d89651ef729e560ad96dcfc002fcde6ff7f923b (patch) | |
tree | eb5be01c25f735d12fe9881ee6327c9b7e8bbe39 /meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.9/0031-Disable-sdt.patch | |
download | meta-linaro-dizzy-enea.tar.gz |
initial commit for Enea Linux 5.0 armdizzy-enea
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.9/0031-Disable-sdt.patch')
-rw-r--r-- | meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.9/0031-Disable-sdt.patch | 113 |
1 files changed, 113 insertions, 0 deletions
diff --git a/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.9/0031-Disable-sdt.patch b/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.9/0031-Disable-sdt.patch new file mode 100644 index 0000000..2c1d5e0 --- /dev/null +++ b/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.9/0031-Disable-sdt.patch | |||
@@ -0,0 +1,113 @@ | |||
1 | From b85265bc94ec1beaf1d3b697c03db62991553467 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 29 Mar 2013 09:28:10 +0400 | ||
4 | Subject: [PATCH 31/35] Disable sdt. | ||
5 | |||
6 | We don't list dtrace in DEPENDS so we shouldn't be depending on this header. | ||
7 | It may or may not exist from preivous builds though. To be determinstic, disable | ||
8 | sdt.h usage always. This avoids build failures if the header is removed after configure | ||
9 | but before libgcc is compiled for example. | ||
10 | |||
11 | RP 2012/8/7 | ||
12 | |||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | |||
15 | Disable sdt for libstdc++-v3. | ||
16 | |||
17 | Signed-off-by: Robert Yang <liezhi.yang@windriver.com> | ||
18 | |||
19 | Upstream-Status: Inappropriate [hack] | ||
20 | --- | ||
21 | gcc/configure | 12 ++++++------ | ||
22 | gcc/configure.ac | 18 +++++++++--------- | ||
23 | libstdc++-v3/configure | 6 +++--- | ||
24 | libstdc++-v3/configure.ac | 2 +- | ||
25 | 4 files changed, 19 insertions(+), 19 deletions(-) | ||
26 | |||
27 | diff --git a/gcc/configure b/gcc/configure | ||
28 | index 3c550a6..01c7626 100755 | ||
29 | --- a/gcc/configure | ||
30 | +++ b/gcc/configure | ||
31 | @@ -26812,12 +26812,12 @@ fi | ||
32 | { $as_echo "$as_me:${as_lineno-$LINENO}: checking sys/sdt.h in the target C library" >&5 | ||
33 | $as_echo_n "checking sys/sdt.h in the target C library... " >&6; } | ||
34 | have_sys_sdt_h=no | ||
35 | -if test -f $target_header_dir/sys/sdt.h; then | ||
36 | - have_sys_sdt_h=yes | ||
37 | - | ||
38 | -$as_echo "#define HAVE_SYS_SDT_H 1" >>confdefs.h | ||
39 | - | ||
40 | -fi | ||
41 | +#if test -f $target_header_dir/sys/sdt.h; then | ||
42 | +# have_sys_sdt_h=yes | ||
43 | +# | ||
44 | +#$as_echo "#define HAVE_SYS_SDT_H 1" >>confdefs.h | ||
45 | +# | ||
46 | +#fi | ||
47 | { $as_echo "$as_me:${as_lineno-$LINENO}: result: $have_sys_sdt_h" >&5 | ||
48 | $as_echo "$have_sys_sdt_h" >&6; } | ||
49 | |||
50 | diff --git a/gcc/configure.ac b/gcc/configure.ac | ||
51 | index 3601ab6..06e501f 100644 | ||
52 | --- a/gcc/configure.ac | ||
53 | +++ b/gcc/configure.ac | ||
54 | @@ -4779,15 +4779,15 @@ if test x$gcc_cv_libc_provides_ssp = xyes; then | ||
55 | fi | ||
56 | |||
57 | # Test for <sys/sdt.h> on the target. | ||
58 | -GCC_TARGET_TEMPLATE([HAVE_SYS_SDT_H]) | ||
59 | -AC_MSG_CHECKING(sys/sdt.h in the target C library) | ||
60 | -have_sys_sdt_h=no | ||
61 | -if test -f $target_header_dir/sys/sdt.h; then | ||
62 | - have_sys_sdt_h=yes | ||
63 | - AC_DEFINE(HAVE_SYS_SDT_H, 1, | ||
64 | - [Define if your target C library provides sys/sdt.h]) | ||
65 | -fi | ||
66 | -AC_MSG_RESULT($have_sys_sdt_h) | ||
67 | +#GCC_TARGET_TEMPLATE([HAVE_SYS_SDT_H]) | ||
68 | +#AC_MSG_CHECKING(sys/sdt.h in the target C library) | ||
69 | +#have_sys_sdt_h=no | ||
70 | +#if test -f $target_header_dir/sys/sdt.h; then | ||
71 | +# have_sys_sdt_h=yes | ||
72 | +# AC_DEFINE(HAVE_SYS_SDT_H, 1, | ||
73 | +# [Define if your target C library provides sys/sdt.h]) | ||
74 | +#fi | ||
75 | +#AC_MSG_RESULT($have_sys_sdt_h) | ||
76 | |||
77 | # Check if TFmode long double should be used by default or not. | ||
78 | # Some glibc targets used DFmode long double, but with glibc 2.4 | ||
79 | diff --git a/libstdc++-v3/configure b/libstdc++-v3/configure | ||
80 | index 4953c9f..53a1145 100755 | ||
81 | --- a/libstdc++-v3/configure | ||
82 | +++ b/libstdc++-v3/configure | ||
83 | @@ -20578,11 +20578,11 @@ ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5' | ||
84 | ac_link='$CC -o conftest$ac_exeext $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5' | ||
85 | ac_compiler_gnu=$ac_cv_c_compiler_gnu | ||
86 | |||
87 | - if test $glibcxx_cv_sys_sdt_h = yes; then | ||
88 | +# if test $glibcxx_cv_sys_sdt_h = yes; then | ||
89 | |||
90 | -$as_echo "#define HAVE_SYS_SDT_H 1" >>confdefs.h | ||
91 | +#$as_echo "#define HAVE_SYS_SDT_H 1" >>confdefs.h | ||
92 | |||
93 | - fi | ||
94 | +# fi | ||
95 | { $as_echo "$as_me:${as_lineno-$LINENO}: result: $glibcxx_cv_sys_sdt_h" >&5 | ||
96 | $as_echo "$glibcxx_cv_sys_sdt_h" >&6; } | ||
97 | |||
98 | diff --git a/libstdc++-v3/configure.ac b/libstdc++-v3/configure.ac | ||
99 | index 73d430a..f2135e2 100644 | ||
100 | --- a/libstdc++-v3/configure.ac | ||
101 | +++ b/libstdc++-v3/configure.ac | ||
102 | @@ -211,7 +211,7 @@ GLIBCXX_CHECK_SC_NPROCESSORS_ONLN | ||
103 | GLIBCXX_CHECK_SC_NPROC_ONLN | ||
104 | GLIBCXX_CHECK_PTHREADS_NUM_PROCESSORS_NP | ||
105 | GLIBCXX_CHECK_SYSCTL_HW_NCPU | ||
106 | -GLIBCXX_CHECK_SDT_H | ||
107 | +#GLIBCXX_CHECK_SDT_H | ||
108 | |||
109 | # Check for available headers. | ||
110 | AC_CHECK_HEADERS([endian.h execinfo.h float.h fp.h ieeefp.h inttypes.h \ | ||
111 | -- | ||
112 | 1.8.3.1 | ||
113 | |||