diff options
author | Tudor Florea <tudor.florea@enea.com> | 2015-10-08 22:46:13 +0200 |
---|---|---|
committer | Tudor Florea <tudor.florea@enea.com> | 2015-10-08 22:46:13 +0200 |
commit | 8d89651ef729e560ad96dcfc002fcde6ff7f923b (patch) | |
tree | eb5be01c25f735d12fe9881ee6327c9b7e8bbe39 /meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.9/0046-libatomic-deptracking.patch | |
download | meta-linaro-dizzy-enea.tar.gz |
initial commit for Enea Linux 5.0 armdizzy-enea
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.9/0046-libatomic-deptracking.patch')
-rw-r--r-- | meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.9/0046-libatomic-deptracking.patch | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.9/0046-libatomic-deptracking.patch b/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.9/0046-libatomic-deptracking.patch new file mode 100644 index 0000000..6ea4f42 --- /dev/null +++ b/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.9/0046-libatomic-deptracking.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | gcc 4.8 won't build with --disable-dependency-tracking since the *.Ppo files | ||
2 | don't get created unless --enable-dependency-tracking is true. | ||
3 | |||
4 | This patch ensures we only use those compiler options when its enabled. | ||
5 | |||
6 | Upstream-Status: Submitted | ||
7 | |||
8 | (Problem was already reported upstream, attached this patch there | ||
9 | http://gcc.gnu.org/bugzilla/show_bug.cgi?id=55930) | ||
10 | |||
11 | RP | ||
12 | 2012/09/22 | ||
13 | |||
14 | Index: gcc-4.8.1/libatomic/Makefile.am | ||
15 | =================================================================== | ||
16 | --- gcc-4.8.1.orig/libatomic/Makefile.am 2013-01-14 18:16:23.000000000 +0000 | ||
17 | +++ gcc-4.8.1/libatomic/Makefile.am 2013-09-22 10:38:18.904064750 +0000 | ||
18 | @@ -100,7 +100,8 @@ | ||
19 | IFUNC_DEF = -DIFUNC_ALT=$(PAT_S) | ||
20 | IFUNC_OPT = $(word $(PAT_S),$(IFUNC_OPTIONS)) | ||
21 | |||
22 | -M_DEPS = -MT $@ -MD -MP -MF $(DEPDIR)/$(@F).Ppo | ||
23 | +@AMDEP_TRUE@M_DEPS = -MT $@ -MD -MP -MF $(DEPDIR)/$(@F).Ppo | ||
24 | +@AMDEP_FALSE@M_DEPS = | ||
25 | M_SIZE = -DN=$(PAT_N) | ||
26 | M_IFUNC = $(if $(PAT_S),$(IFUNC_DEF) $(IFUNC_OPT)) | ||
27 | M_FILE = $(PAT_BASE)_n.c | ||
28 | Index: gcc-4.8.1/libatomic/Makefile.in | ||
29 | =================================================================== | ||
30 | --- gcc-4.8.1.orig/libatomic/Makefile.in 2013-05-31 09:09:26.000000000 +0000 | ||
31 | +++ gcc-4.8.1/libatomic/Makefile.in 2013-09-22 10:40:42.520059917 +0000 | ||
32 | @@ -298,7 +298,8 @@ | ||
33 | PAT_S = $(word 3,$(PAT_SPLIT)) | ||
34 | IFUNC_DEF = -DIFUNC_ALT=$(PAT_S) | ||
35 | IFUNC_OPT = $(word $(PAT_S),$(IFUNC_OPTIONS)) | ||
36 | -M_DEPS = -MT $@ -MD -MP -MF $(DEPDIR)/$(@F).Ppo | ||
37 | +@AMDEP_TRUE@M_DEPS = -MT $@ -MD -MP -MF $(DEPDIR)/$(@F).Ppo | ||
38 | +@AMDEP_FALSE@M_DEPS = | ||
39 | M_SIZE = -DN=$(PAT_N) | ||
40 | M_IFUNC = $(if $(PAT_S),$(IFUNC_DEF) $(IFUNC_OPT)) | ||
41 | M_FILE = $(PAT_BASE)_n.c | ||