summaryrefslogtreecommitdiffstats
path: root/meta-linaro/recipes-linaro/files-injection
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:46:13 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:46:13 +0200
commit8d89651ef729e560ad96dcfc002fcde6ff7f923b (patch)
treeeb5be01c25f735d12fe9881ee6327c9b7e8bbe39 /meta-linaro/recipes-linaro/files-injection
downloadmeta-linaro-dizzy-enea.tar.gz
initial commit for Enea Linux 5.0 armdizzy-enea
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-linaro/recipes-linaro/files-injection')
-rw-r--r--meta-linaro/recipes-linaro/files-injection/files-injection.bb22
-rw-r--r--meta-linaro/recipes-linaro/files-injection/files/files-to-inject.tar.xzbin0 -> 196 bytes
-rw-r--r--meta-linaro/recipes-linaro/files-injection/files/files-to-inject/empty0
3 files changed, 22 insertions, 0 deletions
diff --git a/meta-linaro/recipes-linaro/files-injection/files-injection.bb b/meta-linaro/recipes-linaro/files-injection/files-injection.bb
new file mode 100644
index 0000000..de4677b
--- /dev/null
+++ b/meta-linaro/recipes-linaro/files-injection/files-injection.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Random files to be injected into rootfs"
2LICENSE = "CLOSED"
3
4SRC_URI = "file://files-to-inject.tar.xz"
5
6S = "${WORKDIR}/files-to-inject/"
7
8# all files will be put in /opt/ directory with keeping tarball structure
9
10do_install() {
11 install -d ${D}/opt/
12 cp -a ${S} ${D}/opt/
13}
14
15FILES_${PN} = "/opt"
16
17# How to use it?
18#
19# unpack files/files-to-inject.tar.xz tarball, add own files, compress it.
20# add "files-injection" into CORE_IMAGE_EXTRA_INSTALL in your build/conf/local.conf
21# build rootfs
22#
diff --git a/meta-linaro/recipes-linaro/files-injection/files/files-to-inject.tar.xz b/meta-linaro/recipes-linaro/files-injection/files/files-to-inject.tar.xz
new file mode 100644
index 0000000..50e169d
--- /dev/null
+++ b/meta-linaro/recipes-linaro/files-injection/files/files-to-inject.tar.xz
Binary files differ
diff --git a/meta-linaro/recipes-linaro/files-injection/files/files-to-inject/empty b/meta-linaro/recipes-linaro/files-injection/files/files-to-inject/empty
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/meta-linaro/recipes-linaro/files-injection/files/files-to-inject/empty