diff options
author | Tudor Florea <tudor.florea@enea.com> | 2015-10-08 22:46:13 +0200 |
---|---|---|
committer | Tudor Florea <tudor.florea@enea.com> | 2015-10-08 22:46:13 +0200 |
commit | 8d89651ef729e560ad96dcfc002fcde6ff7f923b (patch) | |
tree | eb5be01c25f735d12fe9881ee6327c9b7e8bbe39 /meta-linaro/recipes-linaro/linaro-lava-tests | |
download | meta-linaro-dizzy-enea.tar.gz |
initial commit for Enea Linux 5.0 armdizzy-enea
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-linaro/recipes-linaro/linaro-lava-tests')
6 files changed, 71 insertions, 0 deletions
diff --git a/meta-linaro/recipes-linaro/linaro-lava-tests/files/LICENSE b/meta-linaro/recipes-linaro/linaro-lava-tests/files/LICENSE new file mode 100644 index 0000000..296f7d6 --- /dev/null +++ b/meta-linaro/recipes-linaro/linaro-lava-tests/files/LICENSE | |||
@@ -0,0 +1,19 @@ | |||
1 | Copyright (C) 2012 Linaro Ltd. | ||
2 | |||
3 | Permission is hereby granted, free of charge, to any person obtaining a copy of | ||
4 | this software and associated documentation files (the "Software"), to deal in | ||
5 | the Software without restriction, including without limitation the rights to | ||
6 | use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies | ||
7 | of the Software, and to permit persons to whom the Software is furnished to do | ||
8 | so, subject to the following conditions: | ||
9 | |||
10 | The above copyright notice and this permission notice shall be included in all | ||
11 | copies or substantial portions of the Software. | ||
12 | |||
13 | THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR | ||
14 | IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, | ||
15 | FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE | ||
16 | AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER | ||
17 | LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, | ||
18 | OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE | ||
19 | SOFTWARE. | ||
diff --git a/meta-linaro/recipes-linaro/linaro-lava-tests/files/hello.c b/meta-linaro/recipes-linaro/linaro-lava-tests/files/hello.c new file mode 100644 index 0000000..247bbe7 --- /dev/null +++ b/meta-linaro/recipes-linaro/linaro-lava-tests/files/hello.c | |||
@@ -0,0 +1,8 @@ | |||
1 | #include <stdio.h> | ||
2 | |||
3 | int main(void) | ||
4 | { | ||
5 | printf ("hello world\n"); | ||
6 | |||
7 | return 0; | ||
8 | } | ||
diff --git a/meta-linaro/recipes-linaro/linaro-lava-tests/files/hello.cc b/meta-linaro/recipes-linaro/linaro-lava-tests/files/hello.cc new file mode 100644 index 0000000..c0b335d --- /dev/null +++ b/meta-linaro/recipes-linaro/linaro-lava-tests/files/hello.cc | |||
@@ -0,0 +1,8 @@ | |||
1 | #include <iostream> | ||
2 | |||
3 | int main(void) | ||
4 | { | ||
5 | std::cout << "hello world" << std::endl; | ||
6 | |||
7 | return 0; | ||
8 | } | ||
diff --git a/meta-linaro/recipes-linaro/linaro-lava-tests/files/info.php b/meta-linaro/recipes-linaro/linaro-lava-tests/files/info.php new file mode 100644 index 0000000..554a22c --- /dev/null +++ b/meta-linaro/recipes-linaro/linaro-lava-tests/files/info.php | |||
@@ -0,0 +1,5 @@ | |||
1 | <?php | ||
2 | |||
3 | phpinfo(); | ||
4 | |||
5 | ?> | ||
diff --git a/meta-linaro/recipes-linaro/linaro-lava-tests/files/mysql.php b/meta-linaro/recipes-linaro/linaro-lava-tests/files/mysql.php new file mode 100644 index 0000000..258b184 --- /dev/null +++ b/meta-linaro/recipes-linaro/linaro-lava-tests/files/mysql.php | |||
@@ -0,0 +1,9 @@ | |||
1 | <?php | ||
2 | |||
3 | $link = mysql_connect('localhost', 'root', ''); | ||
4 | if (!$link) { | ||
5 | die('MySQL error: ' . mysql_error()); | ||
6 | } | ||
7 | echo 'Connected with MySQL'; | ||
8 | mysql_close($link); | ||
9 | ?> | ||
diff --git a/meta-linaro/recipes-linaro/linaro-lava-tests/linaro-lava-tests.bb b/meta-linaro/recipes-linaro/linaro-lava-tests/linaro-lava-tests.bb new file mode 100644 index 0000000..389d2ff --- /dev/null +++ b/meta-linaro/recipes-linaro/linaro-lava-tests/linaro-lava-tests.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | DESCRIPTION = "Scripts and files for LAVA tests" | ||
2 | LICENSE = "Expat" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3725c2bb543d06ff759f9db9b5d986ac" | ||
4 | PR = "r2" | ||
5 | |||
6 | SRC_URI = "\ | ||
7 | file://hello.c \ | ||
8 | file://hello.cc \ | ||
9 | file://info.php \ | ||
10 | file://mysql.php \ | ||
11 | file://LICENSE \ | ||
12 | " | ||
13 | |||
14 | S = "${WORKDIR}" | ||
15 | |||
16 | do_install() { | ||
17 | install -d ${D}/home/root ${D}/usr/share/apache2/htdocs/ | ||
18 | install -m 0644 hello.* ${D}/home/root/ | ||
19 | install -m 0644 *.php ${D}/usr/share/apache2/htdocs/ | ||
20 | } | ||
21 | |||
22 | FILES_${PN} = "/" | ||