diff options
Diffstat (limited to 'meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0038-gcc-4.8-build-args.patch')
-rw-r--r-- | meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0038-gcc-4.8-build-args.patch | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0038-gcc-4.8-build-args.patch b/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0038-gcc-4.8-build-args.patch new file mode 100644 index 0000000..c27e009 --- /dev/null +++ b/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0038-gcc-4.8-build-args.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | When cross compiling a target gcc, target flags may be used on the host | ||
2 | |||
3 | Configure identifies a number of warning flags (WARN_CFLAGS and | ||
4 | WARN_CXXFLAGS) from the $CC value. The cross compiler may be different | ||
5 | from the host compiler and may not support the same set of flags. This | ||
6 | leads to problems such as: | ||
7 | |||
8 | cc1plus: error: unrecognized command line option "-Wno-narrowing" | ||
9 | cc1plus: error: unrecognized command line option "-Wno-overlength-strings" | ||
10 | |||
11 | Work around this problem by removing the warning flags from the | ||
12 | BUILD_CXXFLAGS value, in a way similar to the BUILD_CFLAGS. | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | |||
16 | Signed-off-by: Mark Hatle <mark.hatle@windriver.com> | ||
17 | |||
18 | Index: gcc-4.8.0/gcc/configure | ||
19 | =================================================================== | ||
20 | --- gcc-4.8.0.orig/gcc/configure | ||
21 | +++ gcc-4.8.0/gcc/configure | ||
22 | @@ -11720,6 +10581,7 @@ STMP_FIXINC=stmp-fixinc | ||
23 | if test x$build != x$host || test "x$coverage_flags" != x | ||
24 | then | ||
25 | BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)' | ||
26 | + BUILD_CXXFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)' | ||
27 | BUILD_LDFLAGS='$(LDFLAGS_FOR_BUILD)' | ||
28 | fi | ||
29 | |||
30 | Index: gcc-4.8.0/gcc/configure.ac | ||
31 | =================================================================== | ||
32 | --- gcc-4.8.0.orig/gcc/configure.ac | ||
33 | +++ gcc-4.8.0/gcc/configure.ac | ||
34 | @@ -1901,6 +1901,7 @@ STMP_FIXINC=stmp-fixinc AC_SUBST(STMP_F | ||
35 | if test x$build != x$host || test "x$coverage_flags" != x | ||
36 | then | ||
37 | BUILD_CFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)' | ||
38 | + BUILD_CXXFLAGS='$(INTERNAL_CFLAGS) $(T_CFLAGS) $(CFLAGS_FOR_BUILD)' | ||
39 | BUILD_LDFLAGS='$(LDFLAGS_FOR_BUILD)' | ||
40 | fi | ||
41 | |||