diff options
Diffstat (limited to 'meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0040-fix-g++-sysroot.patch')
-rw-r--r-- | meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0040-fix-g++-sysroot.patch | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0040-fix-g++-sysroot.patch b/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0040-fix-g++-sysroot.patch new file mode 100644 index 0000000..d50aa5c --- /dev/null +++ b/meta-linaro-toolchain/recipes-devtools/gcc/gcc-linaro-4.8/0040-fix-g++-sysroot.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | Portions of | ||
2 | |||
3 | http://www.mail-archive.com/gcc-patches@gcc.gnu.org/msg26013.html | ||
4 | |||
5 | are not upstreamed yet. So lets keep missing pieces. | ||
6 | |||
7 | Upstream-Status: Pending | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | |||
11 | Index: gcc-4.8.1/gcc/configure.ac | ||
12 | =================================================================== | ||
13 | --- gcc-4.8.1.orig/gcc/configure.ac 2013-07-15 15:55:49.488399132 -0700 | ||
14 | +++ gcc-4.8.1/gcc/configure.ac 2013-07-15 16:02:31.772406679 -0700 | ||
15 | @@ -148,7 +148,9 @@ | ||
16 | if test "${with_sysroot+set}" = set; then | ||
17 | gcc_gxx_without_sysroot=`expr "${gcc_gxx_include_dir}" : "${with_sysroot}"'\(.*\)'` | ||
18 | if test "${gcc_gxx_without_sysroot}"; then | ||
19 | - gcc_gxx_include_dir="${gcc_gxx_without_sysroot}" | ||
20 | + if test x${with_sysroot} != x/; then | ||
21 | + gcc_gxx_include_dir="${gcc_gxx_without_sysroot}" | ||
22 | + fi | ||
23 | gcc_gxx_include_dir_add_sysroot=1 | ||
24 | fi | ||
25 | fi | ||
26 | Index: gcc-4.8.1/gcc/configure | ||
27 | =================================================================== | ||
28 | --- gcc-4.8.1.orig/gcc/configure 2013-07-15 15:55:49.472399132 -0700 | ||
29 | +++ gcc-4.8.1/gcc/configure 2013-07-15 16:02:31.780406680 -0700 | ||
30 | @@ -3325,7 +3325,9 @@ | ||
31 | if test "${with_sysroot+set}" = set; then | ||
32 | gcc_gxx_without_sysroot=`expr "${gcc_gxx_include_dir}" : "${with_sysroot}"'\(.*\)'` | ||
33 | if test "${gcc_gxx_without_sysroot}"; then | ||
34 | - gcc_gxx_include_dir="${gcc_gxx_without_sysroot}" | ||
35 | + if test x${with_sysroot} != x/; then | ||
36 | + gcc_gxx_include_dir="${gcc_gxx_without_sysroot}" | ||
37 | + fi | ||
38 | gcc_gxx_include_dir_add_sysroot=1 | ||
39 | fi | ||
40 | fi | ||